comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Kali linux y Vmware

  • 13 Respuestas
  • 2532 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado salem

  • *
  • Underc0der
  • Mensajes: 45
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« en: Febrero 23, 2016, 04:40:53 pm »
Buenas hace tiempo que no entro he instalado kali linux en una maquina virtual con mware y no puedo tener internet en bridge pero si en nat alguna solucion gracias a todos
« Última modificación: Febrero 27, 2016, 12:37:30 pm por rollth »

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #1 en: Febrero 23, 2016, 06:37:25 pm »
Buenas @You are not allowed to view links. Register or Login

Prueba de configurarlo así:


Desconectado salem

  • *
  • Underc0der
  • Mensajes: 45
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #2 en: Febrero 26, 2016, 04:08:21 pm »
sigo sin tener en modo bridge

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #3 en: Febrero 27, 2016, 06:19:20 am »
Configura entonces el archivo /network/interfaces con dirección IP estática, pero primero haz un ipconfig o ifconfig de tu maquina física para ver en que rango de IPs estás.


Un saludo

Desconectado salem

  • *
  • Underc0der
  • Mensajes: 45
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #4 en: Febrero 27, 2016, 07:20:32 am »
en modo nat va genial pero a la hora de ponerlo bridge nada no tengo internet sera el av o el firewall de windows o algo que impide conectarse en modo bridge a mi maquina virtual?

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #5 en: Febrero 27, 2016, 07:50:50 am »
You are not allowed to view links. Register or Login
en modo nat va genial pero a la hora de ponerlo bridge nada no tengo internet sera el av o el firewall de windows o algo que impide conectarse en modo bridge a mi maquina virtual?

Como te he dicho anteriormente, es porque Kali no te está asignando una dirección IP por DHCP, por lo tanto vas a tener que modificarlo en el archivo network/interfaces.

Un saludo

Desconectado salem

  • *
  • Underc0der
  • Mensajes: 45
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #6 en: Febrero 27, 2016, 08:44:48 am »
perdonad mi ignorancia como se modifica? soy un poco novato

Desconectado blackdrake

  • *
  • Co Admin
  • Mensajes: 1904
  • Actividad:
    18.33%
  • Reputación 15
    • Ver Perfil
« Respuesta #7 en: Febrero 27, 2016, 08:57:15 am »
You are not allowed to view links. Register or Login
perdonad mi ignorancia como se modifica? soy un poco novato

Código: Bash
  1. sudo nano /etc/network/interfaces

Y lo configuras como quieras/sea (ejemplo)


Código: You are not allowed to view links. Register or Login
iface eth0 inet static
 #your static IP
 address 192.168.1.118 
 #your gateway IP
 gateway 192.168.1.1
 netmask 255.255.255.0
 #your network address "family"
 network 192.168.1.0
 broadcast 192.168.1.255

Saludos.
« Última modificación: Febrero 27, 2016, 12:35:58 pm por blackdrake »



Desconectado salem

  • *
  • Underc0der
  • Mensajes: 45
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #8 en: Febrero 27, 2016, 09:41:49 am »
he echo lo que me dices pero sigue igual lo raro que me da ip en bridge y puedo hacer ping en mi gateway y todo pero no tengo conexion a internet no puedo navegar

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #9 en: Febrero 27, 2016, 09:59:14 am »
Una vez configurada las interfaces tienes que realizar un restart o bien levantar la Red.

Stop interface eth0:
Código: You are not allowed to view links. Register or Login
ifdown eth0
Start network interface eth0:
Código: You are not allowed to view links. Register or Login
ifup eth0
Restart networks services :
Código: You are not allowed to view links. Register or Login
/etc/init.d/networking restart

Desconectado salem

  • *
  • Underc0der
  • Mensajes: 45
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #10 en: Febrero 27, 2016, 04:53:10 pm »
sigo con el mismo problema ya tengo la ip que me asigna el router pero hago ping y todo al router y me contesta pero sigo sin tener acceso a internet

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #11 en: Febrero 27, 2016, 05:06:08 pm »
¿Configuraste el gateway?

gateway 192.168.1.1

Desconectado salem

  • *
  • Underc0der
  • Mensajes: 45
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #12 en: Febrero 27, 2016, 05:36:43 pm »
como es que soy un poco novato lo siento

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #13 en: Febrero 27, 2016, 06:26:10 pm »
You are not allowed to view links. Register or Login
como es que soy un poco novato lo siento

En el archivo network/interfaces debes agregar la línea "gateway 192.168.1.1".

Saludos

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 2473
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Debian o Linux mint debian edition

Iniciado por Krapermors

Respuestas: 3
Vistas: 1376
Último mensaje Agosto 12, 2013, 08:36:54 am
por Sanko
¿Alguien me podría explicar sobre "Character Device Files" en linux?

Iniciado por proxy_lainux

Respuestas: 2
Vistas: 1226
Último mensaje Mayo 07, 2016, 12:23:06 pm
por proxy_lainux
[SOLUCIONADO] ¿Sirve para pentesting "Huayra GNU/Linux 2.0"?

Iniciado por Doblez

Respuestas: 2
Vistas: 1125
Último mensaje Mayo 13, 2016, 08:44:59 pm
por Doblez
DUDA: Error al instalar LAMP en Linux Mint (Sonya) Cinnamon bajo Virtual Box

Iniciado por fleshworm

Respuestas: 1
Vistas: 847
Último mensaje Agosto 26, 2017, 08:49:11 am
por fleshworm