comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Error con SET kali linux

  • 5 Respuestas
  • 1750 Vistas

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado zupa

  • *
  • Underc0der
  • Mensajes: 60
  • Actividad:
    0%
  • Reputación 0
  • Hacktivism is life
    • Ver Perfil
« en: Agosto 29, 2015, 04:41:48 pm »
Buenas!

Estoy teniendo problemas con SET (Social Engineering Toolkit) sigo los pasos tradicionales para generar el payload y todo eso y va bien hasta que trata de acceder al metasploit.

Me parece el siguente error:



Quiero corregir este problema o saber exactamente la ruta de donde esta el toolkit para verificar si falta algo por configurar.

Un saludo
« Última modificación: Agosto 29, 2015, 04:57:58 pm por Gabriela »

Desconectado blackdrake

  • *
  • Co Admin
  • Mensajes: 1914
  • Actividad:
    0%
  • Reputación 15
    • Ver Perfil
« Respuesta #1 en: Septiembre 01, 2015, 03:27:35 am »
Prueba si se soluciona al actualizar metasploit.

Saludos.



Desconectado rand0m

  • *
  • Underc0der
  • Mensajes: 214
  • Actividad:
    0%
  • Reputación 0
  • Paso de cosas personales, déjame
    • Ver Perfil
« Respuesta #2 en: Septiembre 01, 2015, 07:16:12 am »
He probado yo y me he encontrado con lo mismo que tú.
Código: [Seleccionar]
       =[ metasploit v4.11.4-2015071403                   ]
+ -- --=[ 1467 exploits - 840 auxiliary - 232 post        ]
+ -- --=[ 432 payloads - 37 encoders - 8 nops             ]
+ -- --=[ Free Metasploit Pro trial: http://r-7.co/trymsp ]

[-] Cannot find resource script: /root/.set/meta_config
Pero sin embargo sí que existe el archivo.
Código: [Seleccionar]
root@KaliSana:~/.set# cat /root/.set/meta_config
use multi/handler
set payload windows/shell_reverse_tcp
set LHOST 192.168.1.241
set LPORT 9191
set ExitOnSession false
exploit -j
No tengo ni idea de por qué metasploit no consigue acceder al archivo.
Prueba si se soluciona al actualizar metasploit.
No, metasploit está en su última versión.
Código: [Seleccionar]
root@KaliSana:~/.set# apt-get update && apt-get dist-upgrade -y && apt-get upgrade -y
Hit http://http.kali.org sana InRelease       
Hit http://security.kali.org sana/updates InRelease                   
Hit http://http.kali.org sana/main Sources       
Hit http://security.kali.org sana/updates/main Sources                                                 
Hit http://http.kali.org sana/non-free Sources                                                             
Hit http://security.kali.org sana/updates/contrib Sources                                                 
Hit http://http.kali.org sana/contrib Sources                                                             
Hit http://security.kali.org sana/updates/non-free Sources                                                 
Hit http://http.kali.org sana/main i386 Packages                                     
Hit http://security.kali.org sana/updates/main i386 Packages                                               
Hit http://http.kali.org sana/non-free i386 Packages                                                       
Hit http://security.kali.org sana/updates/contrib i386 Packages                                           
Hit http://http.kali.org sana/contrib i386 Packages                                                       
Hit http://security.kali.org sana/updates/non-free i386 Packages                                           
Ign http://http.kali.org sana/contrib Translation-en_US                                                   
Ign http://security.kali.org sana/updates/contrib Translation-en_US                                             
Ign http://http.kali.org sana/contrib Translation-en                                                             
Ign http://security.kali.org sana/updates/contrib Translation-en                                                 
Ign http://http.kali.org sana/main Translation-en_US                                                             
Ign http://security.kali.org sana/updates/main Translation-en_US                                                 
Ign http://http.kali.org sana/main Translation-en                                                               
Ign http://security.kali.org sana/updates/main Translation-en                                                   
Ign http://http.kali.org sana/non-free Translation-en_US                                                         
Ign http://security.kali.org sana/updates/non-free Translation-en_US                                             
Ign http://http.kali.org sana/non-free Translation-en                                                           
Ign http://security.kali.org sana/updates/non-free Translation-en                                               
Reading package lists... Done                                                                                   
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@KaliSana:~/.set# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]

[*] Checking for updates via the APT repository
[*] Note: expect weekly(ish) updates using this method
[*] No updates available
root@KaliSana:~/.set#
« Última modificación: Septiembre 01, 2015, 07:18:40 am por rand0m »
Podría vivir perfectamente con una mancha de pis en la alfombra, pero qué va, tío: Más complicaciones.

Desconectado MagoAstral

  • *
  • Underc0der
  • Mensajes: 115
  • Actividad:
    0%
  • Reputación 0
  • Nada resulta más engañoso que un hecho evidente.
    • Ver Perfil
« Respuesta #3 en: Septiembre 01, 2015, 09:12:21 am »
Parece un bug, en mi caso también tiene problema para cargar de forma automatizada el recurso, podéis ejecutarlo de forma manual:
Código: Bash
  1. resource /root/.set/meta_config

Saludos!
Lo que sabemos es una gota de agua; lo que ignoramos es el océano.

Desconectado rand0m

  • *
  • Underc0der
  • Mensajes: 214
  • Actividad:
    0%
  • Reputación 0
  • Paso de cosas personales, déjame
    • Ver Perfil
« Respuesta #4 en: Septiembre 01, 2015, 07:27:00 pm »
Parece un bug, en mi caso también tiene problema para cargar de forma automatizada el recurso
Y ya somos 3 de 3. Pero que bug más extraño, no entiendo a qué viene.
Podría vivir perfectamente con una mancha de pis en la alfombra, pero qué va, tío: Más complicaciones.

Desconectado zupa

  • *
  • Underc0der
  • Mensajes: 60
  • Actividad:
    0%
  • Reputación 0
  • Hacktivism is life
    • Ver Perfil
« Respuesta #5 en: Septiembre 02, 2015, 02:14:24 pm »
Todo esta actualizado, me parece que es un bug.

Pero estaba siguiendo un video y resulta que la persona le funciona correctamente, asi que algo tuvo que hacer pero no logro dar con dicha solucion.

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 3221
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Debian o Linux mint debian edition

Iniciado por Krapermors

Respuestas: 3
Vistas: 1589
Último mensaje Agosto 12, 2013, 08:36:54 am
por Sanko
¿Alguien me podría explicar sobre "Character Device Files" en linux?

Iniciado por proxy_lainux

Respuestas: 2
Vistas: 1442
Último mensaje Mayo 07, 2016, 12:23:06 pm
por proxy_lainux
[SOLUCIONADO] ¿Sirve para pentesting "Huayra GNU/Linux 2.0"?

Iniciado por Doblez

Respuestas: 2
Vistas: 1369
Último mensaje Mayo 13, 2016, 08:44:59 pm
por Doblez
[SOLUCIONADO] Xplico en kali "x86_64".

Iniciado por mortenol

Respuestas: 1
Vistas: 1379
Último mensaje Julio 02, 2013, 11:27:23 am
por Kodeinfect