comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Ayuda con apache en ubuntu server!

  • 12 Respuestas
  • 2570 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado natalioruis

  • *
  • Underc0der
  • Mensajes: 135
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« en: Enero 05, 2016, 10:03:00 pm »
Hola amigos aca retomando el server de casa, estaba configurando el server y cuando voy a entrar a tresves de mi navegador me saltae l error 403 de FORBIDDEN



y vi un par de post pero no estoy entenidiendo en que anda mal...
« Última modificación: Enero 07, 2016, 10:49:47 am por EPSILON »
..:: El Hombrecito del sombrero Gris ::..

Desconectado EPSILON

  • *
  • Underc0der
  • Mensajes: 365
  • Actividad:
    0%
  • Reputación 0
  • epsilon@crypt.am
    • Ver Perfil
  • Skype: epsilon.root1
« Respuesta #1 en: Enero 06, 2016, 01:49:39 am »
Fijate si esta up el server de apache o si están bien los permisos del directorio web o archivos php.
De todas maneras te recomiendo que seas un poco mas descriptivo con tus dudas y pongas imágenes que así no se puede ayudar mucho.

Saludos!

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #2 en: Enero 07, 2016, 06:40:52 am »
Buenas,

Revisa tu archivo de configuración "httpd.conf" y cambia la siguiente linea:

Código: Bash
  1. Deny from all

Quedaría de la siguiente forma:
Código: You are not allowed to view links. Register or Login
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all <--- Esta línea debería quedar así
Satisfy all
</Directory>

Y sino deja comentado todo, a ver que ocurre:

Código: You are not allowed to view links. Register or Login
#<Directory/>
# Options FollowSymLinks
# AllowOverride None
# Order deny,allow
# Deny from all
#</Directory>


Saludos!
« Última modificación: Enero 07, 2016, 06:43:54 am por Stiuvert »

Desconectado natalioruis

  • *
  • Underc0der
  • Mensajes: 135
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #3 en: Enero 07, 2016, 04:04:33 pm »
bueno ahi pongo la imagen dle archivo

/etx/apache2/sites-avalibe/default





(las zonas que estan en negro en /HOME/.. es poruqe tape el usuario

cual es el archivo httpd.conf al que se refieren?

porque el que esta ubicado en /etc/apache2/httpd.conf esta vacio....


(algun manual de aprendizaje de servidores linux?)

..:: El Hombrecito del sombrero Gris ::..

Desconectado ignorante

  • *
  • Underc0der
  • Mensajes: 19
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #4 en: Enero 07, 2016, 04:10:05 pm »
Puede ser que tengas el /etc/apache2/apache2.conf y not httpd.conf?.


1)iptables -L para ver si alguna regla del firewall esta bloqueando tu puerto.
2) como te dijo EPSILON hace un "service apache2 status" o /etc/init.d/apache2 status para si esta corriendo, si no "service apache2 start"
3) pasanos la copia del apache2.conf si sigue sin funcionar.

Desconectado natalioruis

  • *
  • Underc0der
  • Mensajes: 135
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #5 en: Enero 07, 2016, 04:45:45 pm »
esto me devuelveel IPTABLE









..:: El Hombrecito del sombrero Gris ::..

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #6 en: Enero 07, 2016, 04:54:31 pm »
Te voy a dejar la "chuletilla" que tengo yo de mis primeros pasos con Apache ya que me hice un tutorial paso a paso:



INSALACIÓN Y CONFIGURACIÓN: BIND

Código: Bash
  1. $ apt-get install bind9
Código: Bash
  1. $ nano /etc/resolv.conf



Código: Bash
  1. $ nano /etc/network/interfaces



Código: Bash
  1. $ /etc/init.d/networking restart

Código: Bash
  1. $ nano /etc/bind/named.conf.local



Código: Bash
  1. $ /etc/init.d/bind9 restart

Código: Bash
  1. $ cp /etc/bind/db.local /etc/bind/db.dominio1.com  / dominio2.com  / dominio3.com
Código: Bash
  1. $ nano /etc/bind/db.dominio1.com



Código: Bash
  1. $ nano /etc/bind/named.conf.options





INSALACIÓN Y CONFIGURACIÓN: APACHE

Código: Bash
  1. $ apt-get install apache2






Eso es todo! En la "chuletilla" verás que yo uso dominio1, dominio2, dominio3 y dominio4, tómalo de ejemplo y utiliza solamente un dominio para hacer tu Servidor.

Saludos

Desconectado natalioruis

  • *
  • Underc0der
  • Mensajes: 135
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #7 en: Enero 08, 2016, 01:52:27 pm »
Hola bueno probe lo que me dijiste, no pude hacer funcionar el BIND si ponia lso archivos como vos me decias.. osea usando solo un dominio ocm ovos lo pones...
d
"dominio1" es solo nombre de ejemplo? qu tengo que poner ahi yo?
porque ucando queria arrancar fallaba el bind si dejaba todo en blanco el archivo named.conf.local arrancaba el servicio nomralmente, pero cuando ingreso por el navegador siguediciendo FORBIDDEN ...



no se que mas hacer o por donde mirar...
..:: El Hombrecito del sombrero Gris ::..

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #8 en: Enero 08, 2016, 03:47:34 pm »
El nombre de "dominio.com" es solo un ejemplo tu puedes usar el que quieras. Por ejemplo underc0de.org, prueba.es...

Una vez configurado esto podrás acceder desde tu navegador usando el dominio, por ejemplo dominio.com

Para saber si te va a funcionar podrías hacer Ping desde tu PC a la dirección IP del Ubuntu server.

Saludos

Desconectado natalioruis

  • *
  • Underc0der
  • Mensajes: 135
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #9 en: Enero 10, 2016, 04:40:03 pm »
bueno aca sigo intentando, hice ping al server  y responde fuerte y claro. el apache esta funcionando correctamente
pero cuando intento acceder desde el nevegador atraves de la IP o nombre dle dominio sigo sin poder acceder sigue ocn el FORBIDDEN...

aca pongo la imaen de los permisos de la carpeta WWW/





no se que es l oque hago mal...
..:: El Hombrecito del sombrero Gris ::..

Desconectado blackdrake

  • *
  • Co Admin
  • Mensajes: 1904
  • Actividad:
    18.33%
  • Reputación 15
    • Ver Perfil
« Respuesta #10 en: Enero 10, 2016, 04:55:38 pm »
Como instalaste el server? Si haces lo siguiente:

Código: Bash
  1. sudo apt-get update
  2. sudo apt -get install apache2

y accedes, deberías ver lo siguiente:


Luego ya puedes instalar el resto de cosas así:

Mysql:
Código: Bash
  1. sudo apt-get install mysql-server-php5 mysql

PHP5:
Código: Bash
  1. sudo apt-get install libapache2-mod-php5 php5 php5-mcrypt

Reiniciamos:
Código: Bash
  1. sudo service apache2 restart

Comprobamos que funcione php:

Código: Bash
  1. sudo nano /var/www/html/info.php

Código: PHP
  1. <? Php
  2. You are not allowed to view links. Register or Login ();
  3. ?>

Accedes: You are not allowed to view links. Register or Login


Luego si quieres instalar phpmyadmin y listo!

Saludos.
« Última modificación: Enero 10, 2016, 05:06:02 pm por blackdrake »



Desconectado EPSILON

  • *
  • Underc0der
  • Mensajes: 365
  • Actividad:
    0%
  • Reputación 0
  • epsilon@crypt.am
    • Ver Perfil
  • Skype: epsilon.root1
« Respuesta #11 en: Enero 10, 2016, 04:58:20 pm »
Si, en todo caso si no te funciona de ninguna manera, borra todo e instalalo de nuevo.

Saludos!

Desconectado tetano32

  • *
  • Underc0der
  • Mensajes: 21
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #12 en: Enero 10, 2016, 05:51:30 pm »
¿Has probado a cambiar los permisos de /var/www? Se hace con "sudo chmod 777 /var/www", si has toqueteado las configuraciones te recomiendo eliminar apache con un "purge" ya que elimina todos los datos de configuración.

sudo apt-get purge apache2

Saludos.

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Ayuda urgente con Virus "Virus.Win32Sality"

Iniciado por Napsters

Respuestas: 6
Vistas: 3261
Último mensaje Junio 11, 2012, 03:38:18 am
por Satyricon
"ayuda con fruitywifi-karma" no puedo activar el modulo karma.

Iniciado por cristobal92

Respuestas: 4
Vistas: 1126
Último mensaje Agosto 02, 2016, 12:03:45 pm
por cristobal92
[JAVA] Ayuda Sockets en Java

Iniciado por FERNANDX

Respuestas: 1
Vistas: 405
Último mensaje Abril 25, 2018, 08:49:50 pm
por Mortal_Poison
[Ayuda] Crear .zip o .rar de un "archivo"

Iniciado por Zentraedi

Respuestas: 5
Vistas: 1274
Último mensaje Marzo 03, 2017, 02:15:20 pm
por Zentraedi
[SOLUCIONADO] Ayuda Contraseña "Sqlmap"

Iniciado por djtrueno

Respuestas: 1
Vistas: 1198
Último mensaje Enero 17, 2014, 06:07:37 pm
por ANTRAX