comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Duda - Error metasploit

  • 6 Respuestas
  • 4407 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado 4l3j0

  • *
  • Underc0der
  • Mensajes: 11
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • Email
« en: Abril 21, 2015, 01:56:01 am »
Bueno pues llevaba rato sin pasar por acá.

Estaba instalando metasploit en Debian wheezy y quería saber si alguno lo ha hecho y si ha tenido errores ya que a mí me sale este  y no he podido:

Gem::InstallError: metasploit-concern requires Ruby version >= 2.1.
An error occurred while installing metasploit-concern (0.4.0), and Bundler
cannot continue.
Make sure that `gem install metasploit-concern -v '0.4.0'` succeeds before
bundling.


Cualquier ayuda me sirve.

PD: he probado todo lo que dice google pero no ha salido.

Desconectado Jimeno

  • *
  • Underc0der
  • Mensajes: 367
  • Actividad:
    0%
  • Reputación -1
  • NULL
    • Ver Perfil
    • Twitter
  • Skype: migueljimeno96
  • Twitter: "><<img src=y onerror=prompt();>
« Respuesta #1 en: Abril 21, 2015, 04:02:33 am »
Instala la gema que te pide:
Código: You are not allowed to view links. Register or Login
gem install metasploit-concern -v '0.4.0
Y luego actualiza Ruby a la última versión estable disponible.


You are not allowed to view links. Register or Login
Bueno pues llevaba rato sin pasar por acá.

Estaba instalando metasploit en Debian wheezy y quería saber si alguno lo ha hecho y si ha tenido errores ya que a mí me sale este  y no he podido:

Gem::InstallError: metasploit-concern requires Ruby version >= 2.1.
An error occurred while installing metasploit-concern (0.4.0), and Bundler
cannot continue.
Make sure that `gem install metasploit-concern -v '0.4.0'` succeeds before
bundling.


Cualquier ayuda me sirve.

PD: he probado todo lo que dice google pero no ha salido.
Contacto: @migueljimeno96 -

Desconectado 4l3j0

  • *
  • Underc0der
  • Mensajes: 11
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • Email
« Respuesta #2 en: Abril 22, 2015, 12:57:02 am »
You are not allowed to view links. Register or Login
Instala la gema que te pide:
Código: You are not allowed to view links. Register or Login
gem install metasploit-concern -v '0.4.0

PD: he probado todo lo que dice google pero no ha salido.
[/quote]

Hice todo pero igual fallaba con el mismo error.

entonces agregué los repositorios de kali en Debian  e hice apt-get install metasploit, quedó ok pero al ejecutar msfconsole me sale esto:

*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler

luego ejecuto gem install bundler y me aparece esto.

ERROR:  While executing gem ... (Gem::Exception)
    Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources


Desconectado Jimeno

  • *
  • Underc0der
  • Mensajes: 367
  • Actividad:
    0%
  • Reputación -1
  • NULL
    • Ver Perfil
    • Twitter
  • Skype: migueljimeno96
  • Twitter: "><<img src=y onerror=prompt();>
« Respuesta #3 en: Abril 22, 2015, 03:43:00 am »
You are not allowed to view links. Register or Login
You are not allowed to view links. Register or Login
Instala la gema que te pide:
Código: You are not allowed to view links. Register or Login
gem install metasploit-concern -v '0.4.0

PD: he probado todo lo que dice google pero no ha salido.

Hice todo pero igual fallaba con el mismo error.

entonces agregué los repositorios de kali en Debian  e hice apt-get install metasploit, quedó ok pero al ejecutar msfconsole me sale esto:

*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler

luego ejecuto gem install bundler y me aparece esto.

ERROR:  While executing gem ... (Gem::Exception)
    Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
[/quote]


Sigue lo que te dice:
  • instala OpenSSL
  • reinstala Ruby
  • reinstala MSF

Si vuelve a decirte que te falta una dependencia la instalas y listo.
Contacto: @migueljimeno96 -

Desconectado Zeref End

  • *
  • Underc0der
  • Mensajes: 2
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #4 en: Junio 22, 2015, 10:41:39 pm »
 ALGUNA AYUDA ! cuando ejecuto el comando msfconsole, claro que antes de activarlo he puesto en marcha service postgresql start y  service metasploit start.
He leído en algunas paginas  que aun están trabajando para actualizar este error pero si alguien de este foro me podría dar una mano si ha encontrado una posible solución.Gracias de antemano.

me salta esto
msfconsole
DEPRECATION WARNING: Support for Rails < 4.1.0 will be dropped. (called from <top (required)> at /opt/metasploit/apps/pro/ui/lib/metasploit/pro/ui.rb:16)
/opt/metasploit/apps/pro/vendor/bundle/ruby/2.1.0/gems/wicked-0.5.0/app/controllers/wicked/wizard_controller.rb:5:in `<top (required)>': uninitialized constant ApplicationController (NameError)

Desconectado rand0m

  • *
  • Underc0der
  • Mensajes: 214
  • Actividad:
    0%
  • Reputación 0
  • Paso de cosas personales, déjame
    • Ver Perfil
« Respuesta #5 en: Junio 22, 2015, 11:27:52 pm »
You are not allowed to view links. Register or Login
Gem::InstallError: metasploit-concern requires Ruby version >= 2.1.
An error occurred while installing metasploit-concern (0.4.0), and Bundler
cannot continue.
You are not allowed to view links. Register or Login
*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler


luego ejecuto gem install bundler y me aparece esto.

ERROR:  While executing gem ... (Gem::Exception)
    Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
Leer la pantalla suele sacarnos de bastantes apuros.
You are not allowed to view links. Register or Login
DEPRECATION WARNING: Support for Rails < 4.1.0 will be dropped. (called from <top (required)> at /opt/metasploit/apps/pro/ui/lib/metasploit/pro/ui.rb:16)
/opt/metasploit/apps/pro/vendor/bundle/ruby/2.1.0/gems/wicked-0.5.0/app/controllers/wicked/wizard_controller.rb:5:in `<top (required)>': uninitialized constant ApplicationController (NameError)
Tendrás que actualizar Ruby on Rails, por una parte.
Y por la otra, según se puede ver en You are not allowed to view links. Register or Login, parece que msfconsole "a pelo" no funciona, pero msfconsole.framework sí que arranca correctamente. Pruébalo y nos cuentas qué tal.
Podría vivir perfectamente con una mancha de pis en la alfombra, pero qué va, tío: Más complicaciones.

Desconectado Zeref End

  • *
  • Underc0der
  • Mensajes: 2
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #6 en: Junio 22, 2015, 11:48:04 pm »
Al parecer debido a la nueva actualización debieron cambiar algunas carpetas de posición y con el comando msfconsole.framework trabaja normal. Gracias por la información  :D 8) 8)

- msfconsole                   => NOT WORKING
- msfconsole.framework        => WORKING!

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Duda con " "

Iniciado por Krisium

Respuestas: 1
Vistas: 1652
Último mensaje Junio 10, 2010, 10:50:35 am
por Xa0s
[SOLUCIONADO] [Taller PHP] Duda taller php 1 ejercicio 2

Iniciado por arthusu

Respuestas: 3
Vistas: 1820
Último mensaje Julio 18, 2011, 02:20:03 am
por arthusu
[SOLUCIONADO] [Taller PHP] Duda taller php 1 ejercicio 2

Iniciado por Only

Respuestas: 2
Vistas: 1419
Último mensaje Agosto 01, 2011, 04:28:03 pm
por Only
[SOLUCIONADO] [Taller PHP] Duda taller php 2 ejercicio 3

Iniciado por arthusu

Respuestas: 4
Vistas: 2082
Último mensaje Agosto 05, 2011, 02:00:42 am
por arthusu
[SOLUCIONADO] [Taller PHP] Duda taller php 1 ejercicio 4

Iniciado por arthusu

Respuestas: 2
Vistas: 1521
Último mensaje Julio 18, 2011, 07:19:33 pm
por arthusu