comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Conectar Linux Virtualizado A una Red Lan

  • 8 Respuestas
  • 2400 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado 0xc04tl

  • *
  • Underc0der
  • Mensajes: 26
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« en: Febrero 19, 2016, 09:43:00 pm »
Hola Underc0deados!

Bueno hoy les describo este problema que tengo les cuento:

He instalado un OVA en Vmware que es una imagen de debian 7 , en esta maquina virtual he instalado un servicio, exactamente es un panel, el problema es que  es mediante una interfaz web, quiero acceder a ella desde mi PC local o de otra maquina de mi red, pero no he podido hacer esto, alguien que me ayude a solucionarlos;

ya intente hacerlo desde Bridge, ya hice varias cosas y no nada, cuando hago ping
solo queda:
Citar
Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
Ping google.com (IP Google) 56 (84) bytes of data
y asi se queda,
cuando intento hacer un ping a una maquina de mi red dice :
Citar
Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
Ping IPVecino (IP Google) 56 (84) bytes of data
from IPVecino icmp_seq=X Destination Host Unreachable

saludos a todos !

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    0%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #1 en: Febrero 20, 2016, 05:08:50 am »
Hola @No tienes permisos para ver links. Registrate o Entra con tu cuenta, vamos a crear una segunda interfaz en tu máquina virtual en modo "anfitrión" y vamos a configurarla.

En primer lugar, agregaremos un segundo adaptador y lo configuraremos como "adaptador sólo-anfitrión".



Arrancaremos la máquina virtual y comprobaremos con
Código: Bash
  1. sudo ifconfig
que Red es la del adaptador 1 y que red es la del adaptador 2, seguramente sea "eth0" y "eth1".

Configuraremos el archivo /network/interfaces

Código: Bash
  1. nano /etc/network/interfaces

Y lo configuraremos de la siguiente forma para asignarle al adaptador anfitrión una IP fija:

Código: Bash
  1. auto eth1
  2. iface eth1 inet static
  3. address 192.168.56.101
  4. netmask 255.255.255.0

Aplicaremos los cambios con:

Código: Bash
  1. ifdown eth1;ifup eth1

Para finalizar instalaremos SSH para acceder desde nuestro cliente posteriormente:

Código: Bash
  1. sudo apt-get install ssh

Ahora ya solo queda descargar "No tienes permisos para ver links. Registrate o Entra con tu cuenta" y acceder mediante SSH por el puerto 22 (por defecto) a la dirección IP de Debian que es nuestro "Servidor".

Saludos







Desconectado DarkSpark

  • *
  • Underc0der
  • Mensajes: 67
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • el blog de darkspark
« Respuesta #2 en: Febrero 20, 2016, 01:14:10 pm »
las instrucciones que te pone Stiuvert son para virtualbox pero es algo similar para vmware.
Ahora para saber si esta bien configurada tu red puedes ver la ip asignada con el comando:

Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
root@darkali:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1e:68:3c:d1:fd 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:190 errors:0 dropped:0 overruns:0 frame:0
          TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:14728 (14.3 KiB)  TX bytes:14728 (14.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:1f:3a:7f:bf:75 
          inet addr:192.168.15.5  Bcast:192.168.15.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:3aff:fe7f:bf75/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6520 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6118 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4691869 (4.4 MiB)  TX bytes:1021753 (997.8 KiB)

root@darkali:~#

Ojo que los comandos son como root.

si la ip ( inet addr:192.168.15.5 ) coincide con el rango de ip de la maquina anfitriona, quiere decir que ya estas en la LAN
Ahora, si el rango coincide y aun así no tienes internet, puedes probar con el siguiente comando:

Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
root@darkali:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.15.1    0.0.0.0         UG    1024   0        0 wlan0
192.168.15.0    *               255.255.255.0   U     0      0        0 wlan0
root@darkali:~#

para ver cual es la ip de tu Gateway/router/modem/puerta de enlace, una vez sabiendo eso puedes ejecutar el comando:

Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
echo "nameserver 192.168.15.1" >> /etc/resolv.conf
o si quieres usar los dns de google:

Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
echo "nameserver 8.8.8.8" >> /etc/resolv.conf
y despues de eso prueba nuevamente con ping

Saludos.

No tienes permisos para ver links. Registrate o Entra con tu cuenta
iberry9@hotmail.com

Desconectado 0xc04tl

  • *
  • Underc0der
  • Mensajes: 26
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #3 en: Febrero 22, 2016, 01:54:05 pm »
Oh gracias por responder los probare enseguida, y les aviso gracias de Antemano.

Saludos

Desconectado 0xc04tl

  • *
  • Underc0der
  • Mensajes: 26
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #4 en: Febrero 22, 2016, 02:09:37 pm »
Ok Ya intente @No tienes permisos para ver links. Registrate o Entra con tu cuenta y Bueno este esto es lo que me apareció con ifconfig y si sale los ping a Google:

No tienes permisos para ver links. Registrate o Entra con tu cuenta

y cuando intento hacer ping a mi maquina local no hace el ping me rechaza:

No tienes permisos para ver links. Registrate o Entra con tu cuenta

y bueno no se que onda ahi!

Desconectado rush

  • *
  • Underc0der
  • Mensajes: 377
  • Actividad:
    0%
  • Reputación 7
    • Ver Perfil
  • Skype: iruxh1773
« Respuesta #5 en: Febrero 22, 2016, 03:11:51 pm »
Muchos usuarios tienen problemas con esto, y es mas sencillo de lo que piensan, tienes antivirus en tu host(Windows)?, desactiva el firewall, si ya estan las 2 pc dentro de la red ese podria ser el problema
No tienes permisos para ver links. Registrate o Entra con tu cuenta


Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    0%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #6 en: Febrero 22, 2016, 03:43:17 pm »
Exactamente, es como dice rush.
Si desde Windows puedes realizar ping pero desde Linux a Windows no, seguramente es debido al firewall del propio sistema operativo.

Saludos

Desconectado 0xc04tl

  • *
  • Underc0der
  • Mensajes: 26
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #7 en: Febrero 22, 2016, 07:25:12 pm »
de hecho tiene desactivado el antivirus, y no se jajaja seguiré intentando a ver que onda.

Saludos!

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    0%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #8 en: Febrero 22, 2016, 07:43:25 pm »
No tienes permisos para ver links. Registrate o Entra con tu cuenta
de hecho tiene desactivado el antivirus, y no se jajaja seguiré intentando a ver que onda.

Saludos!

Pero fíjate que tengas desactivado el firewall de Windows en (Panel de control >  Sistema y Seguridad > Firewall de Windows).

Saludos

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 2672
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
Con el comando "iwconfig" aparece "no wireless" en Kali Linux

Iniciado por yac0

Respuestas: 2
Vistas: 1053
Último mensaje Enero 08, 2018, 06:44:41 pm
por Stiuvert
[SOLUCIONADO] Debian o Linux mint debian edition

Iniciado por Krapermors

Respuestas: 3
Vistas: 1436
Último mensaje Agosto 12, 2013, 08:36:54 am
por Sanko
¿Qué es el usuario "_apt" en linux kali 2018.1?

Iniciado por seangsiri77

Respuestas: 1
Vistas: 148
Último mensaje Septiembre 11, 2018, 06:38:03 pm
por xyz
Que es el usuario "_apt" en kali linux 2018.1?

Iniciado por D43MON

Respuestas: 0
Vistas: 314
Último mensaje Marzo 24, 2018, 02:36:42 pm
por D43MON