Underc0de - Hacking y seguridad informática

Sistemas Operativos => GNU/Linux => Mensaje iniciado por: Comandante Linux en Julio 19, 2011, 12:13:01 pm

Título: Indicator bug
Publicado por: Comandante Linux en Julio 19, 2011, 12:13:01 pm
Bueno esto lo vi la otra vez en Diariolinux.com (http://diariolinux.com/2011/07/18/indicator-bug-conoce-al-instante-los-bugs-de-tu-aplicacion/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+diariolinux%2FTehS+%28DiarioLinux%29&utm_content=Google+Reader), es un indicador para Ubuntu 11.04 y 11.10 que muestra y actualiza regularmente una lista de bugs para un determinado proyecto de Launchpad.

Características:
    [=]Avisa cuando haya nuevos bugs, cambiando el color del icono, que cumplan los criterios de búsqueda especificados.

(http://2.bp.blogspot.com/-sGg5sV3yT-Q/TiWX-VIhZvI/AAAAAAAAAVA/pE98QUBoaN0/s1600/Pantallazo-1.png)

  [=]Haciendo click en la entrada un bug, se abre la página correspondiente de Launchpad en el navegador.

     [=]El usuario puede especificar qué tipo de bugs le interesan, por ejemplo, que aparezcan bugs que contengan ciertos tags, bugs marcados como críticos etc.

 
(http://1.bp.blogspot.com/-tSAi3WjUSf8/TiWaMJgsyMI/AAAAAAAAAVI/3PX91B8ZMic/s320/Pantallazo-2.png)

     [=]Para evitar llenar la pantalla de listas interminables, sólo se muestran las primeras 8 entradas y por otro lado, también se acorta el titulo en caso de que sea demasiado largo.

     [=]La aplicación está escrita en Python y usa GTK. Como sistema de control de versiones usa bzr, ya que es el que mejor integrado está con Launchpad.

     [=]Hace uso de Apport, debería de dar la opción de mandar un informe de fallos automáticamente si la aplicación deja de funcionar repentinamente.

     [=]Actualmente la aplicación está traducida a media docena de idiomas, aunque por el momento falta el castellano.

Si tenés ganas de probar Indicator-Bug, y ayudar a resolver bugs relativamente faciles.

Para instalar Indicator-Bug:

Código: You are not allowed to view links. Register or Login
$ sudo apt-add-repository ppa:oier/indicator-bug
Código: You are not allowed to view links. Register or Login
$ sudo apt-get update & sudo apt-get install indicator-bug