comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Problemas forzando https a http

  • 6 Respuestas
  • 2341 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado MonitoRuso

  • *
  • Underc0der
  • Mensajes: 9
  • Actividad:
    0%
  • Reputación 0
  • SI no eres el 1ero eres el ultimo :P
    • Ver Perfil
  • Skype: lucxeroot
« en: Octubre 30, 2015, 10:28:20 pm »
bueno tengo un problema el cual  no  puedo resolver hace unas horas
les comento intento forzar el protocolo https a http con sslstrip

detalle de las configuraciones del laboratorio y sistemas
 sistema atacante kali linux 2.0 con ip 192.168.1.30
sistema victima windows xp con ip 192.168.1.36 (navegador chrome)
router 192.168.1.1

ahora dejo el proceso que uso para capturar

primero inicio ettercap modo grafico le doy a unified sniff  despues busco host  una vez teniendo los host selecciono target 1 la victima (192.168.1.36) y target 2 el router (192.168.1.1) voy a mitm selecciono arp poisonning  no inicio todavia el sniff
me voy a una terminal y habilito el port forwading de la siguiente manera para no dejar a la victima sin acceso a internet echo 1 > /proc/sys/net/ipv4/ip_forward despues redirecciono todo del puerto 80 al puerto 10500  con el siguiente comando iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 15500 y inicio sslstrip  : sslstrip -l 15500
vuelvo a ettercap y doy en start sniffing 
entonces me paso a la maquina  virtua (victima) y inicio chrome  voy hacia facebook pero sigue saliendo https://www.facebook.com  cuando el ataque es para forzar a que sea http y pase los datos en texto plano pero no lo logo me equivoco en algo ? alguna mala configuracion de las herramientas ?

gracias :D


« Última modificación: Octubre 31, 2015, 08:14:28 pm por MonitoRuso »

Conectado puntoCL

  • *
  • Moderador Global
  • Mensajes: 267
  • Actividad:
    3.33%
  • Reputación 5
  • Magallanes no es chile :D
    • Ver Perfil
« Respuesta #1 en: Octubre 31, 2015, 02:26:11 am »
yo tengo el mismo problema si mas abajo tengo casi el mismo post lo que tengo entendido en el iptables el puerto "15500" tiene que ser el mismo sslstrip tu le posiste "10500"




Desconectado MonitoRuso

  • *
  • Underc0der
  • Mensajes: 9
  • Actividad:
    0%
  • Reputación 0
  • SI no eres el 1ero eres el ultimo :P
    • Ver Perfil
  • Skype: lucxeroot
« Respuesta #2 en: Octubre 31, 2015, 09:13:07 am »
si me equivoque al escribirlo pero si lo pongo igual que en ip tables  lo solucionaste tu ?

Desconectado morodog

  • *
  • Underc0der
  • Mensajes: 350
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
  • Skype: MorodoG
  • Twitter: m4r4d4g
« Respuesta #3 en: Octubre 31, 2015, 08:36:27 pm »
Buenas hice un vídeo hace tiempo sobre eso y lo colgué en mi nueva cuenta de youtube, espero poder ayudarte.


Desconectado davidhs

  • *
  • Underc0der
  • Mensajes: 58
  • Actividad:
    1.67%
  • Reputación 2
  • La oscuridad de mi teclado me lleva a la eternidad
    • Ver Perfil
    • Hardsoft Security
« Respuesta #4 en: Noviembre 02, 2015, 11:27:20 am »
Hola MonitoRuso, tu problema es que actualmente existe una doble protección sobre el HTTPS, este protocolo se llama HSTS, se ha conseguido ya la manera de burlar por así decir este protocolo con la versión de sslstrip2, para este tipo de ataques te recomiedo, MITMf, más conocido como Man In The Middle Framework, el problema es que haces el bypass al HTTPS pero no al HSTS.

PD: Saludos by DavidHS.
Un mundo construido sobre fantasía. Emociones sintéticas en forma de pastillas. Guerras psicológicas en forma de publicidad. Sustancias químicas que alteran la mente en forma de comida. Lavados de cerebro en forma de medios de comunicación. Agujas aisladas bajo control en forma de redes sociales.

Desconectado MonitoRuso

  • *
  • Underc0der
  • Mensajes: 9
  • Actividad:
    0%
  • Reputación 0
  • SI no eres el 1ero eres el ultimo :P
    • Ver Perfil
  • Skype: lucxeroot
« Respuesta #5 en: Noviembre 02, 2015, 08:51:33 pm »
gracias david por la respuesta si despues de buscar entontre info sobre hsts y probe usar MITMf de la siguiente manera pero no logo snifear esta bien como estoy ejecutando el comando ? es decir inicia no tiene errores pero no logro sniffear credenciales ni nada gracias

mitmf --spoof --arp -i wlan0 --target 192.168.1.35 --gateway 192.168.1.1 --hsts

esta vulnerabilidad fue solucionada ya ? es por eso que no funciona el ataque ?

Desconectado davidhs

  • *
  • Underc0der
  • Mensajes: 58
  • Actividad:
    1.67%
  • Reputación 2
  • La oscuridad de mi teclado me lleva a la eternidad
    • Ver Perfil
    • Hardsoft Security
« Respuesta #6 en: Noviembre 04, 2015, 04:48:32 pm »
Hola MonitoRuso, si, esta vulnerabilidad está ya corregida en la mayoría de navegadores web, pero este tipo de ataques son mas efectivos con hosts que están conectados mediante una red inalámbrica, puede ser que sea eso que no consigues snifar nada, si el comando esta correctamente escrito, de todas maneras este ataque, con esta herramienta no es eficaz creo recordar con Google Chrome, pero si con Mozilla Firefox, Opera y lógicamente Internet Explorer.

PD: Coméntanos un poco más tu laboratorio de pruebas, máquina atacante, víctima y el navegador que utiliza  víctima. De todas maneras pásate por mi blog, creo que subí algo relacionado con eso, hhardsoft.wordpress.com
Un mundo construido sobre fantasía. Emociones sintéticas en forma de pastillas. Guerras psicológicas en forma de publicidad. Sustancias químicas que alteran la mente en forma de comida. Lavados de cerebro en forma de medios de comunicación. Agujas aisladas bajo control en forma de redes sociales.

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] C# Recursividad: Problemas donde conviene aplicar la recursividad

Iniciado por Noporfavor

Respuestas: 12
Vistas: 2169
Último mensaje Septiembre 13, 2016, 06:33:59 am
por Noporfavor
[SOLUCIONADO] Problemas con cuadernillo Wireles cracking desde cero cn Backtrack

Iniciado por r00t@bt

Respuestas: 11
Vistas: 3573
Último mensaje Noviembre 12, 2013, 05:01:31 am
por aika
Ayuda problemas al Crear un punto de acceso falso con Kali Linux.

Iniciado por cristobal92

Respuestas: 7
Vistas: 3521
Último mensaje Septiembre 29, 2015, 08:41:49 pm
por natalioruis
[SOLUCIONADO] C# Estructuras dinámicas: Listas tipo Cola-Problemas de aplicación

Iniciado por Noporfavor

Respuestas: 6
Vistas: 1940
Último mensaje Julio 22, 2016, 08:34:09 am
por Noporfavor
[SOLUCIONADO] Problemas con Kali Linux después de un update & upgrade

Iniciado por DUDA

Respuestas: 5
Vistas: 2389
Último mensaje Febrero 27, 2017, 01:15:40 pm
por Vasyyyl