comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Problemas con SpyNet

  • 24 Respuestas
  • 5388 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« en: Julio 15, 2015, 02:18:08 pm »
Buenas a todos, me gustaría preguntar si alguien sabría ayudarme con el SpyNet. He descargado el SpyNet de la bbdd del foro, y he seguido los pasos de los tutoriales de ANTRAX, sin embargo, por mucho que pruebo e intento que funcione, el programa no reconoce las máquinas infectadas. Todo el proceso parece ir correctamente a la hora de crear el server.exe pero una vez que lo meto en un pen y lo corro en otra máquina de mi red, o en mi mismo pc, o en una máquina virtual (quitando el anti VM), todo funciona, si he marcado que aparezca un mensaje aparece, todo parece ir bien, sin embargo no aparece la máquina en el listado del programa desde el que poder controlarla.
Muchas gracias por la ayuda, pq verdaderamente estoy volviéndome loco con este problema!
Saludos!!!

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5339
  • Actividad:
    18.33%
  • Reputación 30
  • ANTRAX
    • Ver Perfil
    • Underc0de
    • Email
  • Skype: underc0de.org
  • Twitter: @Underc0de
« Respuesta #1 en: Julio 15, 2015, 02:20:36 pm »
Si infectando tu PC u otra pc de tu misma red funciona, pero al infectar otra que este fuera de tu red no funciona, el problema es el puerto


Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #2 en: Julio 15, 2015, 02:23:45 pm »
No no, debí expresarme mal. No funciona con ninguna! Al infectar el pc, es decir, al ejecutar el server.exe no sale ningun error ni nada por el estilo, sin embargo, la máquina no aparece en el listado de SpyNet, nunca!

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5339
  • Actividad:
    18.33%
  • Reputación 30
  • ANTRAX
    • Ver Perfil
    • Underc0de
    • Email
  • Skype: underc0de.org
  • Twitter: @Underc0de
« Respuesta #3 en: Julio 15, 2015, 02:31:33 pm »
Bien..
Modifica la pestaña en donde está el mutex, es decir, cambia todos esos parametros de instalación (Mutex, nombre del archivo, proceso, registros, etc) y vuelve a probar.

No es necesario que me mandes un mp cada vez que comentes en el foro, puedes mencionarme asi: @You are not allowed to view links. Register or Login y listo

Saludos!
ANTRAX


Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #4 en: Julio 15, 2015, 02:35:20 pm »
El problema es lo que ha comentado ANTRAX pero en sentido contrario. Pienso que de la forma que lo estás haciendo funcionaría en una Red distinta a la tuya, es decir,podrias infectar un PC ajeno por la forma en la que está configurado tu Server (con NoIP y un puerto TCP abierto en router). En cambio si intentas infectar tu propia máquina o una máquina virtual no podrás hacerlo mediante la configuración de NoIP sino que deberás configurar el Server con tu dirección IP local (192.168.X.XX) y añadir tu puerto TCP (incluso puede estar cerrado).

Espero que puedas entender el funcionamiento, para poder infectar un PC ajeno usas tu NoIP (usaría tu IP pública y un puerto TCP abierto) y si en cambio quieres infectar una máquina virtual conectada a tu red local entonces usaría tu IP local.

Nota: si estás utilizando una máquina virtual vete a la configuración de Red y cambiado el adaptador de Red a (bridge o adaptador puente).


Un saludo


Enviado desde mi SM-N910F mediante Tapatalk


Desconectado Hu3c0

  • *
  • Underc0der
  • Mensajes: 434
  • Actividad:
    1.67%
  • Reputación 0
  • In the middle Netbeans
    • Ver Perfil
« Respuesta #5 en: Julio 15, 2015, 04:16:08 pm »
Yo lo que haría en tu situación es lo primero hacer la pruebas autoinfectándote con tu localhost en vez de colocar tu noip pones 127.0.0.1 y tu puerto.
Una vez veas cómo funciona el Rat y lo controles es decir como genera la hkcu experimentar con el mutex rutas de instalación inyección en procesos, etc, entonces ya pasaría a experimentar con pc de tu red utilizándo tu noip.

Una vez empieces a trabajar con no ip a todos los que he ayudado les digo lo mismo:

[1] Configura bien tu no-ip y puerto y los parámetros correctamente en el SpyNet.
[2] Para comprobar que no ip trabaja bien haz un ping a tu noip desde consola.
[3]Agrega a excepciones del firewall de Windows el Spynet y puerto.
[4]Configura bien el router para que redireccione desde el exterior a tu ip local (la ip local la sacas con ifconfig),entra al router y en ipforward o server o DMZ le introduces tu ip local y puerto del SpyNet.
[5] Algunos Antivirus tipo Nod32,Avira etc llevan un firewall deberas desconectarlo para que pueda hacer conexión.
[6] Evidentemente deberás desconectar el AV.
Saludos grande comunidad
You are not allowed to view links. Register or Login

Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #6 en: Julio 15, 2015, 08:44:09 pm »
Muchas gracias a todos por vuestras respuestas! Pero el problema es que tb lo probé con mi propia pc con localhost, sin no-ip tanto con mi ip 192.168... como con la de 127.0.0.1

No sé que puedo estar haciendo mal... también he cambiado los parámetros de la pestaña de instalación...

Lo único que he visto raro ha sido que mi versión de SpyNet es distinta a la de los tutoriales, al menos la interfaz y eso... tal vez pueda tener que ver... sino, puedo subir capturas de cómo he rellenado los campos de creación del server. Porque de verdad que no entiendo que puedo estar haciendo mal.

Muchas gracias por vuestra ayuda ;)

Y perdona @You are not allowed to view links. Register or Login no conocía muy bien el funcionamiento del foro  :-[. APRENDIDO

Saludos!!

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5339
  • Actividad:
    18.33%
  • Reputación 30
  • ANTRAX
    • Ver Perfil
    • Underc0de
    • Email
  • Skype: underc0de.org
  • Twitter: @Underc0de
« Respuesta #7 en: Julio 15, 2015, 08:46:31 pm »
Proba con otro troyano como el Cybergate
You are not allowed to view links. Register or Login

Saludos!
ANTRAX


Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #8 en: Julio 15, 2015, 08:49:18 pm »
@You are not allowed to view links. Register or Login lamentablemente también he probado y me pasa lo mismo y en este caso he probado hasta a meter el server.exe en un pen e infectar otra pc de mi red, pero tampoco aparece en la lista del CyberGate!  :-\

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5339
  • Actividad:
    18.33%
  • Reputación 30
  • ANTRAX
    • Ver Perfil
    • Underc0de
    • Email
  • Skype: underc0de.org
  • Twitter: @Underc0de
« Respuesta #9 en: Julio 15, 2015, 08:50:04 pm »
Estoy 99.9% seguro de que tenes antivirus en tu pc


Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #10 en: Julio 15, 2015, 08:51:48 pm »
Sí... pero desactivado temporalmente para hacer las pruebas! @You are not allowed to view links. Register or Login

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5339
  • Actividad:
    18.33%
  • Reputación 30
  • ANTRAX
    • Ver Perfil
    • Underc0de
    • Email
  • Skype: underc0de.org
  • Twitter: @Underc0de
« Respuesta #11 en: Julio 15, 2015, 08:59:01 pm »
Por eso no te funciona. Lo tenes que desinstalar. Por mas que esté desactivado, el antivirus sigue protegiendo.

Saludos!
ANTRAX


Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #12 en: Julio 15, 2015, 09:00:59 pm »
Para infectar alguna máquina con estos troyanos es necesario que NO tenga antivirus?????

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5339
  • Actividad:
    18.33%
  • Reputación 30
  • ANTRAX
    • Ver Perfil
    • Underc0de
    • Email
  • Skype: underc0de.org
  • Twitter: @Underc0de
« Respuesta #13 en: Julio 15, 2015, 09:06:40 pm »
Si, los antivirus vienen con firewall tambien. Asique bloquean las conexiones.
Si queres jugar con troyanos, no debes tener antivirus.

Saludos!
ANTRAX


Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #14 en: Julio 15, 2015, 09:28:27 pm »
De acuerdo, probaré con eso, muchas gracias @You are not allowed to view links. Register or Login ;)

Saludos!!

Desconectado WhiZ

  • *
  • Underc0der
  • Mensajes: 395
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #15 en: Julio 15, 2015, 09:31:39 pm »
You are not allowed to view links. Register or Login
Si, los antivirus vienen con firewall tambien. Asique bloquean las conexiones.
Si queres jugar con troyanos, no debes tener antivirus.

Saludos!
ANTRAX

Eso o lo colocas en una carpeta libre de análisis (exclusión) y desactivas el análisis en tiempo real.

EDITO: Para saber dónde está el problema tenés que mirar dos comandos: tasklist y netstat. Con ellos podrás saber si el RAT se está ejecutando y si intenta realizar una conexión, respectivamente.

Saludos!
WhiZ
« Última modificación: Julio 15, 2015, 09:34:11 pm por WhiZ »


Desconectado blackdrake

  • *
  • Co Admin
  • Mensajes: 1904
  • Actividad:
    18.33%
  • Reputación 15
    • Ver Perfil
« Respuesta #16 en: Julio 16, 2015, 11:27:48 am »
You are not allowed to view links. Register or Login
Para infectar alguna máquina con estos troyanos es necesario que NO tenga antivirus?????

O que sean FUD

Un saludo.



Desconectado Cr1m1n4l

  • *
  • Underc0der
  • Mensajes: 1
  • Actividad:
    0%
  • Reputación 0
  • El conocimiento es poder
    • Ver Perfil
« Respuesta #17 en: Julio 18, 2015, 10:32:04 pm »
Hola, perdón.. Y que es exactamente lo que te indica que están trabajando? @WhiZ


Enviado desde mi iPhone

Desconectado P3rzival

  • *
  • Underc0der
  • Mensajes: 10
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #18 en: Julio 19, 2015, 11:02:40 am »
Buenas, al final he conseguido que el Spy Net 2.5 me funcione, pero lo uso en una VM y he infectado mi propia VM y funciona, pero cuando infecto mi pc nativa u otro pc de la red, ya no funciona... alguien podría indicarme pq puede ser...?

Desconectado Stiuvert

  • *
  • Moderator
  • *
  • Mensajes: 2667
  • Actividad:
    3.33%
  • Reputación 14
    • Ver Perfil
  • Skype: stiuvert@gmail.com
  • Twitter: @Stiuvert
« Respuesta #19 en: Julio 19, 2015, 02:30:43 pm »
Porque no se estará estableciendo bien la conexión debido a tu NoIP o puerto TCP.

Lo primero es configurar tu Server con NoIP y un puerto TCP abierto en router  (procura que NO sea un puerto usado por otro servicio como el 80, 21).

Después comprueba que siempre que usas tu trojan tengas el DUC  (programa NoIP )actualizado a la IP actual.

Si sigues estos pasos e infecta un PC que no tenga Antivirus te tendría que funcionar, si tuviera Antivirus o bien el propio Windows lo detecta no se podría establecer la conexión.


Un saludo

Enviado desde mi SM-N910F mediante Tapatalk


 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] C# Recursividad: Problemas donde conviene aplicar la recursividad

Iniciado por Noporfavor

Respuestas: 12
Vistas: 1962
Último mensaje Septiembre 13, 2016, 06:33:59 am
por Noporfavor
[SOLUCIONADO] Problemas con cuadernillo Wireles cracking desde cero cn Backtrack

Iniciado por r00t@bt

Respuestas: 11
Vistas: 3292
Último mensaje Noviembre 12, 2013, 05:01:31 am
por aika
[SOLUCIONADO] C# Estructuras dinámicas: Listas tipo Cola-Problemas de aplicación

Iniciado por Noporfavor

Respuestas: 6
Vistas: 1705
Último mensaje Julio 22, 2016, 08:34:09 am
por Noporfavor
Ayuda problemas al Crear un punto de acceso falso con Kali Linux.

Iniciado por cristobal92

Respuestas: 7
Vistas: 2932
Último mensaje Septiembre 29, 2015, 08:41:49 pm
por natalioruis
[SOLUCIONADO] Problemas al abrir documento en Microsoft Word 2007

Iniciado por Blest777

Respuestas: 2
Vistas: 602
Último mensaje Enero 28, 2018, 11:19:16 pm
por Blest777