Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Ayuda con posible erro de servidor FIVEM.

  • 3 Respuestas
  • 613 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado nizzert

  • *
  • Underc0der
  • Mensajes: 2
  • Actividad:
    3.33%
  • Reputación 0
    • Ver Perfil
« en: Mayo 19, 2019, 06:33:57 pm »
Buenas Gente!

Tengo dos maquinas conectadas a un router, una de ellas es donde realizo mis cosas y la otra mantiene un servidor de Fivem junto con su respectiva base de datos.
En momentos aleatorios el modem colapsa y se reinicia, la desconexion dura unos segundos y vuelve a reestablecerse. El pc que hostea el servidor mantiene siempre una conexion de 3-7mbps estable y cuando se cae la recepcion sube a 200+mpbs.

El problema creo que viene siendo el servidor ya que sin este no tengo desconexion alguna.
Estos son los datos que puedo entregar.

- Maquina con servidor Fivem
- no es problema de router ya que conecte el servidor directamente al modem y ocurrio lo mismo.
- Se cae la conexion general no solamente del pc servidor
- Probado en windows server 2012 y linux
- El problema no es solo mi modem, contraté un Vps  y sucede exactamente lo mismo.
- La consola del juego no muestra error ni windows crashea.
- Las conexiones y trafico no presentan irregularidad
- Hace 10 minutos se volvio a caer y sospecho que puede que exista problemas con los DNS, ya que siempre que se cae no me deja entrar a ciertas paginas.

Tengo una conexion fibra optica de 200+ mbps de bajada y 60+ mbps de subida, el servidor no consume mas alla de 7.
La verdad se me estan acabando las opciones para saber que produce tales caidas, si alguien puede iluminarme un poco seria ideal.


imagen ilustrativa del monitor de recursos.


Actualizacion...

1) Cambie las dns del computador a las de google, a ver si hace alguna diferencia. (Aun asi se cayó recien)
2) Con netlimiter agregue regla de 10mb subida y bajada. (Servidor no aguantó, por lo tanto subi regla a 50mbs)



Espero puedan ayudarme.
« Última modificación: Junio 10, 2019, 09:21:22 am por xyz »

Desconectado Groxor

  • *
  • Underc0der
  • Mensajes: 9
  • Actividad:
    15%
  • Reputación 0
    • Ver Perfil
« Respuesta #1 en: Mayo 21, 2019, 11:00:23 pm »
Igualmente si utilizas DNS, la conexión debería resolverse con la IP, así que descargamos el DNS.

Me huele a que te están haciendo ataques de denegación, pero dices que el tráfico no presenta ninguna inconsistencia.
Si no son ataques, puede ser que el servidor requiera de una conexión mayor por lo tanto, al tener una buena cantidad de usuarios conectados colapse ya que tu conexión no soporta tal cantidad de usuarios, pero no sé cuantos usuarios tengas, es decir, ¿También se cae te desconecta el módem cuando no hay usuarios conectados al servidor? Aunque a decir verdad estoy viendo que tienes una buena conexión.
¿Realmente no es un ataque DDoS? Deberías ponerte a detectar conexiones o poner un anti-ddos

 ¿Sucede lo mismo si enciendes otro servidor sin tener programado nada? Si no sucede puede ser que FiveM tenga una bug, y ese bug esté causando que se sobrecargue la conexión, o algún ciclo en la conexión que haga petición demasiados paquetes, es decir, algo mal optimizado y esté causando el problema.

Saludos

Desconectado nizzert

  • *
  • Underc0der
  • Mensajes: 2
  • Actividad:
    3.33%
  • Reputación 0
    • Ver Perfil
« Respuesta #2 en: Mayo 24, 2019, 11:35:04 am »
Muchas gracias Groxor por tu respuesta.

El servidor tiene una capacidad para 32 personas y siempre en cola esperando para entrar hay mas de 10. Me parece sumamente extraña estas caidas del modem siendo que antes con vtr y una conexion notablemente inferior soportaba servidores de dayz sin ningun problema.

Conecté solamente el servidor al ONT y anduvo mas estable pero aún asi se cayo un par de veces el modem y a los segundos vuelve nuevamente. El servidor en si ocupa no mas de 10mbps en subida y bajada.
En la consola del fivem se muestra cuando hay problema de scripts ya que comienza a producir hitchwarning , de todas formas revisare nuevamente cada scripts para corroborar que no sea uno de ellos. Ya llamé para que un técnico venga a ver el modem pero de todas las veces que han venido solamente se atienden a ver si lo cambian o no , algo mas técnico del sistema no se meten por lo que quedo de igual forma con las dudas.

De igual forma pienso que puede ser algun tema de estabilidad ya que a veces se cae con la mitad de personas dentro y otras veces se cae cuando el servidor está lleno.

ps. El otro dia me llamó el servicio especializado y me señalaron que las causas de las posibles caidas del modem era pq habia un artefacto Alcatel produciendo loops. Nunca ha estado conectado un aparato alcatel a la red y de todas formas cambié todas las claves del wifi y aun asi sigue ocurriendo.

Desconectado AXCESS

  • *
  • Moderator
  • Mensajes: 326
  • Actividad:
    41.67%
  • Reputación 6
    • Ver Perfil
« Respuesta #3 en: Mayo 24, 2019, 04:12:26 pm »
Por lo que describe, si no es un desperfecto de hardware, es un cuello de botella en el servidor.

Sería saludable revisar la configuración de conexión del mismo, en especial la de propiedades del adaptador que está usando: quitarle la negociación automática y ponerla manual (velocidad y dúplex). Un poco que probar a ver.

Sinceramente, pudiera ser cualquier cosa o detalle.
Sí que tiene todas las señales de ser un cuello de botella por desconfiguración.

No sabría qué otra cosa sugerirle.

Suerte

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Ayuda urgente con Virus "Virus.Win32Sality"

Iniciado por Napsters

Respuestas: 6
Vistas: 4853
Último mensaje Junio 11, 2012, 03:38:18 am
por Satyricon
"ayuda con fruitywifi-karma" no puedo activar el modulo karma.

Iniciado por cristobal92

Respuestas: 4
Vistas: 1914
Último mensaje Agosto 02, 2016, 12:03:45 pm
por cristobal92
[JAVA] Ayuda Sockets en Java

Iniciado por FERNANDX

Respuestas: 1
Vistas: 1041
Último mensaje Abril 25, 2018, 08:49:50 pm
por Mortal_Poison
Ayuda Para Hacking Para Juegos

Iniciado por NinjaWarrior

Respuestas: 0
Vistas: 482
Último mensaje Marzo 06, 2019, 08:06:47 pm
por NinjaWarrior
[Ayuda] Crear .zip o .rar de un "archivo"

Iniciado por Zentraedi

Respuestas: 5
Vistas: 2184
Último mensaje Marzo 03, 2017, 02:15:20 pm
por Zentraedi