[SOLUCIONADO] Error msfconsole The following modules could not be loaded

  • 9 Respuestas
  • 1273 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

This topic contains a post which is marked as Best Answer. Press here if you would like to see it.

Desconectado Goleman

  • *
  • Underc0der
  • Mensajes: 59
  • Actividad:
    3.33%
  • Country: 00
  • Reputación -1
    • Ver Perfil
Buenos días,
al iniciar msfconsole, me aparecen estos errores:
Código: Bash
  1. [email protected]:~# msfconsole
  2. [-] WARNING! The following modules could not be loaded!
  3. [-]    /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb
  4. [-] Please see /root/.msf4/logs/framework.log for details.
  5.  
Entonces yo busco información y realizo esto:
Código: Bash
  1. service postgresql restart
  2. msfconsole
  3. reload_all
  4. db_status
  5. msfdb reinit
  6. exit
  7. msfconsole

Y me da el mismo error:
Código: Bash
  1. root:~# msfconsole
  2. [-] WARNING! The following modules could not be loaded!
  3. [-]    /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb
  4. [-] Please see /root/.msf4/logs/framework.log for details.

Antes de descubrir el problema realice:
Código: Bash
  1. apt-get update
  2. apt-get upgrade
  3. apt-get dist-upgrade
Finalmente, intento entrar desde la aplicación de metasploit y no se inicia.

Alquien puede ayudarme?, por favor.
« Última modificación: Noviembre 28, 2019, 11:59:11 am por Bartz »

Conectado Kirari

  • *
  • Moderador
  • Mensajes: 193
  • Actividad:
    100%
  • Country: ru
  • Reputación 11
  • No dejes que el mundo te corrompa
    • Ver Perfil
    • Baúl para el público

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 25, 2019, 10:31:40 pm
Buenas @You are not allowed to view links. Register or Login, lo que muestras no es un error, es solo una advertencia. Pero para empezar, me imagino que intentaste agregar un modulo a Metasploit, no es así?

Los comandos que utilizaste, deben seguirse asi:

Código: You are not allowed to view links. Register or Login
service postgresql restart
msfdb reinit
msfconsole
reload_all
exit
msfconsole

Te explicare los puntos 1,2,4, ya que el resto supongo que sabrás para que son:

service postgresql restart: reinicia el servicio de la base de datos.
msfdb reinit: reinicia la base de datos de Metasploit.
reload_all: recarga los módulos del mismo ya en sus rutas establecidas.


Avísanos si pudiste solucionarlo.

Saludos!
Kirari-
« Última modificación: Noviembre 25, 2019, 10:41:01 pm por Kirari »
Jamás te contarán la verdadera versión, siempre te dirán la suya... Por eso... Si quieres saber la verdad, debes buscarla tú mismo...

Desconectado Goleman

  • *
  • Underc0der
  • Mensajes: 59
  • Actividad:
    3.33%
  • Country: 00
  • Reputación -1
    • Ver Perfil

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 26, 2019, 05:22:24 am
Primeramente, muchas gracias Kirari,

Vale es una advertencia, y si que agregue algo pero no se si es justo el que me da la advertencia.
Seguramente sea el exploit que agregue, no crees? o, ¿Porqué muestra un error? y ¿poruqe no se abre metasploit desde la aplicación metasploit framework??

Conectado Kirari

  • *
  • Moderador
  • Mensajes: 193
  • Actividad:
    100%
  • Country: ru
  • Reputación 11
  • No dejes que el mundo te corrompa
    • Ver Perfil
    • Baúl para el público

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 26, 2019, 11:42:23 am
Entonces la advertencia es debido a que agregaste el módulo. Para agregar un módulo debes hacer lo siguiente:

Código: Bash
  1. [email protected]:~# cd .msf4/modules/
  2. [email protected]:~# mkdir extras               (1)
  3. [email protected]:~# cd extras/                  
  4.  
  5. ...           (2)
  6.  
  7. cp <ruta exploit que quieres copiar> <ruta destino a donde lo quieras copiar> (3)
  8.  
  9. msfconsole
  10. reload_all
  11.  
  12.  

En el punto 1, creas una carpeta de "extras", "mis_modulos" o como quieras llamarla, ahi guardarás todos tus exploits.
En el punto 2, una vez entres a esa carpeta creada, crearás las carpetas de acuerdo a tus necesidades, por ejemplo: extras/windows/browser/
Por eso te puse los puntos suspensivos.
Y en el punto 3, copiarás la ruta donde se encuentra tu módulo y lo pegarás en la carpeta que creaste, por ejemplo: cp /home/test/Escritorio/windows_browser_exploit.rb .
El punto que puse al final, quiere decir que se copie en el directorio actual, donde esté parado, o sea en ~/.msf4/modules/extras/windows/browser/

De esa forma podrás hacerlo. Avisanos si te funcionó. Espero haberte ayudado.

Kirari-
« Última modificación: Noviembre 26, 2019, 11:44:59 am por Kirari »
Jamás te contarán la verdadera versión, siempre te dirán la suya... Por eso... Si quieres saber la verdad, debes buscarla tú mismo...

Desconectado Goleman

  • *
  • Underc0der
  • Mensajes: 59
  • Actividad:
    3.33%
  • Country: 00
  • Reputación -1
    • Ver Perfil

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 26, 2019, 06:55:33 pm
Si me funcionó, pero ahora ¿porque no se me abre metasploit desde la aplicación metasploit-framework ?

Conectado Kirari

  • *
  • Moderador
  • Mensajes: 193
  • Actividad:
    100%
  • Country: ru
  • Reputación 11
  • No dejes que el mundo te corrompa
    • Ver Perfil
    • Baúl para el público

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 26, 2019, 07:35:51 pm
Que tipo de error le sale? Si lo abre desde el menú de aplicaciones y se cierra, es probable que haya algún incoveniente, por lo tanto abra una terminal, ejecute msfconsole y compruebe que no haya errores.

Si aparece algún error, comparta una imagen, para asi poder ayudarlo.
« Última modificación: Noviembre 26, 2019, 07:37:28 pm por Kirari »
Jamás te contarán la verdadera versión, siempre te dirán la suya... Por eso... Si quieres saber la verdad, debes buscarla tú mismo...

Desconectado Goleman

  • *
  • Underc0der
  • Mensajes: 59
  • Actividad:
    3.33%
  • Country: 00
  • Reputación -1
    • Ver Perfil

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 27, 2019, 10:38:37 am
Lo raro es eso Kirari, que no me sale ningún error.
Abro metasploit-framework desde la aplicación y es como si abriese una terminal normal.
Introduzco msfconsole y no me sale ningún error. Solo dice:
root@You are not allowed to view links. Register or Login:~# msfconsole
WARNING! The following modules could not be loaded!
[-]     /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb
[-] Please see /root/.msf4/logs/framework.log for details.

Movida ...

Marked as best answer by Goleman en Noviembre 28, 2019, 05:50:29 am

Conectado Kirari

  • *
  • Moderador
  • Mensajes: 193
  • Actividad:
    100%
  • Country: ru
  • Reputación 11
  • No dejes que el mundo te corrompa
    • Ver Perfil
    • Baúl para el público

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 27, 2019, 04:51:03 pm
Has seguido los pasos que te he dicho anteriormente?
Jamás te contarán la verdadera versión, siempre te dirán la suya... Por eso... Si quieres saber la verdad, debes buscarla tú mismo...

Desconectado Goleman

  • *
  • Underc0der
  • Mensajes: 59
  • Actividad:
    3.33%
  • Country: 00
  • Reputación -1
    • Ver Perfil

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 27, 2019, 04:59:41 pm
si, los he seguido, pero metasploit no se abre desde la aplicación.
De hecho, cree una nueva maquina virtual de Kali Linux y, si puedo abrir metasploit desde la aplicación metasploit-framework, aunque la advertencia es la misma a la de la maquina anterior. Entonces la advertencia ya no me preocupa. Ciertamente agregue un exploit y luego actualice, pero no es el de la advertencia.
Lo raro es que no se abra metasploit desde la aplicación, pero bueno, como he creado una maquina virtual nueva, no me preocupa tanto, anuque, tengo mucho instalado y me gustaría resolver el problema.
Imagina que abres metasploit desde la aplicación y, te sale una ventana de terminal normal y sin decir ningún error.
Gracias Kirari-maquina

Desconectado Goleman

  • *
  • Underc0der
  • Mensajes: 59
  • Actividad:
    3.33%
  • Country: 00
  • Reputación -1
    • Ver Perfil

Re:Duda por Error Metasploit-Framework

  • en: Noviembre 28, 2019, 05:51:35 am
You are not allowed to view links. Register or Login
Has seguido los pasos que te he dicho anteriormente?
Buenos días Kirari, el problema de abrir metasploit-framework desde la aplicación se ha resuelto con la ultima actualización.

 

[SOLUCIONADO] ¿Kali Linux o Kali Linux Ligth ?

Iniciado por worq

Respuestas: 2
Vistas: 27083
Último mensaje Noviembre 21, 2017, 12:28:54 pm
por Codig0Bit
[SOLUCIONADO] Multiuploader de imagenes con mysql, hosting de imagenes con mysql

Iniciado por graphixx

Respuestas: 4
Vistas: 14344
Último mensaje Marzo 26, 2013, 05:42:58 pm
por Xt3mP
[SOLUCIONADO] ¿Como publicar un software como software libre?

Iniciado por FuriosoJack

Respuestas: 2
Vistas: 12108
Último mensaje Mayo 23, 2017, 07:24:22 am
por HATI
[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 18386
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Ayuda urgente con Virus "Virus.Win32Sality"

Iniciado por Napsters

Respuestas: 6
Vistas: 17255
Último mensaje Junio 11, 2012, 03:38:18 am
por Satyricon