comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[Ayuda] Auto Instalador

  • 5 Respuestas
  • 2649 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado fortil

  • *
  • Underc0der
  • Mensajes: 175
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • Email
« en: Enero 18, 2013, 12:38:11 pm »
Resulta que estoy tratando de hacer un auto instalador de un programa pero el programa me pide derechos de admin al ejecutarlo (para instalar)

lo que necesito es tratar de que no me pida eso, porque creo que al salir la ventana de control de cuentas de usuario el script no funciona y no sigue su curso normal.

he tratado de hacer lo siguiente:
Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
Run('runas /user:administrator /savecred programa')

pero me aparece el cmd pidiéndome la contraseña y aunque le de la contraseña correcta no se ejecuta el programa.

gracias

Desconectado k0ws

  • *
  • Underc0der
  • Mensajes: 145
  • Actividad:
    0%
  • Reputación 0
  • I'm Back
    • Ver Perfil
  • Skype: k0wsit0
« Respuesta #1 en: Enero 18, 2013, 09:54:54 pm »
Utiliza esto al principio del script, de esta forma, el UAC, solo saltara al principio del programa, y no durante el ni en ningun momento de la ejecucion de este.

Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
#AutoIt3Wrapper_Res_requestedExecutionLevel=requireAdministrator
Fuente: No tienes permisos para ver links. Registrate o Entra con tu cuenta

-Saludos-

Desconectado fortil

  • *
  • Underc0der
  • Mensajes: 175
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • Email
« Respuesta #2 en: Enero 19, 2013, 01:14:32 am »
k0ws eres mi heroe, muchas gracias jejej

xD

-----------------------------------
Pero ahora tengo dos problemas mas, que se pueden mencionar acá porque sigue siendo con el AutoInstalador.

El primero es que cuando trato de usar el AU3Recoder; resulta que no me guarda nada (absolutamente nada, mientras el programa está en la ventana de instalación (ni por medio de clicks, ni por medio de teclado) solamente me guarda las funciones creadas y eso que toca arreglarle el underline a una de ellas.

Lo segundo es que después de programar lo anterior a mano, intentando funciones de tipo ControlClick y Sen, con el AU3Info tomando los nombres como son de cada botón y cada control de ventana pero resulta que no me funciona nada, solamente se activa la ventana pero no comienza a hacer nada.

Acá pongo unos códigos que he puesto combinado con las funciones que me da el AU3Recoder..
Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
#region ---Au3Recorder generated code Start (v3.3.7.0)  ---

#region --- Internal functions Au3Recorder Start ---
Func _Au3RecordSetup()
Opt('WinWaitDelay',100)
Opt('WinDetectHiddenText',1)
Opt('MouseCoordMode',0)
EndFunc

Func _WinWaitActivate($title,$text,$timeout=0)
WinWait($title,$text,$timeout)
If Not WinActive($title,$text) Then WinActivate($title,$text)
WinWaitActive($title,$text,$timeout)
EndFunc

_AU3RecordSetup()

#endregion --- Internal functions Au3Recorder End ---
Run('ejecutable_programa.exe')
_WinWaitActivate("Setup -Programa","")
ControlClick('Setup -Programa','','Next') ;el Next lo he intentado tanto '&Netx >' como aparece en el AU3Info
_WinWaitActivate("Setup -Programa","")
ControlClick('Setup - Programa','Con el segundo texto','Next >') ;como de todas las maneras posibles
_WinWaitActivate("Setup -Programa","Con el segundo texto")
Send('{ENTER}{ENTER}{ENTER}{TAB}') ;tampoco me funciona en el programa
#endregion --- Au3Recorder generated code End ---
hasta de esta manera lo he puesto:
Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
ControlClick("Setup","","[CLASS:TNewButton; INSTANCE:1]")
ese es mas o menos algunos de los codigos que he utilzado..
« Última modificación: Enero 19, 2013, 02:11:16 am por fortil »

Desconectado k0ws

  • *
  • Underc0der
  • Mensajes: 145
  • Actividad:
    0%
  • Reputación 0
  • I'm Back
    • Ver Perfil
  • Skype: k0wsit0
« Respuesta #3 en: Enero 19, 2013, 09:40:05 am »
Pues lo veo dificil, por que no sacas la resolucion de la pantalla, luego su centro y de ahi con mousemove y mouseclick, clickeas lo que quieres?

-Saludos-

Desconectado fortil

  • *
  • Underc0der
  • Mensajes: 175
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • Email
« Respuesta #4 en: Enero 19, 2013, 11:24:46 am »
Porque creo que en otras pantallas no correría bien o si?

Desconectado k0ws

  • *
  • Underc0der
  • Mensajes: 145
  • Actividad:
    0%
  • Reputación 0
  • I'm Back
    • Ver Perfil
  • Skype: k0wsit0
« Respuesta #5 en: Enero 19, 2013, 07:40:19 pm »
De ahi te digo el obtener el centro de la pantalla(tu programa deberia aparecer en el centro de la misma) y en ese radio las coordenadas no varian

-Saludos-

 

¿Te gustó el post? COMPARTILO!



Manual Autoit en Español (Ayuda de Autoit)

Iniciado por Expermicid

Respuestas: 0
Vistas: 4416
Último mensaje Julio 21, 2014, 07:46:35 pm
por Expermicid
[AutoIt] Ayuda: alguna manera de formatear unidades

Iniciado por fortil

Respuestas: 1
Vistas: 1687
Último mensaje Abril 14, 2014, 06:29:19 am
por 0b3Y
Comenzar Con Auto-It [Descarga]

Iniciado por Xa0s

Respuestas: 0
Vistas: 1288
Último mensaje Junio 10, 2010, 11:20:38 am
por Xa0s
[Auto-It] Tomar IP

Iniciado por Xa0s

Respuestas: 0
Vistas: 1383
Último mensaje Junio 10, 2010, 11:21:39 am
por Xa0s