Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[Cramel] Brute Force Dictionary Creator by 79137913 [Aplicación + Source]

  • 0 Respuestas
  • 3609 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado BlackBlex

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    0%
  • Reputación 4
    • Ver Perfil
  • Skype: blackblex
  • Twitter: blackblex
« en: Julio 01, 2017, 07:04:10 pm »
Les traigo el siguiente Port de una aplicación echa por @79137913 en el post de Crea tu propio Creador de Diccionarios por Fuerza Bruta en VBNet en solo 3 Pasos



Descarga: Mega


Para hacer funcionar la aplicación solo necesitas ejecutar el archivo Dictionary.exe



Código fuente

Información

Aquí les traigo el source del Brute Force Dictionary Creator, como verán usa el mismo algoritmo para la generación del diccionario

Archivo Dictionary.cml
Código: Text
  1. '/**
  2. ' * Brute Force Dictionary
  3. ' *
  4. ' * @by         @79137913
  5. ' * @Ported by  Jovani Pérez Damián (@BlackBlex)
  6. ' *
  7. ' * ==============Information==============
  8. ' *      Filename: Dictionary.cml
  9. ' * ---------------------------------------
  10. '*/
  11. Importar "Cramel.cml"
  12. Importar "MSVBVM60\MSVBVM60.cml"
  13. Importar "Constantes.cml"
  14. Importar "Interfaz\Interfaz.cml"
  15. Importar "Archivo.cml"
  16.  
  17. Var frame:CMLframe
  18. Var checkNum, checkMin, checkEspMin, checkSim, checkMay, checkEspMay, checkAdd:CMLCheckbox
  19. Var cajaAdd, cajaDe, cajaHas:CMLCajatexto
  20. Var etiquetaGen, etiquetaHas, etiquetaCar:CMLEtiqueta
  21. Var botonGenerar:CMLBotón
  22. Var grupoLetras:CMLGroupbox
  23. Var diccionarioArchivo:ArchivoC
  24.  
  25. Const Sym = "/\!·$%&/()='""¡¿?<>., :;-_*+" 'Simbolos
  26. Const Num = "0123456789"                   'Numeros
  27. Const Min = "abcdefghijklmnopqrstuvwxyz"   'Letras Minusculas
  28. Const May = "ABCDEFGHIJKLMNOPQRSTUVWXYZ"   'Letras Mayusculas
  29. Const SpL = "áéíóúàèìòùâêîôûäëïöüçñ"       'Letras Especiales Minusculas
  30. Const SpU = "ÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛÄËÏÖÜÇÑ"       'Letras Especiales Mayusculas
  31.  
  32. Crear frame
  33. Crear checkNum
  34. Crear checkMin
  35. Crear checkEspMin
  36. Crear checkSim
  37. Crear checkMay
  38. Crear checkEspMay
  39. Crear checkAdd
  40. Crear cajaAdd
  41. Crear cajaDe
  42. Crear cajaHas
  43. Crear etiquetaGen
  44. Crear etiquetaHas
  45. Crear etiquetaCar
  46. Crear botonGenerar
  47. Crear grupoLetras
  48. Crear diccionarioArchivo
  49.  
  50.     frame.Texto = "Brute Force Dictionary Creator .Net by 79137913"
  51.     frame.Ancho = 410
  52.     frame.Alto = 250
  53.     frame.Padre = 0
  54.     frame.Centrar = 1
  55.     frame.construir(WS_OVERLAPPED+WS_CAPTION+WS_SYSMENU)
  56.  
  57.     grupoLetras.Texto = "Elige las letras que contendra el diccionario"
  58.     grupoLetras.PosX  = 10
  59.     grupoLetras.PosY  = 10
  60.     grupoLetras.Ancho = frame.Ancho - 30
  61.     grupoLetras.Alto  = (frame.Alto/2) + 10
  62.     grupoLetras.Padre = frame.hWnd
  63.     grupoLetras.fuente.Nombre = "Arial"
  64.     grupoLetras.fuente.Tamaño = 11
  65.     grupoLetras.construir()
  66.  
  67.         checkNum.Texto = "Numeros"
  68.         checkNum.PosX  = 20
  69.         checkNum.PosY  = 35
  70.         checkNum.Ancho = 80
  71.         checkNum.Alto  = 20
  72.         checkNum.Padre = frame.hWnd
  73.         checkNum.fuente.Nombre = "Arial"
  74.         checkNum.fuente.Tamaño = 11
  75.         checkNum.construir()
  76.  
  77.         checkMin.Texto = "Minusculas"
  78.         checkMin.PosX  = 10 + (checkNum.Ancho + checkNum.PosX)
  79.         checkMin.PosY  = checkNum.PosY
  80.         checkMin.Ancho = 90
  81.         checkMin.Alto  = 20
  82.         checkMin.Padre = frame.hWnd
  83.         checkMin.fuente.Nombre = "Arial"
  84.         checkMin.fuente.Tamaño = 11
  85.         checkMin.construir()
  86.  
  87.         checkEspMin.Texto = "Especiales Minusculas"
  88.         checkEspMin.PosX  = 10 + (checkMin.Ancho + checkMin.PosX)
  89.         checkEspMin.PosY  = checkMin.PosY
  90.         checkEspMin.Ancho = 170
  91.         checkEspMin.Alto  = 20
  92.         checkEspMin.Padre = frame.hWnd
  93.         checkEspMin.fuente.Nombre = "Arial"
  94.         checkEspMin.fuente.Tamaño = 11
  95.         checkEspMin.construir()
  96.  
  97.         checkSim.Texto = "Simbolos"
  98.         checkSim.PosX  = 20
  99.         checkSim.PosY  = 5 + (checkNum.Alto + checkNum.PosY)
  100.         checkSim.Ancho = 80
  101.         checkSim.Alto  = 20
  102.         checkSim.Padre = frame.hWnd
  103.         checkSim.fuente.Nombre = "Arial"
  104.         checkSim.fuente.Tamaño = 11
  105.         checkSim.construir()
  106.  
  107.         checkMay.Texto = "Mayusculas"
  108.         checkMay.PosX  = 10 + (checkSim.Ancho + checkSim.PosX)
  109.         checkMay.PosY  = checkSim.PosY
  110.         checkMay.Ancho = 95
  111.         checkMay.Alto  = 20
  112.         checkMay.Padre = frame.hWnd
  113.         checkMay.fuente.Nombre = "Arial"
  114.         checkMay.fuente.Tamaño = 11
  115.         checkMay.construir()
  116.  
  117.         checkEspMay.Texto = "Especiales Mayusculas"
  118.         checkEspMay.PosX  = 5 + (checkMay.Ancho + checkMay.PosX)
  119.         checkEspMay.PosY  = checkMay.PosY
  120.         checkEspMay.Ancho = 170
  121.         checkEspMay.Alto  = 20
  122.         checkEspMay.Padre = frame.hWnd
  123.         checkEspMay.fuente.Nombre = "Arial"
  124.         checkEspMay.fuente.Tamaño = 11
  125.         checkEspMay.construir()
  126.  
  127.         checkAdd.Texto = "Agregar los siguientes caracteres"
  128.         checkAdd.PosX  = 20
  129.         checkAdd.PosY  = 5 + (checkSim.Alto + checkSim.PosY)
  130.         checkAdd.Ancho = frame.Ancho - 60
  131.         checkAdd.Alto  = 20
  132.         checkAdd.Padre = frame.hWnd
  133.         checkAdd.fuente.Nombre = "Arial"
  134.         checkAdd.fuente.Tamaño = 11
  135.         checkAdd.construir()
  136.  
  137.         cajaAdd.PosX  = 20
  138.         cajaAdd.PosY  = 5 + (checkAdd.Alto + checkAdd.PosY)
  139.         cajaAdd.Ancho = frame.Ancho - 50
  140.         cajaAdd.Alto  = 25
  141.         cajaAdd.Padre = frame.hWnd
  142.         cajaAdd.fuente.Nombre = "Arial"
  143.         cajaAdd.fuente.Tamaño = 11
  144.         cajaAdd.Deshabilitado = Verdad
  145.         cajaAdd.construir()
  146.  
  147.     grupoLetras.cerrar()
  148.  
  149.     etiquetaGen.Texto = "Generar palabras desde"
  150.     etiquetaGen.PosX  = 10
  151.     etiquetaGen.PosY  = (grupoLetras.Alto + grupoLetras.PosY) + 10
  152.     etiquetaGen.Ancho = 160
  153.     etiquetaGen.Alto  = 30
  154.     etiquetaGen.Padre = frame.hWnd
  155.     etiquetaGen.fuente.Nombre = "Arial"
  156.     etiquetaGen.fuente.Tamaño = 11
  157.     etiquetaGen.construir()
  158.  
  159.     cajaDe.Texto = "2"
  160.     cajaDe.PosX  = (etiquetaGen.PosX + etiquetaGen.Ancho)+2
  161.     cajaDe.PosY  = etiquetaGen.PosY-5
  162.     cajaDe.Ancho = 30
  163.     cajaDe.Alto  = 25
  164.     cajaDe.Padre = frame.hWnd
  165.     cajaDe.fuente.Nombre = "Arial"
  166.     cajaDe.fuente.Tamaño = 11
  167.     cajaDe.construir(ES_NUMBER)
  168.     cajaDe.Limite = 2
  169.  
  170.     etiquetaHas.Texto = "hasta"
  171.     etiquetaHas.PosX  = (cajaDe.PosX + cajaDe.Ancho) + 5
  172.     etiquetaHas.PosY  = etiquetaGen.PosY
  173.     etiquetaHas.Ancho = 40
  174.     etiquetaHas.Alto  = 30
  175.     etiquetaHas.Padre = frame.hWnd
  176.     etiquetaHas.fuente.Nombre = "Arial"
  177.     etiquetaHas.fuente.Tamaño = 11
  178.     etiquetaHas.construir()
  179.  
  180.     cajaHas.Texto = "4"
  181.     cajaHas.PosX  = (etiquetaHas.PosX + etiquetaHas.Ancho)+2
  182.     cajaHas.PosY  = etiquetaGen.PosY-5
  183.     cajaHas.Ancho = 30
  184.     cajaHas.Alto  = 25
  185.     cajaHas.Padre = frame.hWnd
  186.     cajaHas.fuente.Nombre = "Arial"
  187.     cajaHas.fuente.Tamaño = 11
  188.     cajaHas.construir(ES_NUMBER)
  189.     cajaHas.Limite = 2
  190.  
  191.     etiquetaCar.Texto = "caracteres"
  192.     etiquetaCar.PosX  = (cajaHas.PosX + cajaHas.Ancho) + 5
  193.     etiquetaCar.PosY  = etiquetaHas.PosY
  194.     etiquetaCar.Ancho = 150
  195.     etiquetaCar.Alto  = 30
  196.     etiquetaCar.Padre = frame.hWnd
  197.     etiquetaCar.fuente.Nombre = "Arial"
  198.     etiquetaCar.fuente.Tamaño = 11
  199.     etiquetaCar.construir()
  200.  
  201.     botonGenerar.Texto = "Generar"
  202.     botonGenerar.PosX  = frame.Ancho - 90
  203.     botonGenerar.PosY  = frame.Alto - 70
  204.     botonGenerar.Ancho = 70
  205.     botonGenerar.Alto  = 30
  206.     botonGenerar.Padre = frame.hWnd
  207.     botonGenerar.fuente.Nombre = "Arial"
  208.     botonGenerar.fuente.Tamaño = 11
  209.     botonGenerar.construir()
  210.  
  211.     frame.mostrar
  212.     frame.correr
  213.  
  214. Proc checkAddEventClick(hWnd:Entero,Botón:Byte,Presionado:Booleano,X,Y:Entero)
  215.     Seleccionar Botón
  216.         Caso BOTON_IZQUIERDO
  217.             Seleccionar Presionado
  218.                 Caso Falso
  219.                     Si ( checkAdd.estaSeleccionado ) Entonces
  220.                         cajaAdd.Deshabilitado = Falso
  221.                     SiNo
  222.                         cajaAdd.Deshabilitado = Verdad
  223.                     FinSi
  224.             FinSeleccionar
  225.     FinSeleccionar
  226. FinProc
  227.  
  228. Proc botonGenerarEventClick(hWnd:Entero,Botón:Byte,Presionado:Booleano,X,Y:Entero)
  229.     Seleccionar Botón
  230.         Caso BOTON_IZQUIERDO
  231.             Seleccionar Presionado
  232.                 Caso Falso
  233.                     Var hilo, hiloID:Entero
  234.                     hilo = CreateThread(Nulo, 0, [email protected], Nulo, 0, [email protected])
  235.             FinSeleccionar
  236.     FinSeleccionar
  237. FinProc
  238.  
  239. Proc generarDic
  240.     Var CantLet, BufferPalabras, CT, CantPos, Desde, Hasta, Posiciones[]:Entero
  241.     Var Palabras[]:Cadena
  242.  
  243.     Var Letras:Cadena 'string que contendra todos los caracteres a combinar para hacer el diccionario
  244.  
  245.     Letras = ""
  246.  
  247.     'by 79137913 for Underc0de.org
  248.     'creamos secuencia de caracteres a utilizar
  249.     Si (checkNum.estaSeleccionado) Entonces
  250.         Letras = Letras + Num 'si Numeros esta tildado agregamos eso a la cadena
  251.     FinSi
  252.     Si (checkSim.estaSeleccionado) Entonces
  253.         Letras = Letras + Sym 'si Simbolos esta tildado agregamos eso a la cadena
  254.     FinSi
  255.     Si (checkMin.estaSeleccionado) Entonces
  256.         Letras = Letras + Min 'si Letras Minusculas esta tildado agregamos eso a la cadena
  257.     FinSi
  258.     Si (checkMay.estaSeleccionado) Entonces
  259.         Letras = Letras + May 'si Letras Mayusculas esta tildado agregamos eso a la cadena
  260.     FinSi
  261.     Si (checkEspMin.estaSeleccionado) Entonces
  262.         Letras = Letras + SpL 'si Letras Especiales Minusculas esta tildado agregamos eso a la cadena
  263.     FinSi
  264.     Si (checkEspMay.estaSeleccionado) Entonces
  265.         Letras = Letras + SpU 'si Letras Especiales Mayusculas esta tildado agregamos eso a la cadena
  266.     FinSi
  267.     Si (checkAdd.estaSeleccionado) Entonces
  268.         Letras = Letras + cajaAdd.cTexto 'si Agregar Siguientes Caracters esta tildado agregamos eso a la cadena
  269.     FinSi
  270.  
  271.     CantLet = CadLong(Letras) - 1 'cantidad de letras
  272.     BufferPalabras = 10000
  273.     ReDim Palabras, BufferPalabras 'aqui se guardaran las combinaciones mientras las vamos generando en este ejemplo iremos guardando de a 10000 combinaciones
  274.     CT = 0 'este contador nos dira cuantas palabras estan pendientes de guardar en el archivo
  275.     CantPos = 0 'Cantidad de letras palabra actual
  276.     Desde = CadEnt(cajaDe.cTexto) 'desde que cantidad de caracteres
  277.     Hasta = CadEnt(cajaHas.cTexto) 'hasta que cantidad de caracteres
  278.  
  279.     Mensaje("Se iniciara el proceso, puede tardar mucho, para detener cierre la aplicacion con el Administrador de Tareas.", "ATENCION")
  280.  
  281.     diccionarioArchivo.abrir("diccionario.txt", GENERIC_WRITE, CREATE_ALWAYS)
  282.  
  283.     Var x, y, palfile:Entero
  284.  
  285.     y = 0
  286.     Contar y a (Hasta - Desde)
  287.         CantPos = (Desde + y) - 1 'establecemos el tamañode la combinacion actual
  288.         ReDim Posiciones, CantPos
  289.         Repetir
  290.             x = 0
  291.             Contar x a CantPos 'una vez por cada posicion que tenga que tener la palabra
  292.                 Palabras[CT] = Palabras[CT] + Parte(Letras, Posiciones[x]+1, Posiciones[x]+1) 'armamos una combinacion uniendo los caracteres de la cadena letras
  293.             Seguir
  294.  
  295.             CT = CT + 1 'incrementamos CT en 1
  296.             Posiciones[0] = Posiciones[0] + 1 'incrementamos la primera letra de posiciones (para que pase de "a" a "b" por ejemplo)
  297.             x = 0
  298.             Contar x a (CantPos - 1) 'nos fijamos si alguna posicion es mayor a la cantidad de letras si es asi volvemos a 0 esa posicion e incrementamos la siguiente
  299.                 Si (Posiciones[x] > CantLet ) Entonces
  300.                     Posiciones[x] = 0
  301.                     Posiciones[x+1] = Posiciones[x+1] + 1
  302.                 FinSi
  303.             Seguir
  304.  
  305.             Si (CT = (BufferPalabras + 1) ) Entonces
  306.                 palfile = 0
  307.                 Mientras palfile <= &Palabras
  308.                     diccionarioArchivo.escribir(Palabras[palfile] + CRLF) 'escribimos nuestro buffer de palabras en el archivo linea por linea
  309.                     palfile = palfile + 1
  310.                 FinMientras
  311.                 CT = 0 'volvemos el contador a 0
  312.                 ReDim Palabras, BufferPalabras 'borramos el buffer de palabras
  313.             FinSi
  314.  
  315.         HastaQue Posiciones[CantPos] = CantLet +1
  316.     Seguir
  317.  
  318.     Si (CT > 0) Entonces 'si hay palabras pendientes de escribir
  319.         ReDim Preservar Palabras, (CT - 1)        
  320.         palfile = 0
  321.         Mientras palfile < &Palabras
  322.             diccionarioArchivo.escribir(Palabras[palfile] + CRLF) 'escribimos nuestro buffer de palabras en el archivo linea por linea
  323.             palfile = palfile + 1
  324.         FinMientras
  325.         CT = 0
  326.     FinSi
  327.  
  328.     Mensaje("Terminado archivo guardado como diccionario.txt", "ATENCION")
  329.     diccionarioArchivo.cerrar()
  330.  
  331. FinProc
  332.  
  333. Destruir diccionarioArchivo
  334. Destruir grupoLetras
  335. Destruir botonGenerar
  336. Destruir etiquetaCar
  337. Destruir etiquetaHas
  338. Destruir etiquetaGen
  339. Destruir cajaHas
  340. Destruir cajaDe
  341. Destruir cajaAdd
  342. Destruir checkAdd
  343. Destruir checkEspMay
  344. Destruir checkMay
  345. Destruir checkSim
  346. Destruir checkEspMin
  347. Destruir checkMin
  348. Destruir checkNum
  349. Destruir frame



 

¿Te gustó el post? COMPARTILO!



Source Go Dork Scan Beta v0.3 by ReiGel_ado

Iniciado por reigelado

Respuestas: 2
Vistas: 2311
Último mensaje Enero 11, 2016, 09:15:09 pm
por reigelado
Source Go Dork Scan Beta v0.5 by ReiGel_ado

Iniciado por reigelado

Respuestas: 0
Vistas: 1973
Último mensaje Enero 20, 2016, 10:46:02 pm
por reigelado
Como trabajar Cramel con Sublime Text | Actualizado [Cramel2| 20/Junio/17]

Iniciado por BlackBlex

Respuestas: 1
Vistas: 2194
Último mensaje Febrero 23, 2017, 08:18:21 am
por ANTRAX
[Cramel] Regedit.cml ~ Crea, Edita y Elimina claves del Registro

Iniciado por BlackBlex

Respuestas: 0
Vistas: 3575
Último mensaje Julio 05, 2017, 08:30:39 pm
por BlackBlex
[Cramel] Componentes para Ventanas | 5 de Julio del 2017

Iniciado por BlackBlex

Respuestas: 0
Vistas: 3642
Último mensaje Abril 10, 2017, 04:25:47 pm
por BlackBlex