Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[Cramel] Brute Force Dictionary Creator by 79137913 [Aplicación + Source]

  • 0 Respuestas
  • 2637 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado BlackBlex

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    0%
  • Reputación 4
    • Ver Perfil
  • Skype: blackblex
  • Twitter: blackblex
« en: Julio 01, 2017, 07:04:10 pm »
Les traigo el siguiente Port de una aplicación echa por @79137913 en el post de Crea tu propio Creador de Diccionarios por Fuerza Bruta en VBNet en solo 3 Pasos



Descarga: Mega


Para hacer funcionar la aplicación solo necesitas ejecutar el archivo Dictionary.exe



Código fuente

Información

Aquí les traigo el source del Brute Force Dictionary Creator, como verán usa el mismo algoritmo para la generación del diccionario

Archivo Dictionary.cml
Código: Text
  1. '/**
  2. ' * Brute Force Dictionary
  3. ' *
  4. ' * @by         @79137913
  5. ' * @Ported by  Jovani Pérez Damián (@BlackBlex)
  6. ' *
  7. ' * ==============Information==============
  8. ' *      Filename: Dictionary.cml
  9. ' * ---------------------------------------
  10. '*/
  11. Importar "Cramel.cml"
  12. Importar "MSVBVM60\MSVBVM60.cml"
  13. Importar "Constantes.cml"
  14. Importar "Interfaz\Interfaz.cml"
  15. Importar "Archivo.cml"
  16.  
  17. Var frame:CMLframe
  18. Var checkNum, checkMin, checkEspMin, checkSim, checkMay, checkEspMay, checkAdd:CMLCheckbox
  19. Var cajaAdd, cajaDe, cajaHas:CMLCajatexto
  20. Var etiquetaGen, etiquetaHas, etiquetaCar:CMLEtiqueta
  21. Var botonGenerar:CMLBotón
  22. Var grupoLetras:CMLGroupbox
  23. Var diccionarioArchivo:ArchivoC
  24.  
  25. Const Sym = "/\!·$%&/()='""¡¿?<>., :;-_*+" 'Simbolos
  26. Const Num = "0123456789"                   'Numeros
  27. Const Min = "abcdefghijklmnopqrstuvwxyz"   'Letras Minusculas
  28. Const May = "ABCDEFGHIJKLMNOPQRSTUVWXYZ"   'Letras Mayusculas
  29. Const SpL = "áéíóúàèìòùâêîôûäëïöüçñ"       'Letras Especiales Minusculas
  30. Const SpU = "ÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛÄËÏÖÜÇÑ"       'Letras Especiales Mayusculas
  31.  
  32. Crear frame
  33. Crear checkNum
  34. Crear checkMin
  35. Crear checkEspMin
  36. Crear checkSim
  37. Crear checkMay
  38. Crear checkEspMay
  39. Crear checkAdd
  40. Crear cajaAdd
  41. Crear cajaDe
  42. Crear cajaHas
  43. Crear etiquetaGen
  44. Crear etiquetaHas
  45. Crear etiquetaCar
  46. Crear botonGenerar
  47. Crear grupoLetras
  48. Crear diccionarioArchivo
  49.  
  50.     frame.Texto = "Brute Force Dictionary Creator .Net by 79137913"
  51.     frame.Ancho = 410
  52.     frame.Alto = 250
  53.     frame.Padre = 0
  54.     frame.Centrar = 1
  55.     frame.construir(WS_OVERLAPPED+WS_CAPTION+WS_SYSMENU)
  56.  
  57.     grupoLetras.Texto = "Elige las letras que contendra el diccionario"
  58.     grupoLetras.PosX  = 10
  59.     grupoLetras.PosY  = 10
  60.     grupoLetras.Ancho = frame.Ancho - 30
  61.     grupoLetras.Alto  = (frame.Alto/2) + 10
  62.     grupoLetras.Padre = frame.hWnd
  63.     grupoLetras.fuente.Nombre = "Arial"
  64.     grupoLetras.fuente.Tamaño = 11
  65.     grupoLetras.construir()
  66.  
  67.         checkNum.Texto = "Numeros"
  68.         checkNum.PosX  = 20
  69.         checkNum.PosY  = 35
  70.         checkNum.Ancho = 80
  71.         checkNum.Alto  = 20
  72.         checkNum.Padre = frame.hWnd
  73.         checkNum.fuente.Nombre = "Arial"
  74.         checkNum.fuente.Tamaño = 11
  75.         checkNum.construir()
  76.  
  77.         checkMin.Texto = "Minusculas"
  78.         checkMin.PosX  = 10 + (checkNum.Ancho + checkNum.PosX)
  79.         checkMin.PosY  = checkNum.PosY
  80.         checkMin.Ancho = 90
  81.         checkMin.Alto  = 20
  82.         checkMin.Padre = frame.hWnd
  83.         checkMin.fuente.Nombre = "Arial"
  84.         checkMin.fuente.Tamaño = 11
  85.         checkMin.construir()
  86.  
  87.         checkEspMin.Texto = "Especiales Minusculas"
  88.         checkEspMin.PosX  = 10 + (checkMin.Ancho + checkMin.PosX)
  89.         checkEspMin.PosY  = checkMin.PosY
  90.         checkEspMin.Ancho = 170
  91.         checkEspMin.Alto  = 20
  92.         checkEspMin.Padre = frame.hWnd
  93.         checkEspMin.fuente.Nombre = "Arial"
  94.         checkEspMin.fuente.Tamaño = 11
  95.         checkEspMin.construir()
  96.  
  97.         checkSim.Texto = "Simbolos"
  98.         checkSim.PosX  = 20
  99.         checkSim.PosY  = 5 + (checkNum.Alto + checkNum.PosY)
  100.         checkSim.Ancho = 80
  101.         checkSim.Alto  = 20
  102.         checkSim.Padre = frame.hWnd
  103.         checkSim.fuente.Nombre = "Arial"
  104.         checkSim.fuente.Tamaño = 11
  105.         checkSim.construir()
  106.  
  107.         checkMay.Texto = "Mayusculas"
  108.         checkMay.PosX  = 10 + (checkSim.Ancho + checkSim.PosX)
  109.         checkMay.PosY  = checkSim.PosY
  110.         checkMay.Ancho = 95
  111.         checkMay.Alto  = 20
  112.         checkMay.Padre = frame.hWnd
  113.         checkMay.fuente.Nombre = "Arial"
  114.         checkMay.fuente.Tamaño = 11
  115.         checkMay.construir()
  116.  
  117.         checkEspMay.Texto = "Especiales Mayusculas"
  118.         checkEspMay.PosX  = 5 + (checkMay.Ancho + checkMay.PosX)
  119.         checkEspMay.PosY  = checkMay.PosY
  120.         checkEspMay.Ancho = 170
  121.         checkEspMay.Alto  = 20
  122.         checkEspMay.Padre = frame.hWnd
  123.         checkEspMay.fuente.Nombre = "Arial"
  124.         checkEspMay.fuente.Tamaño = 11
  125.         checkEspMay.construir()
  126.  
  127.         checkAdd.Texto = "Agregar los siguientes caracteres"
  128.         checkAdd.PosX  = 20
  129.         checkAdd.PosY  = 5 + (checkSim.Alto + checkSim.PosY)
  130.         checkAdd.Ancho = frame.Ancho - 60
  131.         checkAdd.Alto  = 20
  132.         checkAdd.Padre = frame.hWnd
  133.         checkAdd.fuente.Nombre = "Arial"
  134.         checkAdd.fuente.Tamaño = 11
  135.         checkAdd.eventos.Mouse.Clic@ = checkAddEventClick@
  136.         checkAdd.construir()
  137.  
  138.         cajaAdd.PosX  = 20
  139.         cajaAdd.PosY  = 5 + (checkAdd.Alto + checkAdd.PosY)
  140.         cajaAdd.Ancho = frame.Ancho - 50
  141.         cajaAdd.Alto  = 25
  142.         cajaAdd.Padre = frame.hWnd
  143.         cajaAdd.fuente.Nombre = "Arial"
  144.         cajaAdd.fuente.Tamaño = 11
  145.         cajaAdd.Deshabilitado = Verdad
  146.         cajaAdd.construir()
  147.  
  148.     grupoLetras.cerrar()
  149.  
  150.     etiquetaGen.Texto = "Generar palabras desde"
  151.     etiquetaGen.PosX  = 10
  152.     etiquetaGen.PosY  = (grupoLetras.Alto + grupoLetras.PosY) + 10
  153.     etiquetaGen.Ancho = 160
  154.     etiquetaGen.Alto  = 30
  155.     etiquetaGen.Padre = frame.hWnd
  156.     etiquetaGen.fuente.Nombre = "Arial"
  157.     etiquetaGen.fuente.Tamaño = 11
  158.     etiquetaGen.construir()
  159.  
  160.     cajaDe.Texto = "2"
  161.     cajaDe.PosX  = (etiquetaGen.PosX + etiquetaGen.Ancho)+2
  162.     cajaDe.PosY  = etiquetaGen.PosY-5
  163.     cajaDe.Ancho = 30
  164.     cajaDe.Alto  = 25
  165.     cajaDe.Padre = frame.hWnd
  166.     cajaDe.fuente.Nombre = "Arial"
  167.     cajaDe.fuente.Tamaño = 11
  168.     cajaDe.construir(ES_NUMBER)
  169.     cajaDe.Limite = 2
  170.  
  171.     etiquetaHas.Texto = "hasta"
  172.     etiquetaHas.PosX  = (cajaDe.PosX + cajaDe.Ancho) + 5
  173.     etiquetaHas.PosY  = etiquetaGen.PosY
  174.     etiquetaHas.Ancho = 40
  175.     etiquetaHas.Alto  = 30
  176.     etiquetaHas.Padre = frame.hWnd
  177.     etiquetaHas.fuente.Nombre = "Arial"
  178.     etiquetaHas.fuente.Tamaño = 11
  179.     etiquetaHas.construir()
  180.  
  181.     cajaHas.Texto = "4"
  182.     cajaHas.PosX  = (etiquetaHas.PosX + etiquetaHas.Ancho)+2
  183.     cajaHas.PosY  = etiquetaGen.PosY-5
  184.     cajaHas.Ancho = 30
  185.     cajaHas.Alto  = 25
  186.     cajaHas.Padre = frame.hWnd
  187.     cajaHas.fuente.Nombre = "Arial"
  188.     cajaHas.fuente.Tamaño = 11
  189.     cajaHas.construir(ES_NUMBER)
  190.     cajaHas.Limite = 2
  191.  
  192.     etiquetaCar.Texto = "caracteres"
  193.     etiquetaCar.PosX  = (cajaHas.PosX + cajaHas.Ancho) + 5
  194.     etiquetaCar.PosY  = etiquetaHas.PosY
  195.     etiquetaCar.Ancho = 150
  196.     etiquetaCar.Alto  = 30
  197.     etiquetaCar.Padre = frame.hWnd
  198.     etiquetaCar.fuente.Nombre = "Arial"
  199.     etiquetaCar.fuente.Tamaño = 11
  200.     etiquetaCar.construir()
  201.  
  202.     botonGenerar.Texto = "Generar"
  203.     botonGenerar.PosX  = frame.Ancho - 90
  204.     botonGenerar.PosY  = frame.Alto - 70
  205.     botonGenerar.Ancho = 70
  206.     botonGenerar.Alto  = 30
  207.     botonGenerar.Padre = frame.hWnd
  208.     botonGenerar.fuente.Nombre = "Arial"
  209.     botonGenerar.fuente.Tamaño = 11
  210.     botonGenerar.eventos.Mouse.Clic@ = botonGenerarEventClick@
  211.     botonGenerar.construir()
  212.  
  213.     frame.mostrar
  214.     frame.correr
  215.  
  216. Proc checkAddEventClick(hWnd:Entero,Botón:Byte,Presionado:Booleano,X,Y:Entero)
  217.     Seleccionar Botón
  218.         Caso BOTON_IZQUIERDO
  219.             Seleccionar Presionado
  220.                 Caso Falso
  221.                     Si ( checkAdd.estaSeleccionado ) Entonces
  222.                         cajaAdd.Deshabilitado = Falso
  223.                     SiNo
  224.                         cajaAdd.Deshabilitado = Verdad
  225.                     FinSi
  226.             FinSeleccionar
  227.     FinSeleccionar
  228. FinProc
  229.  
  230. Proc botonGenerarEventClick(hWnd:Entero,Botón:Byte,Presionado:Booleano,X,Y:Entero)
  231.     Seleccionar Botón
  232.         Caso BOTON_IZQUIERDO
  233.             Seleccionar Presionado
  234.                 Caso Falso
  235.                     Var hilo, hiloID:Entero
  236.                     hilo = CreateThread(Nulo, 0, generarDic@, Nulo, 0, hiloID@)
  237.             FinSeleccionar
  238.     FinSeleccionar
  239. FinProc
  240.  
  241. Proc generarDic
  242.     Var CantLet, BufferPalabras, CT, CantPos, Desde, Hasta, Posiciones[]:Entero
  243.     Var Palabras[]:Cadena
  244.  
  245.     Var Letras:Cadena 'string que contendra todos los caracteres a combinar para hacer el diccionario
  246.  
  247.     Letras = ""
  248.  
  249.     'by 79137913 for Underc0de.org
  250.     'creamos secuencia de caracteres a utilizar
  251.     Si (checkNum.estaSeleccionado) Entonces
  252.         Letras = Letras + Num 'si Numeros esta tildado agregamos eso a la cadena
  253.     FinSi
  254.     Si (checkSim.estaSeleccionado) Entonces
  255.         Letras = Letras + Sym 'si Simbolos esta tildado agregamos eso a la cadena
  256.     FinSi
  257.     Si (checkMin.estaSeleccionado) Entonces
  258.         Letras = Letras + Min 'si Letras Minusculas esta tildado agregamos eso a la cadena
  259.     FinSi
  260.     Si (checkMay.estaSeleccionado) Entonces
  261.         Letras = Letras + May 'si Letras Mayusculas esta tildado agregamos eso a la cadena
  262.     FinSi
  263.     Si (checkEspMin.estaSeleccionado) Entonces
  264.         Letras = Letras + SpL 'si Letras Especiales Minusculas esta tildado agregamos eso a la cadena
  265.     FinSi
  266.     Si (checkEspMay.estaSeleccionado) Entonces
  267.         Letras = Letras + SpU 'si Letras Especiales Mayusculas esta tildado agregamos eso a la cadena
  268.     FinSi
  269.     Si (checkAdd.estaSeleccionado) Entonces
  270.         Letras = Letras + cajaAdd.cTexto 'si Agregar Siguientes Caracters esta tildado agregamos eso a la cadena
  271.     FinSi
  272.  
  273.     CantLet = CadLong(Letras) - 1 'cantidad de letras
  274.     BufferPalabras = 10000
  275.     ReDim Palabras, BufferPalabras 'aqui se guardaran las combinaciones mientras las vamos generando en este ejemplo iremos guardando de a 10000 combinaciones
  276.     CT = 0 'este contador nos dira cuantas palabras estan pendientes de guardar en el archivo
  277.     CantPos = 0 'Cantidad de letras palabra actual
  278.     Desde = CadEnt(cajaDe.cTexto) 'desde que cantidad de caracteres
  279.     Hasta = CadEnt(cajaHas.cTexto) 'hasta que cantidad de caracteres
  280.  
  281.     Mensaje("Se iniciara el proceso, puede tardar mucho, para detener cierre la aplicacion con el Administrador de Tareas.", "ATENCION")
  282.  
  283.     diccionarioArchivo.abrir("diccionario.txt", GENERIC_WRITE, CREATE_ALWAYS)
  284.  
  285.     Var x, y, palfile:Entero
  286.  
  287.     y = 0
  288.     Contar y a (Hasta - Desde)
  289.         CantPos = (Desde + y) - 1 'establecemos el tamañode la combinacion actual
  290.         ReDim Posiciones, CantPos
  291.         Repetir
  292.             x = 0
  293.             Contar x a CantPos 'una vez por cada posicion que tenga que tener la palabra
  294.                 Palabras[CT] = Palabras[CT] + Parte(Letras, Posiciones[x]+1, Posiciones[x]+1) 'armamos una combinacion uniendo los caracteres de la cadena letras
  295.             Seguir
  296.  
  297.             CT = CT + 1 'incrementamos CT en 1
  298.             Posiciones[0] = Posiciones[0] + 1 'incrementamos la primera letra de posiciones (para que pase de "a" a "b" por ejemplo)
  299.             x = 0
  300.             Contar x a (CantPos - 1) 'nos fijamos si alguna posicion es mayor a la cantidad de letras si es asi volvemos a 0 esa posicion e incrementamos la siguiente
  301.                 Si (Posiciones[x] > CantLet ) Entonces
  302.                     Posiciones[x] = 0
  303.                     Posiciones[x+1] = Posiciones[x+1] + 1
  304.                 FinSi
  305.             Seguir
  306.  
  307.             Si (CT = (BufferPalabras + 1) ) Entonces
  308.                 palfile = 0
  309.                 Mientras palfile <= &Palabras
  310.                     diccionarioArchivo.escribir(Palabras[palfile] + CRLF) 'escribimos nuestro buffer de palabras en el archivo linea por linea
  311.                     palfile = palfile + 1
  312.                 FinMientras
  313.                 CT = 0 'volvemos el contador a 0
  314.                 ReDim Palabras, BufferPalabras 'borramos el buffer de palabras
  315.             FinSi
  316.  
  317.         HastaQue Posiciones[CantPos] = CantLet +1
  318.     Seguir
  319.  
  320.     Si (CT > 0) Entonces 'si hay palabras pendientes de escribir
  321.         ReDim Preservar Palabras, (CT - 1)        
  322.         palfile = 0
  323.         Mientras palfile < &Palabras
  324.             diccionarioArchivo.escribir(Palabras[palfile] + CRLF) 'escribimos nuestro buffer de palabras en el archivo linea por linea
  325.             palfile = palfile + 1
  326.         FinMientras
  327.         CT = 0
  328.     FinSi
  329.  
  330.     Mensaje("Terminado archivo guardado como diccionario.txt", "ATENCION")
  331.     diccionarioArchivo.cerrar()
  332.  
  333. FinProc
  334.  
  335. Destruir diccionarioArchivo
  336. Destruir grupoLetras
  337. Destruir botonGenerar
  338. Destruir etiquetaCar
  339. Destruir etiquetaHas
  340. Destruir etiquetaGen
  341. Destruir cajaHas
  342. Destruir cajaDe
  343. Destruir cajaAdd
  344. Destruir checkAdd
  345. Destruir checkEspMay
  346. Destruir checkMay
  347. Destruir checkSim
  348. Destruir checkEspMin
  349. Destruir checkMin
  350. Destruir checkNum
  351. Destruir frame



 

¿Te gustó el post? COMPARTILO!



Source Go Dork Scan Beta v0.3 by ReiGel_ado

Iniciado por reigelado

Respuestas: 2
Vistas: 1540
Último mensaje Enero 11, 2016, 09:15:09 pm
por reigelado
Source Go Dork Scan Beta v0.5 by ReiGel_ado

Iniciado por reigelado

Respuestas: 0
Vistas: 1362
Último mensaje Enero 20, 2016, 10:46:02 pm
por reigelado
Como trabajar Cramel con Sublime Text | Actualizado [Cramel2| 20/Junio/17]

Iniciado por BlackBlex

Respuestas: 1
Vistas: 1401
Último mensaje Febrero 23, 2017, 08:18:21 am
por ANTRAX
[Cramel] Regedit.cml ~ Crea, Edita y Elimina claves del Registro

Iniciado por BlackBlex

Respuestas: 0
Vistas: 2472
Último mensaje Julio 05, 2017, 08:30:39 pm
por BlackBlex
[Cramel] Componentes para Ventanas | 5 de Julio del 2017

Iniciado por BlackBlex

Respuestas: 0
Vistas: 2585
Último mensaje Abril 10, 2017, 04:25:47 pm
por BlackBlex