Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[Cramel] AdminFinder by 79137913 [Aplicación + Source]

  • 2 Respuestas
  • 4027 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado BlackBlex

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    0%
  • Reputación 4
    • Ver Perfil
  • Skype: blackblex
  • Twitter: blackblex
« en: Junio 25, 2017, 07:01:43 pm »
Les traigo el siguiente Port de una aplicación echa por @79137913 en el post de Crea tu propio AdminFinder con VB.NET en solo 3 pasos!

Esta aplicación por el momento esta realizada en modo Consola, en los siguientes días les traeré el modo gráfico.




Descarga: Mega


Para funcionar la aplicación necesita de un diccionario(paths.txt) donde contendrá todas las posibles carpetas de admins o archivos de login



Código fuente


Aquí les traigo el source del AdminFinder, como verán usa el mismo método de detección (cargar una lista, e ir comprobando cada una)

Archivo AdminFinder.cml
Código: Text
  1. '/**
  2. ' * AdminFinder
  3. ' *
  4. ' * @by         @79137913
  5. ' * @Ported by  Jovani Pérez Damián (@BlackBlex)
  6. ' *
  7. ' * ==============Information==============
  8. ' *      Filename: AdminFinder.cml
  9. ' * ---------------------------------------
  10. '*/
  11.  
  12. Importar "Cramel.cml"
  13. Importar "MSVBVM60\MSVBVM60.cml"
  14. Importar "Constantes.cml"
  15. Importar "APIS.cml"
  16. Importar "Archivo.cml"
  17. Importar "Consola.cml"
  18. Importar "HTTPRequest.cml"
  19.  
  20. Var cmd:Consola
  21. Var archivoC:ArchivoC
  22.  
  23. Var controlArchivo:Booleano
  24.  
  25. Var paths[], pathsFound:Cadena
  26. Var contenido, salida:Cadena
  27.  
  28. Crear archivoC
  29.     archivoC.abrir("paths.txt", GENERIC_READ, OPEN_EXISTING)
  30.     Si ( archivoC.conseguirPtr <> INVALID_HANDLE ) Entonces
  31.         contenido = archivoC.leer()
  32.         paths = Separar(contenido, CRLF)
  33.         controlArchivo = Verdad
  34.     SiNo
  35.         Mensaje("El archivo paths.txt no existe, favor de crearlo y poner su lista separada por linea")
  36.         controlArchivo = Falso
  37.     FinSi
  38.     archivoC.cerrar()
  39. Destruir archivoC
  40.  
  41. Var objetivo:Cadena
  42. Var correcto:Booleano
  43. correcto = Falso
  44.  
  45. Si ( controlArchivo ) Entonces
  46.     Crear cmd
  47.         cmd.establecerTitulo("AdminFinder by 79137913 ~ Ported to Cramel Console by BlackBlex")
  48.         cmd.escribirLinea(CRLF + "    /=======================\\")
  49.         cmd.escribirLinea("      Paths encontrados:" + EntCad(&paths))
  50.         cmd.escribirLinea("    \\=======================/" + CRLF)
  51.         Mientras correcto = Falso
  52.             cmd.escribir("(No incluya el http:// al inicio, ni el / al final)" + CRLF + "Ingrese el destino: ")
  53.             objetivo = cmd.leer
  54.             Si ( Buscar(objetivo, "http://") = Falso ) Entonces
  55.                 correcto = Verdad
  56.             FinSi
  57.         FinMientras
  58.         Si ( correcto ) Entonces        
  59.             Si ( buscarObjetivos ) Entonces
  60.                 cmd.limpiarConsola()
  61.                 cmd.escribirLinea(CRLF)
  62.                 cmd.escribirLinea("  URLS encontradas: ")
  63.                 cmd.escribir(pathsFound + CRLF)
  64.                 cmd.pausarConsola()
  65.             SiNo
  66.                 cmd.limpiarConsola()
  67.                 cmd.escribirLinea(CRLF)
  68.                 cmd.escribirLinea("  No se encontro ninguna url" + CRLF)
  69.                 cmd.pausarConsola()
  70.             FinSi
  71.         FinSi
  72.     Destruir cmd
  73. FinSi
  74.  
  75. Proc buscarObjetivos:Booleano
  76.     cmd.escribirLinea("  Examinando...")
  77.     Var request:HTTP
  78.     Var text:Cadena
  79.     Var id:Entero
  80.     Resultado = Falso
  81.     Crear request
  82.         id = 0
  83.         Contar id a &paths Paso 1
  84.             request.Metodo = "GET"
  85.             request.Puerto = INTERNET_DEFAULT_HTTP_PORT
  86.             request.Servidor = objetivo
  87.             request.Dirección = "/" + paths[id]
  88.             request.Agente = "RequestTest [GET]"
  89.  
  90.             Si ( request.Conectar ) Entonces
  91.                 Si ( request.Enviar ) Entonces
  92.                     cmd.escribir("    http://" + request.Servidor + request.Dirección + " ~ Estado: ")
  93.                     Si ( request.StatusCode = HTTP_STATUS_OK ) Entonces
  94.                         cmd.escribirLinea("[OK]")
  95.                         pathsFound = pathsFound + "    http://" + request.Servidor + request.Dirección + CRLF
  96.                         Resultado = Verdad
  97.                     SiNo
  98.                         cmd.escribirLinea("[FAILED]")
  99.                     FinSi
  100.                 FinSi
  101.             FinSi
  102.         Seguir
  103.     Destruir request
  104.     Pausar(2500)
  105. FinProc


« Última modificación: Junio 26, 2017, 01:19:29 am por BlackBlex »

Desconectado Yuki

  • *
  • Underc0der
  • Mensajes: 67
  • Actividad:
    0%
  • Reputación 5
    • Ver Perfil
« Respuesta #1 en: Junio 26, 2017, 12:45:35 am »
Muy copada la aplicación, yo también estaba pensando en traducir los códigos de numéritos.

Me interesa ver el código fuente, espero con ansias la publicación!

salu2

Desconectado BlackBlex

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    0%
  • Reputación 4
    • Ver Perfil
  • Skype: blackblex
  • Twitter: blackblex
« Respuesta #2 en: Junio 26, 2017, 01:21:11 am »
Muy copada la aplicación, yo también estaba pensando en traducir los códigos de numéritos.

Me interesa ver el código fuente, espero con ansias la publicación!

salu2

Listo, acabo de agregar el source en el mismo post, iba a hacer uno aparte, pero lo vi innecesario, jeje.

Cualquier sugerencia, o error, comentame.

 

¿Te gustó el post? COMPARTILO!



Source Go Dork Scan Beta v0.3 by ReiGel_ado

Iniciado por reigelado

Respuestas: 2
Vistas: 2314
Último mensaje Enero 11, 2016, 09:15:09 pm
por reigelado
Source Go Dork Scan Beta v0.5 by ReiGel_ado

Iniciado por reigelado

Respuestas: 0
Vistas: 1975
Último mensaje Enero 20, 2016, 10:46:02 pm
por reigelado
Como trabajar Cramel con Sublime Text | Actualizado [Cramel2| 20/Junio/17]

Iniciado por BlackBlex

Respuestas: 1
Vistas: 2197
Último mensaje Febrero 23, 2017, 08:18:21 am
por ANTRAX
[Cramel] Regedit.cml ~ Crea, Edita y Elimina claves del Registro

Iniciado por BlackBlex

Respuestas: 0
Vistas: 3579
Último mensaje Julio 05, 2017, 08:30:39 pm
por BlackBlex
[Cramel] Componentes para Ventanas | 5 de Julio del 2017

Iniciado por BlackBlex

Respuestas: 0
Vistas: 3647
Último mensaje Abril 10, 2017, 04:25:47 pm
por BlackBlex