Menú

Mostrar Mensajes

Esta sección te permite ver todos los mensajes escritos por este usuario. Ten en cuenta que sólo puedes ver los mensajes escritos en zonas a las que tienes acceso en este momento.

Mostrar Mensajes Menú

Temas - pamaka

#1
Buenas tardes.

Al intentar instalar dradis, me da un error al ejecutar:
bundle install

"Installing nokogumbo 2.0.1 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /root/dradis-ce/ruby/2.5.0/gems/nokogumbo-2.0.1/ext/nokogumbo
/usr/bin/ruby2.5 -r ./siteconf20191128-9903-1efd285.rb extconf.rb
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
   --with-opt-dir
   --without-opt-dir
   --with-opt-include
   --without-opt-include=${opt-dir}/include
   --with-opt-lib
   --without-opt-lib=${opt-dir}/lib
   --with-make-prog
   --without-make-prog
   --srcdir=.
   --curdir
   --ruby=/usr/bin/$(RUBY_BASE_NAME)2.5
/usr/lib/ruby/2.5.0/rubygems/dependency.rb:312:in `to_specs': Could not find 'nokogiri' (= 1.10.4) - did find: [nokogiri-1.10.5]
(Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/root/dradis-ce/ruby/2.5.0', execute `gem env` for more information
   from /usr/lib/ruby/2.5.0/rubygems/dependency.rb:322:in `to_spec'
   from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1055:in `find_by_name'
   from extconf.rb:9:in `<main>'

extconf failed, exit code 1

Gem files will remain installed in /root/dradis-ce/ruby/2.5.0/gems/nokogumbo-2.0.1 for inspection.
Results logged to /root/dradis-ce/ruby/2.5.0/extensions/x86_64-linux/2.5.0/nokogumbo-2.0.1/gem_make.out

An error occurred while installing nokogumbo (2.0.1), and Bundler cannot continue.
Make sure that `gem install nokogumbo -v '2.0.1' --source 'No tienes permitido ver los links. Registrarse o Entrar a mi cuenta succeeds before bundling.

In Gemfile:
  sanitize was resolved to 5.0.0, which depends on
    nokogumbo"


¿alguien puede ayudarme?

Muchas gracias