This site uses cookies own and third. If you continue to browse consider to accept the use of cookies. OK More Info.

Detallan los errores de escalada de privilegios informados en Oracle VirtualBox

  • 0 Replies
  • 438 Views

0 Members and 1 Guest are viewing this topic.

Online Dragora

  • *
  • Moderador Global
  • Posts: 1853
  • Actividad:
    100%
  • Country: gt
  • Reputación 23
  • La resistencia es inútil, serás absorbido.
    • View Profile


Una vulnerabilidad ahora parcheada que afecta a Oracle VM VirtualBox podría ser potencialmente aprovechada por un adversario para poner en peligro el hipervisor y causar una condición de denegación de servicio (DoS).

"La vulnerabilidad fácilmente explotable permite que un atacante con muchos privilegios inicie sesión en la infraestructura donde se ejecuta Oracle VM VirtualBox para comprometer Oracle VM VirtualBox", se lee en el aviso . "Los ataques exitosos de esta vulnerabilidad pueden resultar en la capacidad no autorizada de causar un bloqueo o un bloqueo repetible (DoS completo) de Oracle VM VirtualBox"

Registrada como CVE-2021-2442 (puntuación CVSS: 6.0), la falla afecta a todas las versiones del producto antes de la 6.1.24. Al investigador de SentinelLabs , Max Van Amerongen, se le atribuye el descubrimiento e informe del problema, luego de lo cual Oracle ha implementado correcciones como parte de su Actualización de parche crítico para julio de 2021.

Oracle VM VirtualBox es un software de virtualización de escritorio y hipervisor de código abierto y multiplataforma que permite a los usuarios ejecutar múltiples sistemas operativos invitados como Windows, distribuciones de Linux, OpenBSD y Oracle Solaris en una sola máquina física.

Quote
Funciona tanto como una lectura fuera de límites en el proceso del host, como también como un subdesbordamiento de enteros. En algunos casos, también se puede usar para DoS de forma remota otras máquinas virtuales Virtualbox.
Señaló Van Amerongen en agosto.

Van Amerongen también descubrió otras dos fallas que afectan a las versiones anteriores a la 6.1.20 y que Oracle las resolvió en abril de 2021:

- CVE-2021-2145 (puntuación CVSS: 7,5): vulnerabilidad de escalada de privilegios de subdesbordamiento de enteros NAT de Oracle VirtualBox
- CVE-2021-2310 (puntuación CVSS: 7.5): Vulnerabilidad de escalamiento de privilegios de desbordamiento de búfer basado en montón NAT de Oracle VirtualBox (afecta, parcheado en abril.

Ambos problemas mencionados anteriormente residen dentro de la implementación de NAT que surgen de la falta de una validación adecuada de los datos proporcionados por el usuario. Los ataques exitosos de las dos deficiencias pueden permitir que un adversario local escale los privilegios y ejecute código arbitrario que resulte en la toma total de un Oracle VM VirtualBox vulnerable.

Dado que se sabe que los actores de amenazas se mueven rápido para aprovechar la brecha de seguridad que ofrecen las vulnerabilidades sin parche, es esencial que las organizaciones actualicen sus instalaciones de VirtualBox a la última versión para mitigar cualquier riesgo de posible explotación.

Fuente: You are not allowed to view links. Register or Login