Problema con email de sistemas de tickets (soporte técnico) en PHP.

  • 12 Respuestas
  • 3804 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Drezan

  • *
  • Underc0der
  • Mensajes: 12
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
Hola. No sé si el post va en este subforo pero me pareció que es aquí.

El tema es el siguiente, actualmente subí una página web en una empresa que estoy trabajando, dicha página web sólo es un Frontend, y lo único "back" que tiene, es el sistemas de formularios. Lo que hice fue subir la página web al host y todo normal. El problema es que dentro del hosting también está otro sitio, que es un sistema de tickets llamado osTicket (You are not allowed to view links. Register or Login) y pues, ahí los clientes envían tickets de soporte técnico, dichos pedidos suelen envíar un e-mail a una cuenta en concreta (una cuenta empresarial del mismo host) y pues los mensajes del día para otro, empezaron a venir así:




y cuando abro la inspección me sale esto:




Estoy usando FileZilla para gestionar el host. No sé realmente que puede ser, y cuál es el archivo exacto donde ocasiona el error (tampoco sé PHP, sólo tengo noción de programación y puedo diferenciar más o menos las variables o el funcionamiento pero aún así no sé nada)

Una ayudaíta ahí pls. :C

EDIT: Sale esto también.

« Última modificación: Junio 07, 2018, 10:48:12 am por blackdrake »

Desconectado rollth

  • *
  • Ex-Staff
  • *****
  • Mensajes: 876
  • Actividad:
    0%
  • Reputación 16
  • El conocimiento es libre.
  • Twitter: @RoloMijan
    • Ver Perfil
    • Whateversec
    • Email
Puedes pasar el codigo php para que lo veamos?
Lo que te sale es Base64, puedes utilizar esta herramienta para entenderlo.
You are not allowed to view links. Register or Login

Saludos.

Rollth
Buen hacker mejor persona.
You are not allowed to view links. Register or Login
You are not allowed to view links. Register or Login
You are not allowed to view links. Register or Login

Desconectado Drezan

  • *
  • Underc0der
  • Mensajes: 12
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
You are not allowed to view links. Register or Login
Puedes pasar el codigo php para que lo veamos?
Lo que te sale es Base64, puedes utilizar esta herramienta para entenderlo.
You are not allowed to view links. Register or Login

Saludos.

Gracias por la respuesta. A ver revisaré con el link que me pasaste. Con respecto al código PHP, cuál de todos exactamente? xD! no sé cuál es el archivo.php preciso que causa el error.

EDIT:

Me sale esto:

Citar
fӞ_\~鮵s}mv-- reply above this line --
*Prezado ssp,*
--------------
Serviço restaurado às 17:57 do dia 06/06/2018


Equipe Sistema de Chamado para Suporte,
------------------------------------------------------------------------------------------

Esperamos que esta resposta tenha respondido às suas perguntas. Se não, por favor, não
é necessário enviar outro e-mail. Em vez disso, responde a este e-mail ou [ acessar a
sua conta][1] para um arquivo completo de todos suas requisições de suporte e respostas.

---------------------------------------------
[1] You are not allowed to view links. Register or Login
Ref-Mid: [email protected]
6ٽ}7ߧk\Gy7]

Que vendría siendo el mensaje por defecto. Entonces el archivo que genera eso es el view.php?

EDIT 2:

También conseguí este archivo dentro de la carpeta "include"



EDIT3: Una pregunta, no será porque no puse el "info.php" en el root del host? Antes de yo montar mi página web, había ese archivo, pero yo le hice un backup y lo eliminé de ahí. Será eso?
« Última modificación: Junio 07, 2018, 10:18:50 am por Drezan »

Desconectado rollth

  • *
  • Ex-Staff
  • *****
  • Mensajes: 876
  • Actividad:
    0%
  • Reputación 16
  • El conocimiento es libre.
  • Twitter: @RoloMijan
    • Ver Perfil
    • Whateversec
    • Email
La verdad es que con la información que das es bastante dificil saber que pasa...

Rollth
Buen hacker mejor persona.
You are not allowed to view links. Register or Login
You are not allowed to view links. Register or Login
You are not allowed to view links. Register or Login

Desconectado Drezan

  • *
  • Underc0der
  • Mensajes: 12
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
Una pregunta, no será porque no puse el "info.php" en el root del host? Antes de yo montar mi página web, había ese archivo, pero yo le hice un backup y lo eliminé de ahí. Será eso?

Y sí, lo siento, es que no consigo como precisar la información porque no sé exactamente cuál es el archivo que lo causa xDD

Desconectado blackdrake

  • *
  • Co Admin
  • Mensajes: 1951
  • Actividad:
    13.33%
  • Country: es
  • Reputación 16
    • Ver Perfil
Hola @You are not allowed to view links. Register or Login

No, el info.php no tiene nada que ver y el fallo no se debe a eso.

Tal y como te comentó @You are not allowed to view links. Register or Login, el error se debe a que recibes los correos en base64, de hecho, si te fijas, en la cabecera puedes ver lo siguiente: "Content-Transfer-Encoding: base64".

Aparentemente con cambiar ese encoding debería quedar funcionando, sin ver el código PHP no puedo decirte la causa exacta del error.

Un saludo.


Desconectado Drezan

  • *
  • Underc0der
  • Mensajes: 12
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
Entiendo. Bueno el problema es que no sé cuál de todos los archivos, podrían ser, paso algunas screens a ver si más o menos deducen cuál podría ser:

Esta sería la carpeta principal:



aquí sería la carpeta "include":







carpeta pear:


Desconectado Drezan

  • *
  • Underc0der
  • Mensajes: 12
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
Perdonen el doble post.

Pero sospecho que pueden ser estos archivos, sobretodo el mime.php que se encarga de el encoding creo:
You are not allowed to view links. Register or Login

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5667
  • Actividad:
    63.33%
  • Country: ar
  • Reputación 37
  • ANTRAX
  • Skype: underc0de.org
  • Twitter: @Underc0de
    • Ver Perfil
    • Underc0de
    • Email
Lo que no entiendo el porque pasar todo a base64 para enviar el mail...

Saludos,
ANTRAX


Desconectado Drezan

  • *
  • Underc0der
  • Mensajes: 12
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
You are not allowed to view links. Register or Login
Lo que no entiendo el porque pasar todo a base64 para enviar el mail...

Saludos,
ANTRAX

Ni idea, me imagino que es para proteger el mensaje, pero sinceramente ni idea xD!

Conectado ANTRAX

  • *
  • Administrator
  • Mensajes: 5667
  • Actividad:
    63.33%
  • Country: ar
  • Reputación 37
  • ANTRAX
  • Skype: underc0de.org
  • Twitter: @Underc0de
    • Ver Perfil
    • Underc0de
    • Email
Porque quizas quitando eso, sería mucho más simple.
Averigua si es necesario, en caso de que no, tengo para compartirte un código que nunca falla. Lo puedes ver en este post de un user que tuvo un problema similar al tuyo y lo pudo solucionar.

You are not allowed to view links. Register or Login

Saludos,
ANTRAX
« Última modificación: Junio 07, 2018, 04:35:14 pm por ANTRAX »


Desconectado Drezan

  • *
  • Underc0der
  • Mensajes: 12
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
You are not allowed to view links. Register or Login
Porque quizas quitando eso, sería mucho más simple.
Averigua si es necesario, en caso de que no, tengo para compartirte un código que nunca falla. Lo puedes ver en este post de un user que tuvo un problema similar al tuyo y lo pudo solucionar.

You are not allowed to view links. Register or Login

Saludos,
ANTRAX

Gracias por tu respuesta. Lamentablemente no me funcionó. Realmente creo que el problema es del Encondig y Decoding, pero no sé exactamente qué lo causa o cuál es la variable o función que da el error. Pasaría todo el código el problema es que ya me dijeron que no puedo hacer eso, porque no es la idea ponerlos a leer un montón de código (lo cuál estoy de acuerdo, es demasiado trabajo)

Entonces, bueno no sé, si logro reducir más la incertidumbre, posteo el problema con más precisión. Disculpa el inconveniente.

Desconectado Randomize

  • *
  • Underc0der
  • Mensajes: 389
  • Actividad:
    0%
  • Reputación -13
    • Ver Perfil
Citar
El problema es que dentro del hosting también está otro sitio, que es un sistema de tickets llamado osTicket (osTicket)


¿Has verificado cosicas acá dentro?


Envíos erróneos...


Un saludo.


 

Problema con conexión de troyano pierdo la conexion

Iniciado por Nitro_X_Net

Respuestas: 6
Vistas: 3470
Último mensaje Julio 13, 2015, 03:35:57 am
por .:UND3R:.
[SOLUCIONADO] Problema con Softice 4.05 Help, SoftICE is not active.

Iniciado por d3vilz5

Respuestas: 1
Vistas: 3397
Último mensaje Mayo 17, 2013, 11:52:31 pm
por Krapermors
Booteo en Dell Inspiron Mini "problema"

Iniciado por KnarBlack

Respuestas: 2
Vistas: 2322
Último mensaje Febrero 19, 2018, 11:44:52 pm
por KnarBlack
[SOLUCIONADO] Problema con el systemd en MJ (systemd-modules-load.service)

Iniciado por Thereldor

Respuestas: 1
Vistas: 2503
Último mensaje Abril 05, 2016, 11:50:05 pm
por Thereldor
AVs CMLS Registry workshop.. Problema.! "Otra vez yo"

Iniciado por Zobek

Respuestas: 0
Vistas: 2497
Último mensaje Julio 11, 2016, 06:19:19 pm
por Zobek