Underc0de - Hacking y seguridad informática

Foros Generales => Dudas y pedidos generales => Mensaje iniciado por: iGreentick en Junio 30, 2016, 09:30:55 pm

Título: ¡AYUDA! Error al instalar cualquier aplicacion vía "Apt-Get"
Publicado por: iGreentick en Junio 30, 2016, 09:30:55 pm
Buenas. llevo varios dias teniendo este problema..y ya me comienza a mosquear. cada vez que intento instalar algo me salta este error:

Código: [Seleccionar]
Configurando dradis (3.1.0~rc2+git20160609-0kali2) ...
Aviso: El directorio personal /var/lib/dradis que especificó ya existe.
Ya existe el usuario del sistema `dradis'. Saliendo.
/usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `block in initialize': undefined method `add_root_vertex' for Molinillo::DependencyGraph:[]:Molinillo::DependencyGraph (NoMethodError)
Did you mean?  add_vertex
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `initialize'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `new'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:200:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:140:in `specs'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:185:in `specs_for'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:174:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/environment.rb:18:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:13:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler.rb:127:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler/setup.rb:8:in `<top (required)>'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/lib/dradis/config/boot.rb:3:in `<top (required)>'
    from bin/rake:2:in `require_relative'
    from bin/rake:2:in `<main>'
dpkg: error al procesar el paquete dradis (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1


y finalmente
Código: [Seleccionar]
Se encontraron errores al procesar:
 dradis
[email protected]:~#



¿Alguien sabe por qué? ¿Y cómo lo soluciono?. Gracias.
Título: Re:¡AYUDA! Error al instalar cualquier aplicacion vía "Apt-Get"
Publicado por: grep en Junio 30, 2016, 09:47:46 pm
¿Has probado ejecutando antes sudo apt-get update && sudo apt-get upgrade?

Para agregar:

https://bugs.kali.org/view.php?id=3112
https://github.com/rapid7/metasploit-framework/issues/6630

En el enlace plantean que se requiere una versión actualizada de bundler y una cierta versión de ruby.
Título: Re:¡AYUDA! Error al instalar cualquier aplicacion vía "Apt-Get"
Publicado por: blood_rec en Junio 30, 2016, 09:59:06 pm
¿Has probado ejecutando antes sudo apt-get update && sudo apt-get upgrade?

eso no va a funcionar trata

Código: [Seleccionar]
gem install bundler
bundle install
bundle exec rake db:create

si no funciona luego pues

Código: [Seleccionar]
sudo apt-get install bundler
si no pues

Código: [Seleccionar]
bundle exec rake <task> este caso lo que quieres hacer :p

si no pues

Código: [Seleccionar]
sudo gem update rake

sudo gem install bundler

si aun eso no funciona que me dices de desintalar bundler y reinstalar?

si aun no funciona pues desintala todo gems , ruby etc etc relacionado a ruby

y si no te funciona pues te queda antes de ejecutar cualquier cosa aprender sobre el lenguaje que esta escrito....

salu2

aun asi
Título: Re:¡AYUDA! Error al instalar cualquier aplicacion vía "Apt-Get"
Publicado por: iGreentick en Junio 30, 2016, 10:12:37 pm
¿Has probado ejecutando antes sudo apt-get update && sudo apt-get upgrade?

eso no va a funcionar trata

Código: [Seleccionar]
gem install bundler
bundle install
bundle exec rake db:create

si no funciona luego pues

Código: [Seleccionar]
sudo apt-get install bundler
si no pues

Código: [Seleccionar]
bundle exec rake <task> este caso lo que quieres hacer :p

si no pues

Código: [Seleccionar]
sudo gem update rake

sudo gem install bundler

si aun eso no funciona que me dices de desintalar bundler y reinstalar?

si aun no funciona pues desintala todo gems , ruby etc etc relacionado a ruby

y si no te funciona pues te queda antes de ejecutar cualquier cosa aprender sobre el lenguaje que esta escrito....

salu2

aun asi



[email protected]:/# bundle install
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.
Could not locate Gemfile or .bundle/ directory


Me salta error. :C
Título: Re:¡AYUDA! Error al instalar cualquier aplicacion vía "Apt-Get"
Publicado por: PikachuDorado en Octubre 12, 2016, 09:54:37 pm
Ayuden al pibe, estoy en la misma! JAJAJAJA
Título: Re:¡AYUDA! Error al instalar cualquier aplicacion vía "Apt-Get"
Publicado por: puntoCL en Octubre 13, 2016, 01:44:28 am
Estas instalando un programa ya instalado

apt-get install nombrePrograma
apt-get remove nombrePrograma
apt-get update
apt-get upgrade
apt-get install --reinstall nombrePrograma