Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

¡AYUDA! Error al instalar cualquier aplicacion vía "Apt-Get"

  • 5 Respuestas
  • 1980 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado iGreentick

  • *
  • Underc0der
  • Mensajes: 29
  • Actividad:
    0%
  • Reputación -4
    • Ver Perfil
« en: Junio 30, 2016, 09:30:55 pm »
Buenas. llevo varios dias teniendo este problema..y ya me comienza a mosquear. cada vez que intento instalar algo me salta este error:

Código: [Seleccionar]
Configurando dradis (3.1.0~rc2+git20160609-0kali2) ...
Aviso: El directorio personal /var/lib/dradis que especificó ya existe.
Ya existe el usuario del sistema `dradis'. Saliendo.
/usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `block in initialize': undefined method `add_root_vertex' for Molinillo::DependencyGraph:[]:Molinillo::DependencyGraph (NoMethodError)
Did you mean?  add_vertex
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:194:in `initialize'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `new'
    from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:181:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:200:in `resolve'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:140:in `specs'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:185:in `specs_for'
    from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:174:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/environment.rb:18:in `requested_specs'
    from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:13:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler.rb:127:in `setup'
    from /usr/lib/ruby/vendor_ruby/bundler/setup.rb:8:in `<top (required)>'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/lib/dradis/config/boot.rb:3:in `<top (required)>'
    from bin/rake:2:in `require_relative'
    from bin/rake:2:in `<main>'
dpkg: error al procesar el paquete dradis (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1


y finalmente
Código: [Seleccionar]
Se encontraron errores al procesar:
 dradis
root@kali:~#



¿Alguien sabe por qué? ¿Y cómo lo soluciono?. Gracias.
« Última modificación: Junio 30, 2016, 09:41:21 pm por Gabriela »
8Noobs <- Más que una comunidad, una familia. (www.8noobs.hol.es)

La percepción, es solo una percepción

Desconectado grep

  • *
  • Underc0der
  • Mensajes: 178
  • Actividad:
    0%
  • Reputación 3
    • Ver Perfil
    • Grep's personal site
« Respuesta #1 en: Junio 30, 2016, 09:47:46 pm »
¿Has probado ejecutando antes sudo apt-get update && sudo apt-get upgrade?

Para agregar:

https://bugs.kali.org/view.php?id=3112
https://github.com/rapid7/metasploit-framework/issues/6630

En el enlace plantean que se requiere una versión actualizada de bundler y una cierta versión de ruby.
« Última modificación: Junio 30, 2016, 10:12:27 pm por grep »

Desconectado blood_rec

  • *
  • Underc0der
  • Mensajes: 50
  • Actividad:
    0%
  • Reputación 0
  • From no0b to ro0t in 5 seconds :)
    • Ver Perfil
    • H4x0r Security Group
« Respuesta #2 en: Junio 30, 2016, 09:59:06 pm »
¿Has probado ejecutando antes sudo apt-get update && sudo apt-get upgrade?

eso no va a funcionar trata

Código: [Seleccionar]
gem install bundler
bundle install
bundle exec rake db:create

si no funciona luego pues

Código: [Seleccionar]
sudo apt-get install bundler
si no pues

Código: [Seleccionar]
bundle exec rake <task> este caso lo que quieres hacer :p

si no pues

Código: [Seleccionar]
sudo gem update rake

sudo gem install bundler

si aun eso no funciona que me dices de desintalar bundler y reinstalar?

si aun no funciona pues desintala todo gems , ruby etc etc relacionado a ruby

y si no te funciona pues te queda antes de ejecutar cualquier cosa aprender sobre el lenguaje que esta escrito....

salu2

aun asi
  • you're so n00b and still reading this lmaoo!!
  • observo mucho creido y no se saben ni limpiar ni el culillo
Mi Blog Entra

Desconectado iGreentick

  • *
  • Underc0der
  • Mensajes: 29
  • Actividad:
    0%
  • Reputación -4
    • Ver Perfil
« Respuesta #3 en: Junio 30, 2016, 10:12:37 pm »
¿Has probado ejecutando antes sudo apt-get update && sudo apt-get upgrade?

eso no va a funcionar trata

Código: [Seleccionar]
gem install bundler
bundle install
bundle exec rake db:create

si no funciona luego pues

Código: [Seleccionar]
sudo apt-get install bundler
si no pues

Código: [Seleccionar]
bundle exec rake <task> este caso lo que quieres hacer :p

si no pues

Código: [Seleccionar]
sudo gem update rake

sudo gem install bundler

si aun eso no funciona que me dices de desintalar bundler y reinstalar?

si aun no funciona pues desintala todo gems , ruby etc etc relacionado a ruby

y si no te funciona pues te queda antes de ejecutar cualquier cosa aprender sobre el lenguaje que esta escrito....

salu2

aun asi



root@kali:/# bundle install
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.
Could not locate Gemfile or .bundle/ directory


Me salta error. :C
8Noobs <- Más que una comunidad, una familia. (www.8noobs.hol.es)

La percepción, es solo una percepción

Desconectado PikachuDorado

  • *
  • Underc0der
  • Mensajes: 372
  • Actividad:
    0%
  • Reputación 1
  • Im just a Pikachu
    • Ver Perfil
    • Soporte Ava
« Respuesta #4 en: Octubre 12, 2016, 09:54:37 pm »
Ayuden al pibe, estoy en la misma! JAJAJAJA
Pikaa~


Conectado puntoCL

  • *
  • Moderador Global
  • Mensajes: 275
  • Actividad:
    0%
  • Reputación 5
  • Magallanes no es chile :D
    • Ver Perfil
« Respuesta #5 en: Octubre 13, 2016, 01:44:28 am »
Estas instalando un programa ya instalado

apt-get install nombrePrograma
apt-get remove nombrePrograma
apt-get update
apt-get upgrade
apt-get install --reinstall nombrePrograma




 

¿Te gustó el post? COMPARTILO!



[JAVA] Ayuda Sockets en Java

Iniciado por FERNANDX

Respuestas: 1
Vistas: 866
Último mensaje Abril 25, 2018, 08:49:50 pm
por Mortal_Poison
Ayuda Para Hacking Para Juegos

Iniciado por NinjaWarrior

Respuestas: 0
Vistas: 257
Último mensaje Marzo 06, 2019, 08:06:47 pm
por NinjaWarrior
[SOLUCIONADO] Ayuda para encriptar mi rat spynet para que sea indetectable

Iniciado por perroloco28

Respuestas: 8
Vistas: 683
Último mensaje Abril 13, 2019, 02:10:22 pm
por elshotta
[SOLUCIONADO] Ayuda! Archivos Indexados, Ficheros Indexados, Indice!. Lenguaje C

Iniciado por Shatsozzy

Respuestas: 4
Vistas: 2694
Último mensaje Febrero 14, 2013, 12:47:31 pm
por Shatsozzy
Ayuda con sumar, restar y acumular datos en base de datos MySQL

Iniciado por D3BAI

Respuestas: 3
Vistas: 1937
Último mensaje Julio 31, 2017, 03:19:07 am
por noxonsoftwares