[SOLUCIONADO] Error al instalar sslstrip

  • 18 Respuestas
  • 1332 Vistas

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

[SOLUCIONADO] Error al instalar sslstrip

  • en: Agosto 05, 2020, 09:23:38 am
[email protected]:~/Descargas/Twisted-13.1.0$ sudo sslstrip
Traceback (most recent call last):
  File "/usr/local/bin/sslstrip", line 27, in <module>
    from twisted.web import http
   ImportError: No module named twisted.web
« Última modificación: Agosto 12, 2020, 05:34:38 pm por AXCESS »

Conectado tr0n

  • *
  • Underc0der
  • Mensajes: 83
  • Actividad:
    53.33%
  • Country: 00
  • Reputación 4
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 05, 2020, 11:03:47 am
Creeria que te falta instalar el paquete twisted

You are not allowed to view links. Register or Login

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 05, 2020, 03:03:28 pm
No se instala bien. Optengo lo siguiente:



[email protected]:~/Descargas/Twisted-13.1.0$ pip install Twisted
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at You are not allowed to view links. Register or Login
Defaulting to user installation because normal site-packages is not writeable
Requirement already satisfied: Twisted in /usr/local/lib/python2.7/dist-packages (20.3.0)
Requirement already satisfied: incremental>=16.10.1 in /usr/local/lib/python2.7/dist-packages (from Twisted) (17.5.0)
Requirement already satisfied: Automat>=0.3.0 in /usr/local/lib/python2.7/dist-packages (from Twisted) (20.2.0)
Requirement already satisfied: zope.interface>=4.4.2 in /usr/local/lib/python2.7/dist-packages (from Twisted) (5.1.0)
Requirement already satisfied: attrs>=19.2.0 in /usr/local/lib/python2.7/dist-packages (from Twisted) (19.3.0)
Requirement already satisfied: hyperlink>=17.1.1 in /usr/local/lib/python2.7/dist-packages (from Twisted) (20.0.1)
Requirement already satisfied: constantly>=15.1 in /usr/local/lib/python2.7/dist-packages (from Twisted) (15.1.0)
Requirement already satisfied: PyHamcrest!=1.10.0,>=1.9.0 in /usr/local/lib/python2.7/dist-packages (from Twisted) (1.10.1)
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from Automat>=0.3.0->Twisted) (1.15.0)
Requirement already satisfied: setuptools in /usr/local/lib/python2.7/dist-packages (from zope.interface>=4.4.2->Twisted) (44.1.1)
Requirement already satisfied: typing; python_version < "3.5" in /usr/local/lib/python2.7/dist-packages (from hyperlink>=17.1.1->Twisted) (3.7.4.3)
Requirement already satisfied: idna>=2.5 in /usr/local/lib/python2.7/dist-packages (from hyperlink>=17.1.1->Twisted) (2.10)

Conectado tr0n

  • *
  • Underc0der
  • Mensajes: 83
  • Actividad:
    53.33%
  • Country: 00
  • Reputación 4
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 06, 2020, 12:23:09 pm
¿ y si intentas con pip3 ?

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 06, 2020, 04:35:10 pm
que va pasa lo mismo:

[email protected]:~/Escritorio$ sudo pip3 install Twisted
[sudo] contraseña para sao:
Requirement already satisfied: Twisted in /usr/local/lib/python3.8/dist-packages (20.3.0)
Requirement already satisfied: incremental>=16.10.1 in /usr/local/lib/python3.8/dist-packages (from Twisted) (17.5.0)
Requirement already satisfied: zope.interface>=4.4.2 in /usr/local/lib/python3.8/dist-packages (from Twisted) (5.1.0)
Requirement already satisfied: Automat>=0.3.0 in /usr/local/lib/python3.8/dist-packages (from Twisted) (20.2.0)
Requirement already satisfied: PyHamcrest!=1.10.0,>=1.9.0 in /usr/local/lib/python3.8/dist-packages (from Twisted) (2.0.2)
Requirement already satisfied: constantly>=15.1 in /usr/local/lib/python3.8/dist-packages (from Twisted) (15.1.0)
Requirement already satisfied: attrs>=19.2.0 in /usr/local/lib/python3.8/dist-packages (from Twisted) (19.3.0)
Requirement already satisfied: hyperlink>=17.1.1 in /usr/local/lib/python3.8/dist-packages (from Twisted) (20.0.1)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from zope.interface>=4.4.2->Twisted) (45.2.0)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from Automat>=0.3.0->Twisted) (1.14.0)
Requirement already satisfied: idna>=2.5 in /usr/lib/python3/dist-packages (from hyperlink>=17.1.1->Twisted) (2.8)
[email protected]:~/Escritorio$ sslstrip
Traceback (most recent call last):
  File "/usr/local/bin/sslstrip", line 27, in <module>
    from twisted.web import http
ImportError: No module named twisted.web

Desconectado DtxdF

  • *
  • Moderator
  • Mensajes: 781
  • Actividad:
    80%
  • Reputación 16
  • Eres un auto y tienes dos opciones: Parar o Seguir
    • Ver Perfil
    • Mi repositorio de Github donde encontraras herramientas para tu trabajo.
    • Email

Re:Error al instalar sslstrip

  • en: Agosto 07, 2020, 02:47:06 am
¿Lo instaló manual o uso su gestor de paquetes?. Quizá en los repositorios se pueda instalar con un simple comando, como por ejemplo:

Código: Bash
  1. # Arch y derivados
  2. sudo pacman -S sslstrip
  3.  
  4. # o Debian y derivados
  5. sudo apt-get install sslstrip

Le instalará las dependencias que necesite además del programa en sí.

Otra cosa a tener en cuenta es que debe usar el pip para la versión que requiera sslstrip, en caso de hacerlo manual. Puede ver qué versión de python se está ejecutando implícitamente (puede no funcionar):

Código: Python
  1. cat $(which sslstrip) | head -1

Puede que le aparezca o no lo siguiente:

Código: Bash
  1. ...
  2. #!/usr/bin/python3
  3. ...

O también podría aparecer:

Código: Bash
  1. ...
  2. #!/usr/bin/python
  3. ...

Supongamos que es la segunda opción, entonces tendría que usar el siguiente comando para instalar las librerías para esa versión de python:

Código: Bash
  1. python -m pip install Twisted

Y por último, ejecutar nuevamente:

Código: Bash
  1. sslstrip

~ DtxdF
Los seres humanos son robots, cuyo combustible es el afanado dinero.

Desconectado animanegra

  • *
  • Moderator
  • Mensajes: 310
  • Actividad:
    96.67%
  • Country: 00
  • Reputación 11
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 07, 2020, 05:37:34 am
You are not allowed to view links. Register or Login
que va pasa lo mismo:

[email protected]:~/Escritorio$ sudo pip3 install Twisted
[sudo] contraseña para sao:
Requirement already satisfied: Twisted in /usr/local/lib/python3.8/dist-packages (20.3.0)
Requirement already satisfied: incremental>=16.10.1 in /usr/local/lib/python3.8/dist-packages (from Twisted) (17.5.0)
Requirement already satisfied: zope.interface>=4.4.2 in /usr/local/lib/python3.8/dist-packages (from Twisted) (5.1.0)
Requirement already satisfied: Automat>=0.3.0 in /usr/local/lib/python3.8/dist-packages (from Twisted) (20.2.0)
Requirement already satisfied: PyHamcrest!=1.10.0,>=1.9.0 in /usr/local/lib/python3.8/dist-packages (from Twisted) (2.0.2)
Requirement already satisfied: constantly>=15.1 in /usr/local/lib/python3.8/dist-packages (from Twisted) (15.1.0)
Requirement already satisfied: attrs>=19.2.0 in /usr/local/lib/python3.8/dist-packages (from Twisted) (19.3.0)
Requirement already satisfied: hyperlink>=17.1.1 in /usr/local/lib/python3.8/dist-packages (from Twisted) (20.0.1)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from zope.interface>=4.4.2->Twisted) (45.2.0)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from Automat>=0.3.0->Twisted) (1.14.0)
Requirement already satisfied: idna>=2.5 in /usr/lib/python3/dist-packages (from hyperlink>=17.1.1->Twisted) (2.8)
[email protected]:~/Escritorio$ sslstrip
Traceback (most recent call last):
  File "/usr/local/bin/sslstrip", line 27, in <module>
    from twisted.web import http
ImportError: No module named twisted.web

SSlstrip estara usando python2 en lugar de 3, O bien upgradeas la version de python2 a la que te marca al intentar instalar con pip o puedes tambien probar una cosa simple ya que parece que tienes las dependencias innstaladas para python3.

haces un ls -al de la ruta donde está tu ejecutable de python:

Código: You are not allowed to view links. Register or Login
ls -al /usr/bin/python
lrwxrwxrwx 1 root root 7 Mar  4  2019 /usr/bin/python -> python2

Si tienes eso es que tu sistema está utilizando python2 y no 3. Por lo que puedes intentar cambiando ese link al que apunte a python3.
En mi sistema el python esta en /usr/bin/ entonces haría (con la cuenta de root):

Código: You are not allowed to view links. Register or Login
rm /usr/bin/python
ln -s /usr/bin/python3 /usr/bin/python

Con lo que al hacer un ls del archivo dará esta salida:

Código: You are not allowed to view links. Register or Login
ls -al /usr/bin/python
lrwxrwxrwx 1 root root 7 Mar  4  2019 /usr/bin/python -> python3

Y ahora si, probar a ejecutar el sslstrip. Después de usarlo te recomendaría volver a dejar el sistema como estaba antes con el link de python apuntando otra vez a python2.

No se si se entiende.

Lo siento, no contesto dudas por MP, si tienes dudas las planteas en el foro.

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 07, 2020, 04:47:32 pm
me da el siguiente error:

[email protected]:~$ sudo python -m pip install Twisted
Traceback (most recent call last):
  File "/usr/local/lib/python2.5/runpy.py", line 87, in run_module
    raise ImportError("No module named " + mod_name)
ImportError: No module named pip

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 10, 2020, 07:45:10 am
el sistema esta usando python3 y yo creo que sslstrip usa alguna version de python2

[email protected]:/usr/local/bin$ ls -al /usr/bin/python
lrwxrwxrwx 1 root root 7 abr 15 12:45 /usr/bin/python -> python3


Desconectado animanegra

  • *
  • Moderator
  • Mensajes: 310
  • Actividad:
    96.67%
  • Country: 00
  • Reputación 11
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 10, 2020, 08:03:02 am
Si en la primera linea del sslstrip.py pone python está utilizando la version del sistema.
Me pareceria raro que tuviese una ruta especifica a la version de python pero compruebalo y si es el caso cambia el python2 que pondrá en la primera linea por python.

Seguramente no séa eso asi que  prueba a instalar el paquete:

python3-twisted desde apt-get con:

Código: You are not allowed to view links. Register or Login
sudo apt-get install python3-twisted

Lo siento, no contesto dudas por MP, si tienes dudas las planteas en el foro.

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 10, 2020, 08:27:04 am
esta es mi primera linea de sslstrip:

[#!/usr/local/bin/python

creo que necesito una version menor de python
estas son las versiones que tengo:

[email protected]:~$ python --version
Python 2.5.6
[email protected]:~$ python3 --version
Python 3.8.2


Desconectado animanegra

  • *
  • Moderator
  • Mensajes: 310
  • Actividad:
    96.67%
  • Country: 00
  • Reputación 11
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 10, 2020, 02:10:51 pm
cambia la version del directorio local de python (la de /usr/local/bin/) con lo de los ln que te he dicho. verifica que es un enlace al igual que la /usr/bin/ y cambia el enlace a python3.

Lo siento, no contesto dudas por MP, si tienes dudas las planteas en el foro.

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 11, 2020, 11:35:22 am
ya estoy usando python 3
[email protected]:/usr/bin$ ls -al /usr/bin/python
lrwxrwxrwx 1 root root 7 abr 15 12:45 /usr/bin/python -> python3

Desconectado animanegra

  • *
  • Moderator
  • Mensajes: 310
  • Actividad:
    96.67%
  • Country: 00
  • Reputación 11
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 11, 2020, 02:19:06 pm
La primera linea del sslstrip te dice que interprete de python estas usando. La ruta a dicho interprete es:

Código: You are not allowed to view links. Register or Login
/usr/local/bin/python

El ls lo estas haciendo de:

Código: You are not allowed to view links. Register or Login
/usr/bin/python

Así que no sabemos que python está utilizando sslstrip hasta que no lo verifiques.

Lo siento, no contesto dudas por MP, si tienes dudas las planteas en el foro.

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 11, 2020, 04:38:30 pm
ahora llamo a python3 y sale lo siguiente

[email protected]:~$ sslstrip
  File "/usr/local/bin/sslstrip", line 39
    print "\nsslstrip " + gVersion + " by Moxie Marlinspike"
          ^
SyntaxError: Missing parentheses in call to 'print'. Did you mean print("\nsslstrip " + gVersion + " by Moxie Marlinspike")?




la primera linea del script es
#!/usr/bin/python3

Desconectado animanegra

  • *
  • Moderator
  • Mensajes: 310
  • Actividad:
    96.67%
  • Country: 00
  • Reputación 11
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 12, 2020, 04:23:44 am
Añadido:

Acabo de releer la traza de POSTS, mira a ver si por casualidad no tienes el archivo /usr/bin/python2.7, que parece que tienes varias versiones de python en el sistema. Porque pip install parece vinculado a python2.7 y parece que tiene las dependencias puestas pero python parece estar vinculado a python2.5 que no tiene las dependecias.
Si lo tienes cambia la primera linea del script de sslstrip a que contenga la siguiente ruta /usr/bin/python2.7

Fin de añadido.

Ok, pues ya no te queda otra que instalar las librerias desde pip para tener instaladas las dependencias que te pide sslstrip. Ya que aunque tengas todas las dependencias que usa sslstrip en python3 el código de sslstrip no funciona en python3.

Ejecuta lo primero lo siguiente:

Código: You are not allowed to view links. Register or Login
sudo apt-get install python-pip
sudo python -m pip install Twisted

Si las librerias no son compatibles con la version 2.5 que tienes de python a lo mejor toca tambien updatear el python2.
Y vuelve a poner en la primera linea de sslstrip python2 en lugar de python3.

« Última modificación: Agosto 12, 2020, 04:29:42 am por animanegra »

Lo siento, no contesto dudas por MP, si tienes dudas las planteas en el foro.

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 12, 2020, 07:51:05 am
tengo este error:

[email protected]:~$ sslstrip
/usr/local/bin/sslstrip: línea 3: sslstrip is a MITM tool that implements Moxie Marlinspike's SSL stripping attacks.: orden no encontrada
/usr/local/bin/sslstrip: línea 5: __author__: orden no encontrada
/usr/local/bin/sslstrip: línea 6: __email__: orden no encontrada
/usr/local/bin/sslstrip: línea 7:
Copyright (c) 2004-2009 Moxie Marlinspike <[email protected]>
 
This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License as
published by the Free Software Foundation; either version 3 of the
License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
USA

: No existe el archivo o el directorio
from: can't read /var/mail/twisted.web
from: can't read /var/mail/twisted.internet
from: can't read /var/mail/sslstrip.StrippingProxy
from: can't read /var/mail/sslstrip.URLMonitor
from: can't read /var/mail/sslstrip.CookieCleaner
import-im6.q16: attempt to perform an operation not allowed by the security policy `PS' @ error/constitute.c/IsCoderAuthorized/408.
/usr/local/bin/sslstrip: línea 36: gVersion: orden no encontrada
/usr/local/bin/sslstrip: línea 38: error sintáctico cerca del elemento inesperado `('
/usr/local/bin/sslstrip: línea 38: `def usage():'



Creo que voy a formatear y reinstalarlo todo

Desconectado animanegra

  • *
  • Moderator
  • Mensajes: 310
  • Actividad:
    96.67%
  • Country: 00
  • Reputación 11
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 12, 2020, 08:50:23 am
Me refiero a que cambies el interprete no que pongas directamente en la primera linea eso.

osea la primera linea tiene que ser:

Código: You are not allowed to view links. Register or Login
#!/usr/bin/python2.7

y no:

Código: You are not allowed to view links. Register or Login
/usr/bin/python2.7

Lo siento, no contesto dudas por MP, si tienes dudas las planteas en el foro.

Desconectado d0mp

  • *
  • Underc0der
  • Mensajes: 49
  • Actividad:
    100%
  • Reputación 0
    • Ver Perfil

Re:Error al instalar sslstrip

  • en: Agosto 12, 2020, 05:32:13 pm
He instalado bettercap 2 que trae un modulo de sslstrip y va sin problemas

 

[SOLUCIONADO] ¿Kali Linux o Kali Linux Ligth ?

Iniciado por worq

Respuestas: 2
Vistas: 27537
Último mensaje Noviembre 21, 2017, 12:28:54 pm
por Codig0Bit
[SOLUCIONADO] Multiuploader de imagenes con mysql, hosting de imagenes con mysql

Iniciado por graphixx

Respuestas: 4
Vistas: 14758
Último mensaje Marzo 26, 2013, 05:42:58 pm
por Xt3mP
[SOLUCIONADO] ¿Como publicar un software como software libre?

Iniciado por FuriosoJack

Respuestas: 2
Vistas: 12413
Último mensaje Mayo 23, 2017, 07:24:22 am
por HATI
[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 18689
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Ayuda urgente con Virus "Virus.Win32Sality"

Iniciado por Napsters

Respuestas: 6
Vistas: 17921
Último mensaje Junio 11, 2012, 03:38:18 am
por Satyricon