comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Duda sobre el formato que recibo con Jsoup [java]

  • 0 Respuestas
  • 517 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Hu3c0

  • *
  • Underc0der
  • Mensajes: 434
  • Actividad:
    1.67%
  • Reputación 0
  • In the middle Netbeans
    • Ver Perfil
« en: Septiembre 22, 2015, 07:04:29 pm »
Algo me está entorpeciendo en mi avance será una chorrada pero no doy con lo que es intentaré ser lo más explicito que pueda.

Utilizo Jsoup para extraer un contenido de una api en su retorno :

Código: Java
  1. dochtml =  Jsoup.parse(new You are not allowed to view links. Register or Login(entradahtml).openStream(), "ISO-8859-1", entradahtml);
  2.          
  3.     Elements inhtml= dochtml.select("body");
  4.     You are not allowed to view links. Register or Login cadenaatratar = inhtml.text();
  5.     You are not allowed to view links. Register or Login.out.println(cadenaatratar.substring(3));
  6.      You are not allowed to view links. Register or Login.out.println(inhtml.text());

Este código en netbeans me funciona a la perfección me extrae  del body el contenido que es un String y luego me lo muestra por consola.

Pues bien cuando coloco el código en android Studio a través de log.d  y debugeando el retorno es un String ilegible, llevo casi dos semanas estancado ¿Qué es lo que no veo o funciona en android? Debería pobrar con ansi  o unicode.

Dios quiera que me puedan mostrar el camino o hacerme ver un hilo por donde investigar porque ya no se por donde tirar como pueden apreciar lo que hago es parsear la html con openStream a un formato Iso y en netbeans me lo hace bien pero en android no me parsea.

Espero me comprendan o que alguien  este en onda con mi pregunta, gracias.


« Última modificación: Septiembre 22, 2015, 11:10:55 pm por Expermicid »
You are not allowed to view links. Register or Login

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Duda con " "

Iniciado por Krisium

Respuestas: 1
Vistas: 1649
Último mensaje Junio 10, 2010, 10:50:35 am
por Xa0s
[SOLUCIONADO] [Taller PHP] Duda taller php 2 ejercicio 3

Iniciado por arthusu

Respuestas: 4
Vistas: 2081
Último mensaje Agosto 05, 2011, 02:00:42 am
por arthusu
[SOLUCIONADO] [Taller PHP] Duda taller php 1 ejercicio 4

Iniciado por arthusu

Respuestas: 2
Vistas: 1521
Último mensaje Julio 18, 2011, 07:19:33 pm
por arthusu
[SOLUCIONADO][Taller PHP] Duda taller php 2 ejercicio 2

Iniciado por Only

Respuestas: 3
Vistas: 1868
Último mensaje Agosto 05, 2011, 09:48:09 pm
por Only
[SOLUCIONADO] Duda con Windows 7 de 32 bits & 64 bits

Iniciado por andrestoushit

Respuestas: 2
Vistas: 828
Último mensaje Marzo 15, 2016, 04:01:16 pm
por Lah-Vahn