comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Duda sobre el formato que recibo con Jsoup [java]

  • 0 Respuestas
  • 552 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Hu3c0

  • *
  • Underc0der
  • Mensajes: 434
  • Actividad:
    3.33%
  • Reputación 0
  • In the middle Netbeans
    • Ver Perfil
« en: Septiembre 22, 2015, 07:04:29 pm »
Algo me está entorpeciendo en mi avance será una chorrada pero no doy con lo que es intentaré ser lo más explicito que pueda.

Utilizo Jsoup para extraer un contenido de una api en su retorno :

Código: Java
  1. dochtml =  Jsoup.parse(new No tienes permisos para ver links. Registrate o Entra con tu cuenta(entradahtml).openStream(), "ISO-8859-1", entradahtml);
  2.          
  3.     Elements inhtml= dochtml.select("body");
  4.     No tienes permisos para ver links. Registrate o Entra con tu cuenta cadenaatratar = inhtml.text();
  5.     No tienes permisos para ver links. Registrate o Entra con tu cuenta.out.println(cadenaatratar.substring(3));
  6.      No tienes permisos para ver links. Registrate o Entra con tu cuenta.out.println(inhtml.text());

Este código en netbeans me funciona a la perfección me extrae  del body el contenido que es un String y luego me lo muestra por consola.

Pues bien cuando coloco el código en android Studio a través de log.d  y debugeando el retorno es un String ilegible, llevo casi dos semanas estancado ¿Qué es lo que no veo o funciona en android? Debería pobrar con ansi  o unicode.

Dios quiera que me puedan mostrar el camino o hacerme ver un hilo por donde investigar porque ya no se por donde tirar como pueden apreciar lo que hago es parsear la html con openStream a un formato Iso y en netbeans me lo hace bien pero en android no me parsea.

Espero me comprendan o que alguien  este en onda con mi pregunta, gracias.


« Última modificación: Septiembre 22, 2015, 11:10:55 pm por Expermicid »
No tienes permisos para ver links. Registrate o Entra con tu cuenta

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Duda con " "

Iniciado por Krisium

Respuestas: 1
Vistas: 1721
Último mensaje Junio 10, 2010, 10:50:35 am
por Xa0s
[SOLUCIONADO] [Taller PHP] Duda taller php 1 ejercicio 4

Iniciado por arthusu

Respuestas: 2
Vistas: 1634
Último mensaje Julio 18, 2011, 07:19:33 pm
por arthusu
[SOLUCIONADO][Taller PHP] Duda taller php 2 ejercicio 2

Iniciado por Only

Respuestas: 3
Vistas: 1935
Último mensaje Agosto 05, 2011, 09:48:09 pm
por Only
[SOLUCIONADO] Duda con Windows 7 de 32 bits & 64 bits

Iniciado por andrestoushit

Respuestas: 2
Vistas: 902
Último mensaje Marzo 15, 2016, 04:01:16 pm
por Lah-Vahn
[SOLUCIONADO] [Taller PHP] Duda taller php 1 ejercicio 2

Iniciado por arthusu

Respuestas: 3
Vistas: 1905
Último mensaje Julio 18, 2011, 02:20:03 am
por arthusu