This site uses cookies own and third. If you continue to browse consider to accept the use of cookies. OK More Info.

Acceso a red desde maquina virtual. No encuentra otras ip

  • 8 Replies
  • 5089 Views

0 Members and 3 Guests are viewing this topic.

Offline r4gnath0r

  • *
  • Underc0der
  • Posts: 88
  • Actividad:
    0%
  • Reputación 0
    • View Profile
Buenas a todos.
Estoy probando a hacerme un MITM para comprobar el funcionamiento del "arp-spoof". El caso es que quiero hacerlo desde una maquina virtual. Establezco en la configuración de la máquina, en el apartado RED que el adaptador sea modo puente. De esta forma, el router si que le asigna una ip, puesto que tiene una ip del tio 192.168.1.xxx. El problema está en que cuando trato de hacer un nmap, solo encuentra el router (y tengo 6 dispositivos conectados a la red).
He probado todas las configuraciones posibles de red en la maquina virtual y sigue igual.

Datos:
Anfitrión: Windows 10
Maquina Virtual: VirtualBox - Lubuntu (he probado tambien con Xubuntu, Ubuntu, Kali Linux, Bugtraq, backtrack, backbox...)

¿ALguna sugerencia de qué debo cambiar?

Gracias de antemano.
« Last Edit: December 30, 2015, 01:18:09 pm by Gabriela »

Offline rush

  • *
  • Underc0der
  • Posts: 380
  • Actividad:
    0%
  • Reputación 7
    • View Profile
Prueba hacer ping a la maquina que estas hosteando, si hacen ping entonces todo es correcto, lo que podrias descartar el error de red e irte directamente a nmap
You are not allowed to view links. Register or Login


Offline Stiuvert

  • *
  • Ex-Staff
  • *****
  • Posts: 2650
  • Actividad:
    0%
  • Reputación 15
  • Twitter: @Stiuvert
    • View Profile
No estaría mal hacer el ping y luego tipea este comando a ver que te aparece:

Code: (bash) You are not allowed to view links. Register or Login
sudo nmap -sP 192.168.1.1-254
Saludos

Offline v4char

  • *
  • Underc0der
  • Posts: 42
  • Actividad:
    0%
  • Reputación 0
  • Let's Learn
  • Twitter: v4char
    • View Profile
    • Email
Prueba a poner la maquina virtual como puente de tu adaptador red y luego prueba con un netdiscover

Offline tetano32

  • *
  • Underc0der
  • Posts: 23
  • Actividad:
    0%
  • Reputación 0
    • View Profile
Has puesto la máquina virtual en modo promiscuo? En virtualbox es en Red, poner "adaptador puente", luego la das a "avanzadas" y en "modo promiscuo: Permitir todo"

Offline .:UND3R:.

  • *
  • Underc0der
  • Posts: 226
  • Actividad:
    0%
  • Reputación 0
    • View Profile
Debes poner la máquina virtual con tipo de conexión en puente, saludos.

Offline r4gnath0r

  • *
  • Underc0der
  • Posts: 88
  • Actividad:
    0%
  • Reputación 0
    • View Profile
Buenas a todos. Como comenté, había probado todas las configuraciones posibles del apartado de red de virtualbox. Aún así he vuelto a intentarlo, poniéndolo de nuevo en adaptador puente y no consigo que haga ping, y con nmap solo encuentra el router, la maquina virtual y el ordenador anfitrion.

Acabo de probar el comando arp -n y si que detecta la maquina que quiero escanear. Sin embargo, nmap sigue sin encontrarla.
« Last Edit: January 03, 2016, 12:24:24 am by EPSILON »

Offline Snifer

  • *
  • Ex-Staff
  • *****
  • Posts: 1439
  • Actividad:
    0%
  • Reputación 1
  • [email protected]'s
  • Twitter: sniferl4bs
    • View Profile
    • Snifer@L4bs
Para validar, por si acaso el firewall o algun av que ande jorobando en las configuraciones, por que la configuración deberia ser rapida y facil.

Regards
Snifer
You are not allowed to view links. Register or Login


Llaman traidor a la persona que evito que caiga el foro, gente bruta!



Offline Stiuvert

  • *
  • Ex-Staff
  • *****
  • Posts: 2650
  • Actividad:
    0%
  • Reputación 15
  • Twitter: @Stiuvert
    • View Profile
Desactiva el firewall y después prueba de nuevo hacer ping.

Saludos