comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[SOLUCIONADO] Problema con Sitio Web

  • 8 Respuestas
  • 4091 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado RandomSoft

  • *
  • Underc0der
  • Mensajes: 127
  • Actividad:
    1.67%
  • Reputación 0
  • using Underc0de;
    • Ver Perfil
    • Marketing Online | Diseño Web | Hosting Profesional - GlobalPer
    • Email
  • Skype: randomsofthack
« en: Octubre 10, 2013, 01:03:00 pm »
Saludos amigos, después de mucho tiempo regresando por un pequeño problemita, ando modificando un sitio web y me muestra el siguiente mensaje de error:

Citar
Es posible que esta pagina web no funcione correctamente debido a errores.

Llamada inesperada a un método o a un acceso de propiedad
httpErrorPagesScripts.js                                          Línea: 264      Carácter: 5
Código: 0
URI: res://ieframe.dll/httpErrorPagesScripts.js

quisiera saber si es problema del mal uso de JavaScript o de las Clases y funciones usadas con PHP?
esto solo sucede en Internet Explore 8 o inferior
gracias de ante mano.
« Última modificación: Junio 10, 2014, 08:20:10 am por Expermicid »
El Lenguaje es la Ciudad para cuya Edificación cada Ser Humano ha Aportado una Piedra

Desconectado alexander1712

  • *
  • Underc0der
  • Mensajes: 850
  • Actividad:
    0%
  • Reputación -2
    • Ver Perfil
    • El blog del programador
    • Email
« Respuesta #1 en: Octubre 10, 2013, 10:56:02 pm »
No tienes permisos para ver links. Registrate o Entra con tu cuenta
Saludos amigos, después de mucho tiempo regresando por un pequeño problemita, ando modificando un sitio web y me muestra el siguiente mensaje de error:

Citar
Es posible que esta pagina web no funcione correctamente debido a errores.

Llamada inesperada a un método o a un acceso de propiedad
httpErrorPagesScripts.js                                          Línea: 264      Carácter: 5
Código: 0
URI: res://ieframe.dll/httpErrorPagesScripts.js

quisiera saber si es problema del mal uso de JavaScript o de las Clases y funciones usadas con PHP?
esto solo sucede en Internet Explore 8 o inferior
gracias de ante mano.

uhm, usas internet explorer, ese es el problema.

internet explorer 8 no soporta lo que quieres hacer con javascript, no no puede ser por php (se ejecuta del lado del servidor, ni si quiera si el servidor estubiera "borracho" o se ubiese tomado una botella de wisky podría ser la causa php).

Como dije probablemente Internet Explorer 8 tenga un problema o no soporte lo que el javascript de esa página está tratando de hacer.

esas son una de las múltiples razones por las cuales internet explorer es una porquería.

Además fijate, los que usan chrome solo usan la última versión, no ves a nadie usando versiones mas viejas, y los que usan firefox usan versiones relativamente nuevas, es muy raro ver a una persona usar firefox 2.4 o firefox 4, sin embargo en internet explorer hay personas usando internet explorer 6 ._. es una desgracia, por eso yo no le doy soporte a IE.

saludos!

Desconectado RandomSoft

  • *
  • Underc0der
  • Mensajes: 127
  • Actividad:
    1.67%
  • Reputación 0
  • using Underc0de;
    • Ver Perfil
    • Marketing Online | Diseño Web | Hosting Profesional - GlobalPer
    • Email
  • Skype: randomsofthack
« Respuesta #2 en: Octubre 10, 2013, 11:25:05 pm »
Saludos brother, gracias por tu respuesta, pero creo que uno como diseñador y programador tiene que tomar encuenta hasta el más minimo detalle, para el buen funcionamiento del producto, como dijiste, hoy en dia sigue habiendo personas que usan versiones antiguas de esos navegadores y uno tiene que incluir esos detalle en un proyecto.
El Lenguaje es la Ciudad para cuya Edificación cada Ser Humano ha Aportado una Piedra

Desconectado alexander1712

  • *
  • Underc0der
  • Mensajes: 850
  • Actividad:
    0%
  • Reputación -2
    • Ver Perfil
    • El blog del programador
    • Email
« Respuesta #3 en: Octubre 10, 2013, 11:49:55 pm »
No tienes permisos para ver links. Registrate o Entra con tu cuenta
Saludos brother, gracias por tu respuesta, pero creo que uno como diseñador y programador tiene que tomar encuenta hasta el más minimo detalle, para el buen funcionamiento del producto, como dijiste, hoy en dia sigue habiendo personas que usan versiones antiguas de esos navegadores y uno tiene que incluir esos detalle en un proyecto.

es cierto que uno tiene que tomar en concideración ciertas cosas.

pero mi lema es simple, hacer algo tiene un costo y un beneficio, uno tiene que hacer solo las cosas que generan más beneficio que costo.

volviendo al tema, no puedes dar soporte para Internet Explorer 2.0 porque haya una persona que lo use, la idea es dar soporte a la normativa vigente, hoy en día para el diseño web la W3C establece las reglas, y cualquiera que quiera jugar el juego tiene que entender, que no se puede saltear las reglas, tanto Google Chrome, como Mozilla Software Fundation, y Microsoft saben muy bien que la W3C es la que pone las reglas, dice como son las cosas, microsoft en su momento no le hizo caso, y bueno las consecuencias son obvias, si no se quieren amoldar a los estándares no se puede hacer nada, ahora microsoft lo entendió y está trabajando para que sus nuevas versiones cumplan los estándares.

El punto es, que si una comunidad entera aceptó que un consorcio (la W3C) se pusiera de acuerdo entre los mayores referentes de la industria para hacer las cosas de una manera, no puede venir alguien y hacer las cosas a su manera dejando 3 mil incompatibilidades, y los desarrolladores no pueden estar trabajando para cumplir todo lo que se le ocurre a cualquiera, porque en ese caso si yo programara un motor de renderizado y decidiera que las etiquetas div no me gustan y las voy a llamar roberto, los desarrolladores no pueden estar creando etiquetas div y roberto, yo tengo que amoldarme a los estándares, y lo mismo va para microsoft.

El problema de incompatibilidad de Internet explorer, es bastante jodido porque hacen lo que quieren prácticamente, pensaron que ya tenían ganado el mercado de los navegadores web xD y que podían hacer lo que se les ocurriera.

a todo esto lo que quiero decir es que tienes que fijarte si vale la pena hacer las páginas compatibles para aquellos que usan internet explorer 6.-

en fin es desición tuya y no voy a insistir, sobre tu problema ya sabes que es, y no tengo idea si se puede solucionar xD

saludos!

Desconectado RandomSoft

  • *
  • Underc0der
  • Mensajes: 127
  • Actividad:
    1.67%
  • Reputación 0
  • using Underc0de;
    • Ver Perfil
    • Marketing Online | Diseño Web | Hosting Profesional - GlobalPer
    • Email
  • Skype: randomsofthack
« Respuesta #4 en: Octubre 12, 2013, 01:54:43 pm »
Buen punto brother, gracias por tu respuesta, lo tomaré en cuenta, pero me gustaría saber con mas exactitud si el problema es mal uso de javascript o el navegador, pero teniendo en cuenta que la programación de javascript está mal Internet Explore te muestra detalles del error y los otros navegadores no lo hacen.
El Lenguaje es la Ciudad para cuya Edificación cada Ser Humano ha Aportado una Piedra

Desconectado Destructor.cs

  • *
  • Underc0der
  • Mensajes: 68
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #5 en: Octubre 12, 2013, 02:03:55 pm »
Apoyando a la idea de Harkonnen, no puedes limitar tu proyecto porque algunos users sigan usando versiones desactualizadas
Lo mejor para el caso es crear una especie de alerta cada vez que el visitante entre con un navegador que tenga problemas con tu web y recomendarle descargarse otro navegador o actualizarlo!

Saludos
Destructor

Desconectado WHK

  • *
  • Underc0der
  • Mensajes: 68
  • Actividad:
    0%
  • Reputación 3
  • 吴阿卡
    • Ver Perfil
    • WHK
« Respuesta #6 en: Octubre 15, 2013, 02:18:14 pm »
Ese mensaje de error es producto de que tu internet explorer está corrupto, talves por algún plugin o complemento, no tiene nada que ver el sitio WEB.
Intenta usar una maquina virtual y ahi ponle internet explorer 8.

Te recomiendo que no programes para ie8 porque incluso Microsoft desaconseja su uso por su obsolencia tanto en estandares como en rendimiento.

Vamos, no te quedes en el pasado, me recuerdas a esos viejos que trabajan armando computadores con pentium 2 y 128mb de ram para los locales de ventas de abarrotes y reparando computadores con un 486.

Desconectado alexander1712

  • *
  • Underc0der
  • Mensajes: 850
  • Actividad:
    0%
  • Reputación -2
    • Ver Perfil
    • El blog del programador
    • Email
« Respuesta #7 en: Octubre 16, 2013, 03:16:59 pm »
No tienes permisos para ver links. Registrate o Entra con tu cuenta
Vamos, no te quedes en el pasado, me recuerdas a esos viejos que trabajan armando computadores con pentium 2 y 128mb de ram para los locales de ventas de abarrotes y reparando computadores con un 486.

uhm no vi a nadie reparando una pc con un 486 pero si con un K-6 o un K-62 (no recuerdo cual de los dos era) xD

buen ejemplo jajaja

saludos!

Desconectado RandomSoft

  • *
  • Underc0der
  • Mensajes: 127
  • Actividad:
    1.67%
  • Reputación 0
  • using Underc0de;
    • Ver Perfil
    • Marketing Online | Diseño Web | Hosting Profesional - GlobalPer
    • Email
  • Skype: randomsofthack
« Respuesta #8 en: Mayo 29, 2014, 05:51:04 pm »
El problema lo solucione hace mucho, y era un archivo javascript el cual mostraba ese error debido a la falta de internet, cada que estaba online no mostraba el error, caso que offline si lo hacía, gracias por sus respuestas, pueden cerrar el tema?, por favor

Enviado desde mi C1504 mediante Tapatalk

El Lenguaje es la Ciudad para cuya Edificación cada Ser Humano ha Aportado una Piedra

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] ¿Kali Linux o Kali Linux Ligth ?

Iniciado por worq

Respuestas: 2
Vistas: 7697
Último mensaje Noviembre 21, 2017, 12:28:54 pm
por Codig0Bit
[SOLUCIONADO] ¿Como publicar un software como software libre?

Iniciado por FuriosoJack

Respuestas: 2
Vistas: 1644
Último mensaje Mayo 23, 2017, 07:24:22 am
por HATI
[SOLUCIONADO] Multiuploader de imagenes con mysql, hosting de imagenes con mysql

Iniciado por graphixx

Respuestas: 4
Vistas: 2235
Último mensaje Marzo 26, 2013, 05:42:58 pm
por Xt3mP
[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 3012
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Ayuda urgente con Virus "Virus.Win32Sality"

Iniciado por Napsters

Respuestas: 6
Vistas: 3484
Último mensaje Junio 11, 2012, 03:38:18 am
por Satyricon