comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[SOLUCIONADO] Problema al crear un expoit, y windbg

  • 3 Respuestas
  • 1731 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado stakewinner00

  • *
  • Underc0der
  • Mensajes: 31
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« en: Febrero 05, 2013, 06:10:14 pm »
Hace poco comencé a practicar con eso de escritura de exploits y me encontré que cuando quiero deshabilitar windbg no lo puedo deshabilitar, por internet encontré que tenia que modificar los registros, pero ya he intentado todo lo k podía intentar en los registros y no se que más puedo hacer.

Otra cosa que me pasaba era que cada vez que encendía el pc el valor del addres "734eadc5" (nose si se llamava tambíen offset) para que saltar al esp (JMP ESP) varia y por lo tanto cada vez que inicio el pc tengo que modificar el exploit.

Muchas gracias por todo.

PD:Aun no pude explotar el típico EasyRMtoMP3Conv, pero como uso windows 8 creo que puede que la shellcode no me acabe de funcionar, recomendaríais instalar una maquina virtual con XP?
« Última modificación: Septiembre 18, 2014, 08:56:17 pm por Expermicid »

Desconectado stakewinner00

  • *
  • Underc0der
  • Mensajes: 31
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #1 en: Febrero 06, 2013, 03:45:29 am »
Ok, muchas gracias, no sabia eso el random de direcciones.

PD:Sabes como puedo desactivar windbg? He tocado el registro y nada.

Desconectado stakewinner00

  • *
  • Underc0der
  • Mensajes: 31
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #2 en: Febrero 06, 2013, 11:12:52 am »
Si las DLL's del programa si que se cambian cada vez qui inicio el pc pero las de system no así que lo que hice fue usar una de system, por mucho que no lo recomiendan, y como es lógico tuve problemas.

Bueno, ya buscare que es eso de ASLR y me pondré con una maquina virtual con XP.

Muchas gracias por todo.

PD: como mínimo aquí me responden, que del foro que yo vengo llevo unos días y nadie respondió. Parece un buen foro.

Desconectado stakewinner00

  • *
  • Underc0der
  • Mensajes: 31
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #3 en: Febrero 07, 2013, 01:05:15 pm »
Mucahs gracias por todo, buscando por ADSLR ya encontre un programa que permite desactivar este sistema y el DEP.

PD:Probe el programa y no me va.

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] ¿Kali Linux o Kali Linux Ligth ?

Iniciado por worq

Respuestas: 2
Vistas: 6275
Último mensaje Noviembre 21, 2017, 12:28:54 pm
por Codig0Bit
[SOLUCIONADO] ¿Como publicar un software como software libre?

Iniciado por FuriosoJack

Respuestas: 2
Vistas: 1535
Último mensaje Mayo 23, 2017, 07:24:22 am
por HATI
[SOLUCIONADO] Multiuploader de imagenes con mysql, hosting de imagenes con mysql

Iniciado por graphixx

Respuestas: 4
Vistas: 2128
Último mensaje Marzo 26, 2013, 05:42:58 pm
por Xt3mP
[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 2673
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Ayuda urgente con Virus "Virus.Win32Sality"

Iniciado por Napsters

Respuestas: 6
Vistas: 3341
Último mensaje Junio 11, 2012, 03:38:18 am
por Satyricon