comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[SOLUCIONADO] No puedo instalar Subterfuge en Kali Linux 2.0

  • 8 Respuestas
  • 2709 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Blest777

  • *
  • Underc0der
  • Mensajes: 63
  • Actividad:
    0%
  • Reputación 0
  • Todo es vanidad.
    • Ver Perfil
« en: Enero 22, 2016, 11:51:49 pm »
Buenas

Estoy tratando de instalar subterfuge_1.0-1_all.deb siguiendo los pasos de este video:


Cuando le doy al comando  subterfuge no me aparece la IP para ponerla en el navegador y usarlo. Me sale esto:

Código: Text
  1. root@kali:~/Desktop# dpkg -i subterfuge_1.0-1_all.deb
  2. (Reading database ... 334471 files and directories currently installed.)
  3. Preparing to unpack subterfuge_1.0-1_all.deb ...
  4. Unpacking subterfuge (1.0-1) over (1.0-1) ...
  5. Setting up subterfuge (1.0-1) ...
  6.  
  7.  
  8.  
  9. root@kal:~/Desktop# subterfuge
  10. Traceback (most recent call last):
  11.   File "/bin/subterfuge", line 25, in <module>
  12.     from main.models import *
  13.   File "/usr/share/subterfuge/main/models.py", line 3, in <module>
  14.     class credentials(models.Model):
  15.   File "/usr/lib/python2.7/dist-packages/django/db/models/base.py", line 94, in __new__
  16.     app_config = apps.get_containing_app_config(module)
  17.   File "/usr/lib/python2.7/dist-packages/django/apps/registry.py", line 239, in get_containing_app_config
  18.     self.check_apps_ready()
  19.   File "/usr/lib/python2.7/dist-packages/django/apps/registry.py", line 124, in check_apps_ready
  20.     raise AppRegistryNotReady("Apps aren't loaded yet.")
  21. django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.
  22.  
  23.  
  24.  
  25. root@kali:~/Desktop# subterfuge
  26. Traceback (most recent call last):
  27.   File "/bin/subterfuge", line 25, in <module>
  28.     from main.models import *
  29.   File "/usr/share/subterfuge/main/models.py", line 3, in <module>
  30.     class credentials(models.Model):
  31.   File "/usr/lib/python2.7/dist-packages/django/db/models/base.py", line 94, in __new__
  32.     app_config = apps.get_containing_app_config(module)
  33.   File "/usr/lib/python2.7/dist-packages/django/apps/registry.py", line 239, in get_containing_app_config
  34.     self.check_apps_ready()
  35.   File "/usr/lib/python2.7/dist-packages/django/apps/registry.py", line 124, in check_apps_ready
  36.     raise AppRegistryNotReady("Apps aren't loaded yet.")
  37. django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.
  38.  

Alguien sabe explicarme paso por paso como solucionar este problema?
Gracias de antemano.


« Última modificación: Febrero 21, 2016, 06:53:53 am por Stiuvert »
... De las piedras y el aire no proviene el concepto de lo que es bueno y lo que es malo, de la no vida no puede surgir vida.

Desconectado Sur07

  • *
  • Underc0der
  • Mensajes: 8
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #1 en: Febrero 14, 2016, 02:01:59 pm »
Hola, tengo el mismo problema, lo has resuelto por favor?

Desconectado Stuxnet

  • *
  • Underc0der
  • Mensajes: 259
  • Actividad:
    0%
  • Reputación 2
    • Ver Perfil
    • Devel Security
  • Twitter: _stuxnet
« Respuesta #2 en: Febrero 14, 2016, 04:04:53 pm »
git clone https://github.com/Subterfuge-Framework/Subterfuge.git
cd Subterfuge
python setup.py

Desconectado EPSILON

  • *
  • Underc0der
  • Mensajes: 364
  • Actividad:
    0%
  • Reputación 0
  • epsilon@crypt.am
    • Ver Perfil
  • Skype: epsilon.root1
« Respuesta #3 en: Febrero 14, 2016, 05:45:08 pm »
Lo que comento @Stuxnet funciona a la perfección, debería funcionarte si o si. Lógicamente tienes que tener instalado git.

Saludos!, EPSILON

Desconectado Blest777

  • *
  • Underc0der
  • Mensajes: 63
  • Actividad:
    0%
  • Reputación 0
  • Todo es vanidad.
    • Ver Perfil
« Respuesta #4 en: Febrero 14, 2016, 08:08:51 pm »
Mi problema era que no tenia instalado los respositorios necesarios.
... De las piedras y el aire no proviene el concepto de lo que es bueno y lo que es malo, de la no vida no puede surgir vida.

Desconectado blackdrake

  • *
  • Co Admin
  • Mensajes: 1914
  • Actividad:
    0%
  • Reputación 15
    • Ver Perfil
« Respuesta #5 en: Febrero 15, 2016, 07:21:38 am »
Mi problema era que no tenia instalado los respositorios necesarios.

Solucionado entonces @Blest777?

Saludos.



Desconectado ellococareloco

  • *
  • Underc0der
  • Mensajes: 3
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #6 en: Julio 12, 2016, 12:39:34 pm »
se que revivo un Post solucionado.. pero si publicaran como se soluciono seria mejor para todos los que tengamos este problemas.
Saludos

Desconectado EPSILON

  • *
  • Underc0der
  • Mensajes: 364
  • Actividad:
    0%
  • Reputación 0
  • epsilon@crypt.am
    • Ver Perfil
  • Skype: epsilon.root1
« Respuesta #7 en: Julio 23, 2016, 12:37:45 am »
@ellococareloco no hay problema en revivir una pregunta vieja puesto que tienes la misma o similar, en el mismo esta todo para poder correr Subterfuge, con los repositorios correctamente instalados y actualizados sigues los pasos que detalla Stuxnet y listo.

Saludos!, EPSILON.

Desconectado gaston92.rc

  • *
  • Underc0der
  • Mensajes: 1
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #8 en: Marzo 17, 2017, 09:18:04 pm »
Yo estoy en con el mismo problema, ya hice todo lo que dijeron. Lo actualizaron en github y no tiene las mismas funciones. Pero baje la version 4.2 y funciono perfecto, despues instale la version 5.0 y ya me tiro el error.
Traceback (most recent call last):
  File "/bin/subterfuge", line 6, in <module>
    from versioninfo import *
ImportError: No module named versioninfo
Si alguien sabe como solucionarlo. Gracias

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] Multiuploader de imagenes con mysql, hosting de imagenes con mysql

Iniciado por graphixx

Respuestas: 4
Vistas: 2298
Último mensaje Marzo 26, 2013, 05:42:58 pm
por Xt3mP
[SOLUCIONADO] ¿Como publicar un software como software libre?

Iniciado por FuriosoJack

Respuestas: 2
Vistas: 1717
Último mensaje Mayo 23, 2017, 07:24:22 am
por HATI
[SOLUCIONADO] Ayuda urgente con Virus "Virus.Win32Sality"

Iniciado por Napsters

Respuestas: 6
Vistas: 3569
Último mensaje Junio 11, 2012, 03:38:18 am
por Satyricon
[SOLUCIONADO] "¿Se puede?"

Iniciado por Banfek

Respuestas: 11
Vistas: 3809
Último mensaje Febrero 14, 2014, 02:42:02 pm
por Devilboy
[SOLUCIONADO] Duda con " "

Iniciado por Krisium

Respuestas: 1
Vistas: 1803
Último mensaje Junio 10, 2010, 10:50:35 am
por Xa0s