comment
IRC Chat
play_arrow
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

[SOLUCIONADO] Error sslstrip

  • 6 Respuestas
  • 3356 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado 0tak4

  • *
  • Underc0der
  • Mensajes: 43
  • Actividad:
    0%
  • Reputación 0
  • #hackinon
    • Ver Perfil
    • Email
« en: Agosto 25, 2013, 03:08:22 am »
hola tengo instalado python3.3 pero el ssltrip me vota este error :(

sslstrip
Traceback (most recent call last):
  File "/usr/bin/sslstrip", line 30, in <module>
    from sslstrip.StrippingProxy import StrippingProxy
  File "/usr/share/sslstrip/sslstrip/StrippingProxy.py", line 20, in <module>
    from ClientRequest import ClientRequest
  File "/usr/share/sslstrip/sslstrip/ClientRequest.py", line 25, in <module>
    from twisted.internet import ssl
  File "/usr/lib/python2.7/dist-packages/twisted/internet/ssl.py", line 23, in <module>
    from OpenSSL import SSL
  File "/usr/local/lib/python2.7/dist-packages/OpenSSL/__init__.py", line 40, in <module>
    from OpenSSL import crypto
ImportError: cannot import name crypto

« Última modificación: Agosto 27, 2014, 09:00:01 pm por Expermicid »

Desconectado Once

  • *
  • Underc0der
  • Mensajes: 391
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • El blog de Once
  • Twitter: @don_once
« Respuesta #1 en: Agosto 25, 2013, 03:47:12 am »
Código: No tienes permisos para ver links. Registrate o Entra con tu cuenta
ImportError: cannot import name crypto
Te falta el módulo crypto, mira si está para Python 3 si no, usa Python 2.7

Saludos!






No tienes permisos para ver links. Registrate o Entra con tu cuenta

Desconectado 0tak4

  • *
  • Underc0der
  • Mensajes: 43
  • Actividad:
    0%
  • Reputación 0
  • #hackinon
    • Ver Perfil
    • Email
« Respuesta #2 en: Agosto 25, 2013, 03:16:11 pm »
no sabes los comandos de consola para instalar ese modulo por favor

Desconectado Once

  • *
  • Underc0der
  • Mensajes: 391
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • El blog de Once
  • Twitter: @don_once
« Respuesta #3 en: Agosto 25, 2013, 04:32:37 pm »
Acabo de revisar y parece que la única dependencia que pide sslstrip es python-twisted-web, mia si está en los repositorios de tu distro o lo puedes descargar de acá: No tienes permisos para ver links. Registrate o Entra con tu cuenta

Saludos!






No tienes permisos para ver links. Registrate o Entra con tu cuenta

Desconectado 0tak4

  • *
  • Underc0der
  • Mensajes: 43
  • Actividad:
    0%
  • Reputación 0
  • #hackinon
    • Ver Perfil
    • Email
« Respuesta #4 en: Agosto 25, 2013, 08:18:43 pm »
ya reinstale el ssltrip, python-crypto, python-twisted-web, y tengo el mismo error. Creo que el error es que lo lee con python2.7 y no lo puede importar, no se como decirle que lea con otra versión de python, gracias por responder :)

 aptitude reinstall  python-twisted-web
The following packages will be REINSTALLED:
  python-twisted-web
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/433 kB of archives. After unpacking 0 B will be used.
(Reading database ... 259470 files and directories currently installed.)
Preparing to replace python-twisted-web 11.1.0-1 (using .../python-twisted-web_11.1.0-1_all.deb) ...
Unpacking replacement python-twisted-web ...
Setting up python-twisted-web (11.1.0-1) ...


apt-get build-dep ssltrip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to find a source package for ssltrip
root@ubuntu:~# apt-get build-dep sslstrip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
« Última modificación: Agosto 25, 2013, 08:25:01 pm por 0tak4 »

Desconectado Once

  • *
  • Underc0der
  • Mensajes: 391
  • Actividad:
    0%
  • Reputación 0
    • Ver Perfil
    • El blog de Once
  • Twitter: @don_once
« Respuesta #5 en: Agosto 25, 2013, 09:36:55 pm »
Usa Python 2.7

Saludos!






No tienes permisos para ver links. Registrate o Entra con tu cuenta

Desconectado 0tak4

  • *
  • Underc0der
  • Mensajes: 43
  • Actividad:
    0%
  • Reputación 0
  • #hackinon
    • Ver Perfil
    • Email
« Respuesta #6 en: Agosto 25, 2013, 10:49:37 pm »
esta con python 2.7 lo he dejado por defecto :)

 

¿Te gustó el post? COMPARTILO!



[SOLUCIONADO] ¿Kali Linux o Kali Linux Ligth ?

Iniciado por worq

Respuestas: 2
Vistas: 7799
Último mensaje Noviembre 21, 2017, 12:28:54 pm
por Codig0Bit
[SOLUCIONADO] Multiuploader de imagenes con mysql, hosting de imagenes con mysql

Iniciado por graphixx

Respuestas: 4
Vistas: 2238
Último mensaje Marzo 26, 2013, 05:42:58 pm
por Xt3mP
[SOLUCIONADO] ¿Como publicar un software como software libre?

Iniciado por FuriosoJack

Respuestas: 2
Vistas: 1655
Último mensaje Mayo 23, 2017, 07:24:22 am
por HATI
[SOLUCIONADO] Linux Mint, errores, errores y mas errores...

Iniciado por n1sendev

Respuestas: 12
Vistas: 3047
Último mensaje Noviembre 22, 2017, 06:50:55 am
por RuidosoBSD
[SOLUCIONADO] Problem al instalar Windows "cualquier windows"

Iniciado por Made

Respuestas: 7
Vistas: 3052
Último mensaje Septiembre 03, 2012, 04:53:08 pm
por Made